Windows 10 goes to sleep outside listed sleep times



  • I've had a user who's computer has been going to sleep after approx 2 mins, instead of 15 as the power and sleep applet says.

    I've made registry changes, wiped the profile, hell - even rebuilt the machine. Nothing worked. The problem has continued to return.

    Well, back to google this morning, with what must have been a new search and found this.
    https://superuser.com/questions/1019043/windows-10-sleeps-before-set-time
    Which pointed to this > https://www.sevenforums.com/tutorials/246364-power-options-add-system-unattended-sleep-timeout.html

    This gist of which is that there is a hidden option that can be made viewable by a registry change.

     Windows Registry Editor Version 5.00
     
     ; Created by: Shawn Brink
     ; http://www.sevenforums.com
     ; Tutorial: http://www.sevenforums.com/tutorials/246364-power-options-add-system-  unattended-sleep-timeout.html
     
    
     [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0]
     "Attributes"=dword:00000002
    

    While this setting should only affect windows if the computer isn't used after it's woken from sleep mode, it seems to activate regardless of use or not in some cases.

    I'm testing it with my two users now.



  • @dashrender Thanks that is interesting. I've encountered that a few times but not often. Had no idea why it showed up a little and not all the time.



  • @jmoore said in Windows 10 goes to sleep outside listed sleep times:

    @dashrender Thanks that is interesting. I've encountered that a few times but not often. Had no idea why it showed up a little and not all the time.

    This is the most frustrating part - I have 100 PCs, but only two people complaining about the problem. The second one is only today. It's likely/possible that others just aren't reporting it.

    The problem also temporarily goes away when you reboot. It only happens (the system going into sleep after 2 mins of inactivity) after the system goes into sleep mode following the listed times (in my case 15 mins). I.e. the user goes to lunch or leaves desk for a while, returns, they wake it up, now it will go to sleep after 2 mins of inactivity. but if they reboot, it's fine, until it goes back to sleep after 15 mins of inactivity.



  • The main user who was having this issue is now reporting that the problem seems to be resolved.

    While I'm sure it's overkill, I need to find the actual registry entry that's changed when the setting is modified, not just the setting that makes the the option appear in the control panel applet. Then deploy it via GPO - just squash this bug!



  • @dashrender Yeah good idea. I've experimented with setting these people to the High Performance power setting. So far no one has complained but its not enough time yet to know anything definitive yet.



  • The issue only appears after the computer goes into sleep mode. If your high performance option basically killed sleep mode, then it's no wonder they have no issues.



  • @Dashrender : I literally JUST went through this with a client. All GPO's configured to monitor sleep & lock after 15 minutes which, after a fresh reboot, was stable.
    Once the monitor went to sleep and was wakened, the systems would go to full sleep every 2 minutes.
    I had to apply the same registry "hack" via GPO.

    This was extremely annoying to the staff and made us look pretty incompetent as the control panel, powercfg.exe, etc all showed that the settings were being applied properly.

    Ugh..



  • @manxam said in Windows 10 goes to sleep outside listed sleep times:

    @Dashrender : I literally JUST went through this with a client. All GPO's configured to monitor sleep & lock after 15 minutes which, after a fresh reboot, was stable.
    Once the monitor went to sleep and was wakened, the systems would go to full sleep every 2 minutes.
    I had to apply the same registry "hack" via GPO.

    This was extremely annoying to the staff and made us look pretty incompetent as the control panel, powercfg.exe, etc all showed that the settings were being applied properly.

    Ugh..

    Yeah the hidden setting is just dumb!!



  • @manxam said in Windows 10 goes to sleep outside listed sleep times:

    @Dashrender : I literally JUST went through this with a client. All GPO's configured to monitor sleep & lock after 15 minutes which, after a fresh reboot, was stable.
    Once the monitor went to sleep and was wakened, the systems would go to full sleep every 2 minutes.
    I had to apply the same registry "hack" via GPO.

    This was extremely annoying to the staff and made us look pretty incompetent as the control panel, powercfg.exe, etc all showed that the settings were being applied properly.

    Ugh..

    Hey
    @manxam enabling this via GPO only makes the setting visible. Did your users then have to manually set it?

    I'm trying to find a way to set the actual setting to a value using GPO - did you find one?



  • I think I've figured it out.

    The dwords need to be replaced with the hex value you want for the auto sleep after wakeup with no user interaction to kick in.
    The value set in my example is 120 mins.

    The three different sections are for

     [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0]
     "Attributes"=dword:00000002
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues\381b4222-f694-41f0-9685-ff5bb260df2e]
    "AcSettingIndex"=dword:00000078
    "DcSettingIndex"=dword:00000078
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues\8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c]
    "AcSettingIndex"=dword:00000078
    "DcSettingIndex"=dword:00000078
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues\a1841308-3541-4fab-bc81-f71556f20b4a]
    "AcSettingIndex"=dword:00000078
    "DcSettingIndex"=dword:00000078
    
    


  • Sigh - these registry settings don't fix the issue.

    And I'm starting to get more users complaining about this issue.

    So far I only seem to be able to fix it manually via the GUI.



  • I figure I owe an update here.

    These reg entries are in hex... 00000078 = 120 in decimal. i.e. 2 mins.. sigh I completely over looked this. No wonder the times weren't changing.