Can you downgrade Yealink EHS36 firmware

  • I have a Yealink T42G + EHS36 + Plantronics CS540 headset.

    It has worked fine for a month.

    Today I updated the firmware on the T42G and now the headset no longer answers calls as it used to. I have revert my T42G to 3 versions of firmware all with no luck at fixing the problem. That is when I hit Google and found out about the EHS36 having firmware.

    Prior to today, when a call rang in, I would touch the button on the headset, and it would go online and the call would answer. Or if I wanted to make a call, I would simply hit the speed dial or BLF button and the phone would initiate the call and the headset would come on.

    Now, the headset never comes on by itself when I initiate a call, nor does the phone answer when I push the button on the headset after a call rings in.

    Not knowing about the firmware upgrades for the EHS36 before now, I had never checked what version mine currently was before.

    Now, my EHS36 is on firmware

    I dug out a T38G and set it to an older version of firmware that was specified as the version to be used to upgrade an EHS36 to version Unfortunately, it seems that it is not possible to downgrade as it always states update failed when I follow the update process.

    I posted a thread on the Yealink community, but as they are a Chinese based company, most official answers won't come for a few hours.

  • While readying your thread I saw this below:

    EHS36 and T42G

  • Wait - you might have already done that...

    ETA: yup,.. looks like you have already done that..

  • Ok, I resolved this problem by reverting back to As soon as the phone finished booting with the firmware, I heard the CS540 base click active. I pushed the button on the headset to deactivate it and I knew it was going to work before i even picked it up to test.

    This does not explain why the EHS previously worked with

    After confirming everything working correctly, I upgraded to The headset no longer worked correctly. I downgraded back to and it worked correctly again.

    This is a problem with the new firmware for the phone and obviously not a problem with the EHS firmware.

    Email sent to yealink support. Hopefully this will be resolved in future firmware.