Kimchi VM Guest Console Timeout Issue



  • Between Cockpit and Kimchi, I was able to get this far in a few minutes, from a fresh install:

    0_1500048953722_Untitled.jpg

    When you click on the "Livetile" it opens up a new tab for the VM Console. Except it times out. Online information on this aspect is pretty much non-existent between a few quick Bing and Google searches.

    Has anyone had this issue or been able to get the vm console working on Kimchi? The host is Fed25.

    TEST is using VNC
    TEST2 is using SPICE
    ...if that helps, both timeout after trying to connect.



  • Check that the KVM host iptables rules allow ports required for Spice and VNC from your subnet?



  • @tim_g said in Kimchi VM Guest Console Timeout Issue:

    Between Cockpit and Kimchi, I was able to get this far in a few minutes, from a fresh install:

    0_1500048953722_Untitled.jpg

    When you click on the "Livetile" it opens up a new tab for the VM Console. Except it times out. Online information on this aspect is pretty much non-existent between a few quick Bing and Google searches.

    Has anyone had this issue or been able to get the vm console working on Kimchi? The host is Fed25.

    TEST is using VNC
    TEST2 is using SPICE
    ...if that helps, both timeout after trying to connect.

    SELinux permissions?



  • @black3dynamite said in Kimchi VM Guest Console Timeout Issue:

    @tim_g said in Kimchi VM Guest Console Timeout Issue:

    Between Cockpit and Kimchi, I was able to get this far in a few minutes, from a fresh install:

    0_1500048953722_Untitled.jpg

    When you click on the "Livetile" it opens up a new tab for the VM Console. Except it times out. Online information on this aspect is pretty much non-existent between a few quick Bing and Google searches.

    Has anyone had this issue or been able to get the vm console working on Kimchi? The host is Fed25.

    TEST is using VNC
    TEST2 is using SPICE
    ...if that helps, both timeout after trying to connect.

    SELinux permissions?

    I have done the following as part of initial setup to get to where I am in my screenshot:

    firewall-cmd --add-port=8000/tcp --permanent
    firewall-cmd --add-port=8001/tcp --permanent
    firewall-cmd --add-port=64667/tcp --permanent
    firewall-cmd --reload
    semanage permissive -a httpd_t
    

    If there is more to do, then it will take some digging.



  • @tim_g What install instructions did you follow? I can try to do the same & see what I come up with?



  • @fateknollogee said in Kimchi VM Guest Console Timeout Issue:

    @tim_g What install instructions did you follow? I can try to do the same & see what I come up with?

    This is a VERY rough copy of my notes straight from notepad... mis-numbered, etc... but should get you to where I am:

    (it looks short and sweet, but it's from here and there and works!)

    == Install Kimchi ==

    1. dnf instal kimchi

    2. Open ports:
      firewall-cmd --add-port=8000/tcp --permanent
      firewall-cmd --add-port=8001/tcp --permanent
      firewall-cmd --add-port=64667/tcp --permanent
      firewall-cmd --reload
      semanage permissive -a httpd_t

    3. systemctl enable kimchid

    4. nano /etc/libvirt/qemu.conf
      Uncomment user/group root

    5. reboot now

    6. service libvirtd restart (-if needed-)

    7. service kimchid restart (-if needed-)

    a. (N/A) nano /etc/modprobe.d/kvm.conf
    options kvm_intel nested=1
    b. semanage permissive -l | grep httpd_t
    c. service kimchid status
    d.



  • Lol, nodebb renumbered it all..



  • I just tried with selinux disabled, same result after rebooting, turning it back on.

    So, it doesn't seem to be firewall/selinux related (as far as I can tell).



  • @tim_g said in Kimchi VM Guest Console Timeout Issue:

    I just tried with selinux disabled, same result after rebooting, turning it back on.

    So, it doesn't seem to be firewall/selinux related (as far as I can tell).

    The VNC ports are in the 5900 range. I don't see those in your firewall-cmd statements.



  • @dafyre said in Kimchi VM Guest Console Timeout Issue:

    @tim_g said in Kimchi VM Guest Console Timeout Issue:

    I just tried with selinux disabled, same result after rebooting, turning it back on.

    So, it doesn't seem to be firewall/selinux related (as far as I can tell).

    The VNC ports are in the 5900 range. I don't see those in your firewall-cmd statements.

    Same with SPICE. If you look with virt manager it should tell you what port each VM is on. No idea if this interface will tell you.

    To test you can create an SSH tunnel with whatever port the console is on and see if it shows up locally.



  • Do all of those ranges need to be opened if im connecting via SSL on the web browser via port 64667? That's what shows in the browser, ip:64667, when attempting to connect to VM console. Its browser based. Im not actually connecting via spice/vnc. That's internally.



  • @tim_g did you try the same thing with virtmanager? Install it where kimchi is and try. Just to sort out issues: system, setup, bug...



  • I opened an issue on git, and it turns out that I was using version 1.5.1-0 and current release is 2.5.

    Why installing it from the repo (dnf install kimchi) installs such an old version, I shall never know... so I never thought to check that.

    I'm finally able to access it remotely, and get a web-based console view of my VMs... mostly anyways.

    Only a few issues remain that I'm trying to work out... it doesn't display the full screen and the keyboard/mouse stops functioning in the console.



  • @tim_g Screenshots would be nice to see :)



  • So far it seems to be okay:
    (edit: oh, Test1 doesn't seem to work... I guess because I either don't have novnc installed, or I didn't do anything to it... but Test2 works with webconsole as pictured below using spice)

    • I can remotely access it
    • Web console is showing the whole screen (but I have scroll bars to deal with... still rather have that than nothing)
    • Keyboard and mouse seem to be working okay now (in Edge, haven't yet tried in FF/Ch)

    0_1500579458173_Untitled.jpg

    0_1500579470884_Untitled2.jpg
    and the bottom
    0_1500579481094_Untitled3.jpg



  • Went to install novnc. It's already installed. So I have no clue why I can't use webconsole on Test1 that uses vnc... test2 works just fine as pictured above using spice via web console.



  • Okay, so looks like:

    Potential to remotely manage your Linux servers, hypervisors, and VMs via HTML5 from anywhere in the world.

    Works great! Just don't create a template that uses VNC. Use Spice instead and you'll have no issues. At least that's my fix until they get around to helping me clear it up.



  • How did you re-install since dnf install kimchi was an old version?



  • @fateknollogee said in Kimchi VM Guest Console Timeout Issue:

    How did you re-install since dnf install kimchi was an old version?

    First I did a wget <theKimchiFile>.rpm and then tried "dnf upgrade <kimchi-file>.rpm" but that failed saying it was missing new version of WOK.

    So I did a wget <theWOKfile>.rpm and then installed that, then I could do the upgrade command above.

    At that point, I did a bunch of stuff and it wasn't working, so I did a "dnf remove kimchi wok" and removed everything.

    Then I installed the prerequisites for wok, installed that, then kimchi... this was after installing a GUI and all the crap that comes with it because I couldn't get on remotely, I twas only working via localhost.

    I need to recreate my steps completely from fresh Fedora install to working Kimchi doing it this other way.

    Once I do that, I'll post the steps in a very easy to read and accurate step by step from fresh Fedora 26 install to completely working Kimchi.



  • Are you connecting to kimchi via localhost or remotely from another pc?



  • @fateknollogee said in Kimchi VM Guest Console Timeout Issue:

    Are you connecting to kimchi via localhost or remotely from another pc?

    Remotely from another PC.


Log in to reply
 

Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.