Unifi switch - tagged traffic issues



  • I'm trying to put a device on my Unifi Switch that has tagged traffic. My switch is set to allow all traffic on the port, but I currently don't see a way to mark it as Tagged traffic is allowed. Still digging through the documentation.

    Note - well, none of these changes made any difference. The default is to allow all known VLANs on all ports, and have the default LAN be the untagged traffic.
    My issue was on the uplink switch - that switch didn't allow VLAN2 on the incoming port. Adjusted that, and it all worked.

    CznwCsQ.png
    AIrkvtT.png



  • Real switches are oh so hard!
    0_1487632099695_upload-a7546ef3-20f5-4862-a3d8-64e3bb4105a8



  • @JaredBusch said in Unifi switch - tagged traffic issues:

    Real switches are oh so hard!

    yeah yeah.



  • n89GeQi.png
    lfrEUsl.png

    1- name new network
    2 - choose the untagged network
    3 - choose what tagged networks are allowed on this network



  • Finally, edit the ports you want to apply this network to and select the new network you just created.

    r5zmIyY.png



  • Ug not working 😞

    Tomorrow I guess.



  • Back to the problem at hand.

    By default, the Unifi switch lists all ports as ALL in the Network/VLAN settings. Which I know was at least partially working. I know because I set my uplink port to the new LAN I created above, which only allowed the corporate network and tagged VLAN 2 traffic, and my WIFI stopped working (which is on VLAN 105). Moving the uplink port back to ALL solved that issue.



  • But - there is an even bigger reason to not have my DHCP server give IPs to the public, and that's Windows licensing. Windows licensing is required when using Windows DHCP and DNS, and since I'm not going to license for the public, I might as well just put them on their own segment with a DHCP/DNS server I don't have to worry about licenses for. (which is what I'm doing now with an ER-X)

    I'm pretty sure this also means I can't use the Unifi Guest network WiFi option either.



  • @Dashrender said in Unifi switch - tagged traffic issues:

    But - there is an even bigger reason to not have my DHCP server give IPs to the public, and that's Windows licensing. Windows licensing is required when using Windows DHCP and DNS, and since I'm not going to license for the public, I might as well just put them on their own segment with a DHCP/DNS server I don't have to worry about licenses for. (which is what I'm doing now with an ER-X)

    That's pretty valid.



  • So if you have Windows DHCP handing out IP's for BYOD devices, you need to have CAL's for them? Did not know that, but looking at it makes sense as the BYOD device is using a resource form the server. Got to re-think some of our deployments



  • @jt1001001 said in Unifi switch - tagged traffic issues:

    So if you have Windows DHCP handing out IP's for BYOD devices, you need to have CAL's for them? Did not know that, but looking at it makes sense as the BYOD device is using a resource form the server. Got to re-think some of our deployments

    Yep, something I learned a few years ago here or ML.



  • @jt1001001 said in Unifi switch - tagged traffic issues:

    So if you have Windows DHCP handing out IP's for BYOD devices, you need to have CAL's for them? Did not know that, but looking at it makes sense as the BYOD device is using a resource form the server. Got to re-think some of our deployments

    Yes, if you are using Windows Servers... everything that talks to them needs a CAL, either machine CALs or User CALs. Windows Servers are very limiting on the license front, people often overlook just how much cost and exposure they end up with when using them.



  • The problem I'm trying to solve is that my Mitel phones, that are manually configured to be on VLAN 2, are not communicating to anything else on my network.



  • Found the problem - the uplink from my Unifi to my core switch, VLAN 2 wasn't allowed on the connection.

    Enabled VLAN2, problem solved.

    Aww the little things.



  • @Dashrender said in Unifi switch - tagged traffic issues:

    Found the problem - the uplink from my Unifi to my core switch, VLAN 2 wasn't allowed on the connection.

    Enabled VLAN2, problem solved.

    Aww the little things.

    on which switch.

    Also, reinforcing the issue with VLAN complicating things.



  • @JaredBusch said in Unifi switch - tagged traffic issues:

    @Dashrender said in Unifi switch - tagged traffic issues:

    Found the problem - the uplink from my Unifi to my core switch, VLAN 2 wasn't allowed on the connection.

    Enabled VLAN2, problem solved.

    Aww the little things.

    on which switch.

    Also, reinforcing the issue with VLAN complicating things.

    The core switch, in my case an HP 2824.

    I don't disagree that VLANs can/do add complication. But in this case it was pre-existing complication that I had to work through, not remove at this point.