Yum update failed


  • Service Provider

    My Nextcloud instance is on CentOS7 and has been since it was ownCloud 7.

    It has been updating my fine until today.

    Failed to check for updates with the following error message: 
    Failed to build transaction: selinux-policy-3.13.1-192.el7_5.3.noarch requires policycoreutils >= 2.5-18
    kernel-3.10.0-862.2.3.el7.x86_64 requires linux-firmware >= 20180113-61
    selinux-policy-targeted-3.13.1-192.el7_5.3.noarch requires policycoreutils >= 2.5-18
    


  • I just completed updates this morning on a centos 7 system here (snipe-it) and encountered no issues.

    Are you seeing this on other systems as well?


  • Service Provider

    I've only updated a few, but not run into that yet. Did run into a Mongo DB third party repo issue, but that's not super surprising.



  • No issue for me.



  • Isn't this the second time you have had issues with yum? I believe I have had this before and iirc I had to make sure my kernel was up to date. Don't hold me to that.


  • Service Provider

    @jaredbusch said in Yum update failed:

    kernel-3.10.0-862.2.3.el7.x86_64 requires linux-firmware >= 20180113-61

    The Google says you are the first person to have this issue 🙂

    Congrats.


  • Service Provider

    Back at my desk now, I rebooted the instance first and then manually ran yum update.

    [[email protected] ~]$ sudo yum update
    [sudo] password for jbusch: 
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * base: centos.unixheads.org
     * epel: mirror.oss.ou.edu
     * extras: mirror.cs.uwp.edu
     * remi-php71: repo1.dal.innoscale.net
     * remi-safe: repo1.dal.innoscale.net
     * updates: distro.ibiblio.org
    Resolving Dependencies
    --> Running transaction check
    ---> Package kernel.x86_64 0:3.10.0-862.2.3.el7 will be installed
    --> Processing Dependency: linux-firmware >= 20180113-61 for package: kernel-3.10.0-862.2.3.el7.x86_64
    ---> Package kernel-tools.x86_64 0:3.10.0-693.21.1.el7 will be updated
    ---> Package kernel-tools.x86_64 0:3.10.0-862.2.3.el7 will be an update
    ---> Package kernel-tools-libs.x86_64 0:3.10.0-693.21.1.el7 will be updated
    ---> Package kernel-tools-libs.x86_64 0:3.10.0-862.2.3.el7 will be an update
    ---> Package krb5-libs.x86_64 0:1.15.1-8.el7 will be updated
    ---> Package krb5-libs.x86_64 0:1.15.1-19.el7 will be an update
    ---> Package python-perf.x86_64 0:3.10.0-693.21.1.el7 will be updated
    ---> Package python-perf.x86_64 0:3.10.0-862.2.3.el7 will be an update
    ---> Package selinux-policy.noarch 0:3.13.1-166.el7_4.9 will be updated
    ---> Package selinux-policy.noarch 0:3.13.1-192.el7_5.3 will be an update
    --> Processing Dependency: policycoreutils >= 2.5-18 for package: selinux-policy-3.13.1-192.el7_5.3.noarch
    ---> Package selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.9 will be updated
    ---> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.3 will be an update
    --> Processing Dependency: policycoreutils >= 2.5-18 for package: selinux-policy-targeted-3.13.1-192.el7_5.3.noarch
    ---> Package tzdata.noarch 0:2018d-1.el7 will be updated
    ---> Package tzdata.noarch 0:2018e-3.el7 will be an update
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package kernel.x86_64 0:3.10.0-693.5.2.el7 will be erased
    ---> Package kernel.x86_64 0:3.10.0-862.2.3.el7 will be installed
    --> Processing Dependency: linux-firmware >= 20180113-61 for package: kernel-3.10.0-862.2.3.el7.x86_64
    ---> Package selinux-policy.noarch 0:3.13.1-192.el7_5.3 will be an update
    --> Processing Dependency: policycoreutils >= 2.5-18 for package: selinux-policy-3.13.1-192.el7_5.3.noarch
    ---> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.3 will be an update
    --> Processing Dependency: policycoreutils >= 2.5-18 for package: selinux-policy-targeted-3.13.1-192.el7_5.3.noarch
    --> Finished Dependency Resolution
    Error: Package: selinux-policy-3.13.1-192.el7_5.3.noarch (updates)
               Requires: policycoreutils >= 2.5-18
               Installed: policycoreutils-2.5-17.1.el7.x86_64 (@base)
                   policycoreutils = 2.5-17.1.el7
    Error: Package: selinux-policy-targeted-3.13.1-192.el7_5.3.noarch (updates)
               Requires: policycoreutils >= 2.5-18
               Installed: policycoreutils-2.5-17.1.el7.x86_64 (@base)
                   policycoreutils = 2.5-17.1.el7
    Error: Package: kernel-3.10.0-862.2.3.el7.x86_64 (updates)
               Requires: linux-firmware >= 20180113-61
               Installed: linux-firmware-20170606-58.gitc990aae.el7_4.noarch (@updates)
                   linux-firmware = 20170606-58.gitc990aae.el7_4
               Available: linux-firmware-20170606-56.gitc990aae.el7.noarch (base)
                   linux-firmware = 20170606-56.gitc990aae.el7
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
    

  • Service Provider

    @scottalanmiller said in Yum update failed:

    kernel-3.10.0-862.2.3.el7.x86_64 requires linux-firmware >= 20180113-61

    Grr...
    0_1526053713848_fde9901c-c197-4d8d-9862-40ed803776e5-image.png





  • I was able to correct this on a few of my instances that were having issues by running:

    yum clean all
    rm -rf /var/cache/yum

    and then attempting the update again.

    I think the cause of this was initially having a network connectivity issue on my end, so this may not help everyone, but worth a shot?


  • Service Provider

    @baslugger48 said in Yum update failed:

    I was able to correct this on a few of my instances that were having issues by running:

    yum clean all
    rm -rf /var/cache/yum

    and then attempting the update again.

    I think the cause of this was initially having a network connectivity issue on my end, so this may not help everyone, but worth a shot?

    I did that this morning right after I posted. Same result.

    Then I did --skip-broken.

    I just did it again and now there are 230 updates and no conflicts.


  • Service Provider

    Dependencies Resolved
    
    ==================================================================================================================================
     Package                                 Arch                   Version                             Repository               Size
    ==================================================================================================================================
    Updating:
     kernel-tools                            x86_64                 3.10.0-862.2.3.el7                  updates                 6.2 M
     kernel-tools-libs                       x86_64                 3.10.0-862.2.3.el7                  updates                 6.1 M
     krb5-libs                               x86_64                 1.15.1-19.el7                       updates                 747 k
     python-perf                             x86_64                 3.10.0-862.2.3.el7                  updates                 6.2 M
     tzdata                                  noarch                 2018e-3.el7                         updates                 482 k
    Skipped (dependency problems):
     kernel                                  x86_64                 3.10.0-862.2.3.el7                  updates                  46 M
     selinux-policy                          noarch                 3.13.1-192.el7_5.3                  updates                 453 k
     selinux-policy-targeted                 noarch                 3.13.1-192.el7_5.3                  updates                 6.6 M
    
    Transaction Summary
    ==================================================================================================================================
    Upgrade                        5 Packages
    Skipped (dependency problems)  3 Packages
    
    Total download size: 20 M
    Is this ok [y/d/N]: y
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    

  • Service Provider

    0_1526068041528_dc9ef2a8-acfe-4e18-8445-5b3fd5cde427-image.png

    0_1526068060766_cbbf2686-1323-43c4-87c6-67adab3bb39e-image.png


  • Service Provider

    I have 4 CentOS 7 servers at this location that I want to migrate to Fedora, just not high on my priority list.


  • Service Provider

    @jaredbusch said in Yum update failed:

    I have 4 CentOS 7 servers at this location that I want to migrate to Fedora, just not high on my priority list.

    But a little higher on that list now 🙂

    I truly find fedora updates more reliable than CentOS ones.



  • Can you upgrade to policycoreutils >= 2.5-18?


  • Service Provider

    @obsolesce it ran this afternoon. I noted that.