@JaredBusch said in Windows 10 Update 1607 seems to be removing .Net 3.5: @travisdh1 said in Windows 10 Update 1607 seems to be removing .Net 3.5: @JaredBusch So how the [self-moderated] do certain, previously named, companies make things that require very specific not-quite-upgraded versions of certain components of .net? I mean, they target specific versions of files that are a part of .net. When I go bald, at least I'll know why! Because they do not want to spend the money to recompile for newer versions in order to maintain a stupid high level of compatibility with people using old shit. You think they're actually bothering to use the tool you posted? Nope. They're checking the filenames on the system. I forget exactly which files they do this for, but it's super annoying because it didn't match with the latest updates or original version last time I had to install the P.O.S.