WDS/MDT very slow



  • So I was deploying images with WDS but it didn't give very much control so I setup MDT 2013. After stripping out all the drivers/images from WDS and doing everything in MDT then importing the WinPE image into WDS. Now the target computer I'm testing with is taking a very long time to download the WinPE image.

    When testing the new SCCM release, I had to modify the registry on the SCCM server to speed things up but WDS didn't require that (had to do with block sizes/etc).

    Any ideas why MDT/WDS might be very slow? Our network throughput is very high and the servers have plenty of resources so I'm thinking it's a configuration of MDT/WDS on my part...



  • If I remove the boot image in WDS (created in MDT), and just create one in WDS, it is just as slow. So taking MDT out of the equation, it looks like a configuration issue with WDS specifically...



  • Is your WDS / MDT server a VM?



  • @dafyre said in WDS/MDT very slow:

    Is your WDS / MDT server a VM?

    Yes, I've read in some cases that there was dispute with the virtual switch but I haven't found any supporting evidence of that.



  • What Hypervisor?



  • @dafyre said in WDS/MDT very slow:

    What Hypervisor?

    Hyper-V, server is 2012.

    Edit: Server 2012 Standard. Version 6.2.9200 Build 9200

    WDS was very fast just prior to adding/configuring MDT on that server which is weird...



  • @BBigford said in WDS/MDT very slow:

    @dafyre said in WDS/MDT very slow:

    What Hypervisor?

    Hyper-V, server is 2012.

    VMQ is often the culprit for slow network stuff... Especially if you have Intel or Broadcom NICs in the server...

    on the Hyper-V server... from the powershell command prompt, try:

    get-netadaptervmq|disable-netadaptervmq

    That will disable VMQ on all of the network adapters in the server. It generally doesn't cause a noticeable disconnection on the servers, but you know how that goes... be careful, lol.



  • @dafyre said in WDS/MDT very slow:

    @BBigford said in WDS/MDT very slow:

    @dafyre said in WDS/MDT very slow:

    What Hypervisor?

    Hyper-V, server is 2012.

    VMQ is often the culprit for slow network stuff... Especially if you have Intel or Broadcom NICs in the server...

    on the Hyper-V server... from the powershell command prompt, try:

    get-netadaptervmq|disable-netadaptervmq

    That will disable VMQ on all of the network adapters in the server. It generally doesn't cause a noticeable disconnection on the servers, but you know how that goes... be careful, lol.

    I disabled that on the VM itself.. I can't do that on the host if there is going to possibly cause a disconnect on the VMs. There's like 25 production VMs that are up.

    But disabling that on the VM itself did nothing if that's where I was supposed to run it.



  • @BBigford said in WDS/MDT very slow:

    @dafyre said in WDS/MDT very slow:

    @BBigford said in WDS/MDT very slow:

    @dafyre said in WDS/MDT very slow:

    What Hypervisor?

    Hyper-V, server is 2012.

    VMQ is often the culprit for slow network stuff... Especially if you have Intel or Broadcom NICs in the server...

    on the Hyper-V server... from the powershell command prompt, try:

    get-netadaptervmq|disable-netadaptervmq

    That will disable VMQ on all of the network adapters in the server. It generally doesn't cause a noticeable disconnection on the servers, but you know how that goes... be careful, lol.

    I disabled that on the VM itself.. I can't do that on the host if there is going to possibly cause a disconnect on the VMs. There's like 25 production VMs that are up.

    But disabling that on the VM itself did nothing if that's where I was supposed to run it.

    No, this has to be run from the host... It usually doesn't cause a disconnect that users will notice. But you raise another point though... The server was fast before adding MDT.



  • @dafyre said in WDS/MDT very slow:

    @BBigford said in WDS/MDT very slow:

    @dafyre said in WDS/MDT very slow:

    @BBigford said in WDS/MDT very slow:

    @dafyre said in WDS/MDT very slow:

    What Hypervisor?

    Hyper-V, server is 2012.

    VMQ is often the culprit for slow network stuff... Especially if you have Intel or Broadcom NICs in the server...

    on the Hyper-V server... from the powershell command prompt, try:

    get-netadaptervmq|disable-netadaptervmq

    That will disable VMQ on all of the network adapters in the server. It generally doesn't cause a noticeable disconnection on the servers, but you know how that goes... be careful, lol.

    I disabled that on the VM itself.. I can't do that on the host if there is going to possibly cause a disconnect on the VMs. There's like 25 production VMs that are up.

    But disabling that on the VM itself did nothing if that's where I was supposed to run it.

    No, this has to be run from the host... It usually doesn't cause a disconnect that users will notice. But you raise another point though... The server was fast before adding MDT.

    Exactly...


Log in to reply
 

Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.