XenServer issue



  • So after i got my desktop back from servicing, wanted to upgrade the xen server i had on that machine which is dual boot with WIn 2012. Boot that machine, started xen and all i could see is a blank screen with blinking cursor!

    Anyways, i wanted to upgrade, so got the xen server iso, used mac and unetbootin copied the file to usb and boot with that on the desktop. After keyboard selection, i got an error called "unexpected error occured". Used Alt+F2 to get into console and checked the error log, got something called "assertion error"

    Checked and found a solution from a site: http://networkrockstar.ca/2013/07/installing-xenserver-6-2-0-from-a-usb-stick/

    Just in case if this site is not available in future.

    Download the XenServer 6.2.0 ISO image (http://downloadns.citrix.com.edgesuite.net/7281/XenServer-6.2.0-install-cd.iso)
    Format a USB stick using FAT32.
    Use unetbootin (http://unetbootin.sourceforge.net/) to install the ISO to the USB stick.  Use the “DiskImage” option instead of the “Distribution” one, and point it right to the ISO file.
    Now we need to fix up some boot stuff:
        All paths are relative to the root of the USB drive.
        mv boot/isolinux/isolinux.cfg boot/isolinux/syslinux.cfg
        mv boot/isolinux boot/syslinux
        mv syslinux.cfg syslinux.cfg.bak
    Unmount the USB drive and eject it.
    Boot from the USB stick.
    

    If you get a “kernel not found” error at boot, double check that you renamed all the files properly.

    My installation went well and after the reboot, unfortunately i am still getting the same blinking cursor! Anyone faced such issue?



  • Did you remove the USB stick? If so, have you tried booting with it installed?



  • Removed the USB stick after installation and restarted from Xen, all i could see is the cursor. Last resort, i can do a clean install but really want to see why this is happening and how can i fix it



  • I even did a clean install on that machine, after reboot same issue!



  • Have you checked your bios settings for anything unusual? Perhaps this thread will help.



  • Thanks for the link, checked my bios, nothing seems to be changed, boot os set to legacy, tried optimised defaults but still the same, checking on it



  • So found out that the SATA mode selection was set to AHCI, i changed it to IDE and Xen started working fine, but then Windows server gave me BSOD. Seems like i could only get either Xen/Windows working at one time, i mean to go to windows, i need to go back in bios, set back to AHCI and can boot from windows. This was not the case before, don't know what changed!



  • Anyways Xen is up and i am installing Xen Orchestra as well. Still need to figure out how this can be fixed. Thanks @Danp for the pointers.



  • Might be related to the hardware? i can't say i had the same issue before, but something similar on linux, try to update the motherboard firmware, or try to install another version of the XENSERVER, it would be good to have the ACHI mode active in BIOS again... but thanks for the tutorial anyway.



  • If you've got Xen working, why still have a second boot option instead of running it in a VM?

    I mean, I can understand wanting to experiment, but that's just odd.



  • @travisdh1 said:

    If you've got Xen working, why still have a second boot option instead of running it in a VM?

    I mean, I can understand wanting to experiment, but that's just odd.

    As mentioned earlier, this is fine with me, started working on the Xen, but just wondering how this worked earlier and why is it not working now. @Mohammed-Fota i will try the bios update as well.


Log in to reply