Spiceworks installation --- help?



  • Hey everyone,

    I've setup Spiceworks before, and now I'm setting it up again, but with trouble accessing it from other workstations. I have the installation out on a VM, port 80 wasn't being used so I left it as default 80/443. I changed the email URL in settings to http://help/portal. The only thing left was to put in a DNS entry but I can't remember for the life of me what I did on that portion because a CNAME of help/portal obviously doesn't work for the generated FQDN, and I didn't think I put in an A record. Any thoughts? I only need this to be used internally, so I'd rather not setup IIS. I checked this how-to but step 4 (the step I'm missing) has zero substance.



  • DNS will not be needed for the first step of testing. A Spiceworks install does not use HTTP Headers by default. So, we can test with just the IP Address before looking at DNS entries.

    If you go to http://youripaddress you should just see the Spiceworks interface come up. If it does not come up, ensure that SW is running and that your firewall is not blocking port 80.



  • For step four....

    The DNS entry is an A record, not a shortcup (CNAME.) You'll want your internally desired name to point to the IP Address of the install address.



  • @scottalanmiller on the local host, the IP does indeed take me to the landing page. Suspected the firewall to be an issue, its managed so I'm moving and gpupdating it now to disable/test.



  • @scottalanmiller said:

    For step four....

    The DNS entry is an A record, not a shortcup (CNAME.) You'll want your internally desired name to point to the IP Address of the install address.

    Ah, so they weren't talking about using an alias. They were just talking about simply adding it to DNS is all?



  • @BBigford said:

    @scottalanmiller on the local host, the IP does indeed take me to the landing page. Suspected the firewall to be an issue, its managed so I'm moving and gpupdating it now to disable/test.

    You can test from local host to see if it is running, but to test the firewall you have to test from the outside.



  • @scottalanmiller Yeah local host is all good.



  • It was indeed the firewall. Simple enough I guess... thanks for the quick reply, Scott. Man, I'm glad you brought me over to Mango. Super fast responses.



  • @BBigford said:

    It was indeed the firewall. Simple enough I guess... thanks for the quick reply, Scott. Man, I'm glad you brought me over to Mango. Super fast responses.

    Woot!!


Log in to reply