GrandStream phones with FreePBX



  • Has anyone deployed the GXP2170 and GXP2135 with FreePBX. I am having a hell of a time getting them to connect to my instance on Vultr. I noticed on the GrandStream the local rtp port is 5004. Do I need to change with to 10000?

    I deployed using the EndPoint Manager so I assumed the settings would be good to go but apparently something is not right.

    Appreciate any feedback.

    Thanks



  • Just some more info:

    Some phone connect alright but then seem to lose extension to extension audio. This is what lead me to the RTP settings on the GrandStream.

    The phones that do not connect are pulling their lines settings and blf settings correctly from the FreePBX so I know it is connecting or sort of.



  • Just to update this, I am using FreePBX 15 Asterisk 16. Started off using PJSip as the default and then switched to ChanSip. All extensions connected on ChanSip but extension to extension on some phones is still not working.



  • I don’t have one of them.

    But I have multiple phone systems to test with if you want.

    We could set one up to my PBX and let me watch the logs and such.



  • @syko24 said in GrandStream phones with FreePBX:

    I noticed on the GrandStream the local rtp port is 5004. Do I need to change with to 10000?

    The local RTP port should not matter.

    I deployed using the EndPoint Manager so I assumed the settings would be good to go but apparently something is not right.

    If it is a listed phone, it should work right.



  • @syko24 Almost sounds like a SIP-ALG issue to me. Make sure SIP-ALG is disabled on your router. I've got a 2170 laying around if it can help.



  • @JaredBusch said in GrandStream phones with FreePBX:

    I don’t have one of them.

    But I have multiple phone systems to test with if you want.

    We could set one up to my PBX and let me watch the logs and such.

    Thanks @JaredBusch for the offer. So I know this should have been more obvious but there was a SonicWall router in place at this site. The reason I didn't think much of it was because about half the phones were working properly and the other half were not. I was thinking the issue was something with the local RTP being set at 5004 on the GrandStreams.

    I swapped out the SonicWall with an EdgeRouter but that still did not fix the issue. I rebooted the isp's modem and rebooted the edgerouter. I factory reset all the phones and they all connected. I tested that all could access extension calls and make outbound calls. For now I am assuming the SonicWall was the culprit but tomorrow will tell.

    If I run into this issue again I may take you up on your offer. Thanks again!!



  • @syko24 said in GrandStream phones with FreePBX:

    but there was a SonicWall router in place at this site.

    Oh you should always mention those. SonicWall are the #1 "doesn't work properly" device we've ever seen. When dealing with someone that we don't control their network and their phones don't work, we always ask "Do you have a SonicWall" first? Because literally 80% of the time or more, that's the problem. They can be made to work, but their default configuration is specifically to break VoIP.

    The EdgeRouter works in default state. So should be good for testing now.



  • @syko24 said in GrandStream phones with FreePBX:

    For now I am assuming the SonicWall was the culprit but tomorrow will tell.

    It's a known "doesn't work" piece of hardware. I'm pretty sure, based on the unethical reasons why SonicWall exists and is sold (they are a "only for resellers to screw companies" product, not one for IT to select) that they break VoIP by default to probably support some kind of resell or consulting effort so that when competitor VoIP doesn't work, the unethical VAR who deals in SW can magically make their own work and resell that.


Log in to reply