HyperVServer Build



  • I've installed HyperVServer 2016 for the first time (HV01)
    I have gone through sconfig and renamed the computer, given it a static ip, enabled remote desktop and remote management but now hit a brick wall.

    I want to install 2x VM's on there so have a Windows 10 laptop which I installed the Hyper-V manager on but when i try to connect to my HyperV host (HV01) it says:

    "An error occured whilst attempting to connect to server "HV01" check that the Virtual Machine Management Service service is running and that you are authorised to connect to the server.

    The computer HV01 could not be resolved. Make sure you typed the machine name correctly and that you have network access.

    HELP



  • Update:
    I just ran Hyper-V Manager as an admin and this time when I tried to connect to HV01, I chose the option to Use another account and entered the HV01 local admin account and got message:

    'Enable delegation of user credentials?
    This computer is not configured to allow delegation of user credentials. Do you want to allow delgation of user credentials to HV01?'

    I clicked YES and got the error:

    Delegation of credentials to HV01 could not be enabled.
    CredSSP authentication is currently disabled on the local client. You must be running with administrator privileges in order to enable CredSSP

    Double help!





  • If you are not in an AD environment, there are a number of things you have to do to establish trust between the management system (your laptop) and the Hyper-V server.



  • @black3dynamite said in HyperVServer Build:

    https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/manage/remotely-manage-hyper-v-hosts

    I saw this earlier but skimmed over it. Having just re-read it, this was key to do on my Windows 10 client.

    Computer Configuration > Administrative Templates > System > Credentials Delegation > Allow delegating fresh credentials with NTLM-only server authentication
    Click Enable and add wsman/fqdn-of-hyper-v-host.

    I'm going to format and start from scratch as previously I had enabled so many firewall rules and bits so want to start clean and see what I need to enable exactly.

    Thanks I'll report back



  • These are the steps I follow when setting up a Hyper-V server with a Windows 10 machine to manage in a Workgroup environment. Works perfectly every time.

    From Hyper-V Server:

    Enable Remote Management

    • Select 4 on the menu
    • Then select 1 for Enable Remote Management
    • Go back to previous menu

    Enable Remote Desktop

    • Select 7 on the menu
    • Then select "e" for enable
    • Select 2 on the next screen for Allow clients running ANY version of remote desktop

    Run Powershell Commands

    • Type powershell in command window and press Enter
    • Type "Enable-PSRemoting" and press ENTER
    • Type "Enable-WSManCredSSP -Role Server" and press ENTER
    • Select "y" when prompted to confirm and press ENTER
    • Exit Powershell by typing "exit" and press ENTER
    • In command prompt, type "net start winrm" and press ENTER <-- Use this is can't connect later to server

    From Windows 10 Machine

    • Control Panel -> Programs & Features -> Turn Windows Features On Or Off
    • Enable Hyper-V role and press OK
    • Launch Powershell as Admin
    • Type "Set-Item WSMan:\localhost\Client\TrustedHosts -Value "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER
    • Type "Enable-WSManCredSSP -Role client -DelegateComputer "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER

    Edit Group Policy

    • Click Windows icon and type "gpedit" and open Group Policy program
    • Local Computer-> Computer Configuration -> Administrative Templates -> System -> Credential Delegation
    • Edit the "Allow delegating fresh credentials with NTLM-Only server authentication"
    • Click "Show" button to add items
    • Add value "WSMAN/*" to servers list and click OK

    Manage Via Hyper-V Manager

    • Start Hyper-V Manager and click Connect To Server and add IP address of server
    • Select "Connect as another user" and click "Set User"
    • Enter user login details with username in format of "WSMAN\Username"
    • Create Virtual Switch as needed


  • @nashbrydges said in HyperVServer Build:

    These are the steps I follow when setting up a Hyper-V server with a Windows 10 machine to manage in a Workgroup environment. Works perfectly every time.

    From Hyper-V Server:

    Enable Remote Management

    • Select 4 on the menu
    • Then select 1 for Enable Remote Management
    • Go back to previous menu

    Enable Remote Desktop

    • Select 7 on the menu
    • Then select "e" for enable
    • Select 2 on the next screen for Allow clients running ANY version of remote desktop

    Run Powershell Commands

    • Type powershell in command window and press Enter
    • Type "Enable-PSRemoting" and press ENTER
    • Type "Enable-WSManCredSSP -Role Server" and press ENTER
    • Select "y" when prompted to confirm and press ENTER
    • Exit Powershell by typing "exit" and press ENTER
    • In command prompt, type "net start winrm" and press ENTER <-- Use this is can't connect later to server

    From Windows 10 Machine

    • Control Panel -> Programs & Features -> Turn Windows Features On Or Off
    • Enable Hyper-V role and press OK
    • Launch Powershell as Admin
    • Type "Set-Item WSMan:\localhost\Client\TrustedHosts -Value "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER
    • Type "Enable-WSManCredSSP -Role client -DelegateComputer "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER

    Edit Group Policy

    • Click Windows icon and type "gpedit" and open Group Policy program
    • Local Computer-> Computer Configuration -> Administrative Templates -> System -> Credential Delegation
    • Edit the "Allow delegating fresh credentials with NTLM-Only server authentication"
    • Click "Show" button to add items
    • Add value "WSMAN/*" to servers list and click OK

    Manage Via Hyper-V Manager

    • Start Hyper-V Manager and click Connect To Server and add IP address of server
    • Select "Connect as another user" and click "Set User"
    • Enter user login details with username in format of "WSMAN\Username"
    • Create Virtual Switch as needed

    MY HERO ๐Ÿ™‚ - I'm in process of re-installing so will follow these steps - Thanks



  • @joel said in HyperVServer Build:

    @nashbrydges said in HyperVServer Build:

    These are the steps I follow when setting up a Hyper-V server with a Windows 10 machine to manage in a Workgroup environment. Works perfectly every time.

    From Hyper-V Server:

    Enable Remote Management

    • Select 4 on the menu
    • Then select 1 for Enable Remote Management
    • Go back to previous menu

    Enable Remote Desktop

    • Select 7 on the menu
    • Then select "e" for enable
    • Select 2 on the next screen for Allow clients running ANY version of remote desktop

    Run Powershell Commands

    • Type powershell in command window and press Enter
    • Type "Enable-PSRemoting" and press ENTER
    • Type "Enable-WSManCredSSP -Role Server" and press ENTER
    • Select "y" when prompted to confirm and press ENTER
    • Exit Powershell by typing "exit" and press ENTER
    • In command prompt, type "net start winrm" and press ENTER <-- Use this is can't connect later to server

    From Windows 10 Machine

    • Control Panel -> Programs & Features -> Turn Windows Features On Or Off
    • Enable Hyper-V role and press OK
    • Launch Powershell as Admin
    • Type "Set-Item WSMan:\localhost\Client\TrustedHosts -Value "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER
    • Type "Enable-WSManCredSSP -Role client -DelegateComputer "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER

    Edit Group Policy

    • Click Windows icon and type "gpedit" and open Group Policy program
    • Local Computer-> Computer Configuration -> Administrative Templates -> System -> Credential Delegation
    • Edit the "Allow delegating fresh credentials with NTLM-Only server authentication"
    • Click "Show" button to add items
    • Add value "WSMAN/*" to servers list and click OK

    Manage Via Hyper-V Manager

    • Start Hyper-V Manager and click Connect To Server and add IP address of server
    • Select "Connect as another user" and click "Set User"
    • Enter user login details with username in format of "WSMAN\Username"
    • Create Virtual Switch as needed

    MY HERO ๐Ÿ™‚ - I'm in process of re-installing so will follow these steps - Thanks

    So I followed this to the letter and no luck this time!!!
    Last time i did run some PS for firewalls - do I need to do this also on the host?



  • @joel said in HyperVServer Build:

    @joel said in HyperVServer Build:

    @nashbrydges said in HyperVServer Build:

    These are the steps I follow when setting up a Hyper-V server with a Windows 10 machine to manage in a Workgroup environment. Works perfectly every time.

    From Hyper-V Server:

    Enable Remote Management

    • Select 4 on the menu
    • Then select 1 for Enable Remote Management
    • Go back to previous menu

    Enable Remote Desktop

    • Select 7 on the menu
    • Then select "e" for enable
    • Select 2 on the next screen for Allow clients running ANY version of remote desktop

    Run Powershell Commands

    • Type powershell in command window and press Enter
    • Type "Enable-PSRemoting" and press ENTER
    • Type "Enable-WSManCredSSP -Role Server" and press ENTER
    • Select "y" when prompted to confirm and press ENTER
    • Exit Powershell by typing "exit" and press ENTER
    • In command prompt, type "net start winrm" and press ENTER <-- Use this is can't connect later to server

    From Windows 10 Machine

    • Control Panel -> Programs & Features -> Turn Windows Features On Or Off
    • Enable Hyper-V role and press OK
    • Launch Powershell as Admin
    • Type "Set-Item WSMan:\localhost\Client\TrustedHosts -Value "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER
    • Type "Enable-WSManCredSSP -Role client -DelegateComputer "IP_OF_HYPER-V_SERVER" and press ENTER
    • Type "y" when prompted and press ENTER

    Edit Group Policy

    • Click Windows icon and type "gpedit" and open Group Policy program
    • Local Computer-> Computer Configuration -> Administrative Templates -> System -> Credential Delegation
    • Edit the "Allow delegating fresh credentials with NTLM-Only server authentication"
    • Click "Show" button to add items
    • Add value "WSMAN/*" to servers list and click OK

    Manage Via Hyper-V Manager

    • Start Hyper-V Manager and click Connect To Server and add IP address of server
    • Select "Connect as another user" and click "Set User"
    • Enter user login details with username in format of "WSMAN\Username"
    • Create Virtual Switch as needed

    MY HERO ๐Ÿ™‚ - I'm in process of re-installing so will follow these steps - Thanks

    So I followed this to the letter and no luck this time!!!
    Last time i did run some PS for firewalls - do I need to do this also on the host?

    WHat error are you getting now? Make sure hyperv server is fully up to date, as well as your Win10 pc



  • I'm getting this error now!

    0_1532634515000_Capture111.PNG

    I have just run:
    netsh advfirewall firewall set rule group = "XXX" new enable =yes

    Where XXX = Remote Event Log Management
    Remote Service Management
    File and Printer Sharing
    Remote Scheduled Tasks
    Performance Logs and Alerts
    Remote Volume Management
    Windows Firewall Remote Management



  • @joel said in HyperVServer Build:

    I'm getting this error now!

    0_1532634515000_Capture111.PNG

    I have just run:
    netsh advfirewall firewall set rule group = "XXX" new enable =yes

    Where XXX = Remote Event Log Management
    Remote Service Management
    File and Printer Sharing
    Remote Scheduled Tasks
    Performance Logs and Alerts
    Remote Volume Management
    Windows Firewall Remote Management

    Are you connecting as a user that has permission on the host?



  • I'm connecting as the local admin. Ie on my host there is a default 'Administrator' user account.

    Within HyperV-Manager I choose 'Connect to server' and Set User as:
    Workgroup\administrator and then enter my password



  • I found online to run this command on the host - I'm not sure what that is so dont feel comfortable running it. Any ideas?

    Run โ€œMOFCOMP %SYSTEMROOT%\System32\WindowsVirtualization.V2.mofโ€

    https://community.spiceworks.com/how_to/122307-fix-error-managing-hyper-v-server-2012-r2-from-windows-10



  • @joel said in HyperVServer Build:

    I'm connecting as the local admin. Ie on my host there is a default 'Administrator' user account.

    Within HyperV-Manager I choose 'Connect to server' and Set User as:
    Workgroup\administrator and then enter my password

    Try it as hostname\administrator instead of workgroup



  • sadly no joy - same result even with hostname\administrator



  • @joel said in HyperVServer Build:

    sadly no joy - same result even with hostname\administrator

    The name of the server, not literally "hostname", right?



  • @obsolesce haha yes. HV01\Administrator



  • @joel said in HyperVServer Build:

    @obsolesce haha yes. HV01\Administrator

    Can you connect via powershell?

    Verify you can ping HV01 by name.

    Open up PowerShell on your Win10 PC, and type Enter-PSSession, then hit enter.

    Then enter HV01.



  • @obsolesce said in HyperVServer Build:

    @joel said in HyperVServer Build:

    @obsolesce haha yes. HV01\Administrator

    Can you connect via powershell?

    Verify you can ping HV01 by name.

    Open up PowerShell on your Win10 PC, and type Enter-PSSession, then hit enter.

    Then enter HV01.

    Enter-PSSession -ComputerName HV01 -Credential HV01\Administrator does work.



  • Enter-PSSession -ComputerName HV01 -Credential HV01\Administrator does work - yes this does work!



  • Its just the connecting via hyper-v manager 'Operation not supported' - So how can I allow remote management on the HV01 host or get my host to support Hyper-V Manager?



  • Enter another PSSession to HV01.

    Then type get-service vmms

    Does the status say it's running?



  • UPDATE: I have run Updates on the host and after a reboot I think i can now connect. It did throw another error about WinRM firewall but it connected - i'll report back after a bit more tetsing
    THANKS so far



  • Next I want to create a new VM - My Domain Controller.

    First, I want to change Hyper-V settings so my VM's go into D:\

    1. How do I partition the D drive on my host - when i formatted windows I created one partition for ๐Ÿ˜„ (80GB) and left 1.9TB spare (which I want to be my D drive) - How do I bring the D drive online on the host and have it accessible?

    Thanks



  • 0_1532638597925_disks.PNG



  • @joel said in HyperVServer Build:

    Next I want to create a new VM - My Domain Controller.

    First, I want to change Hyper-V settings so my VM's go into D:\

    1. How do I partition the D drive on my host - when i formatted windows I created one partition for ๐Ÿ˜„ (80GB) and left 1.9TB spare (which I want to be my D drive) - How do I bring the D drive online on the host and have it accessible?

    Thanks

    If you have RSAT installed, you can use Server Manager > File and Storage Services to manage your disks or use Disk Management.



  • I'm assuming Disk 0 is your RAID10.

    You have a partition setup for 80GB which is your C volume.

    Now you need to (on DISK 0), create another VOLUME using the rest of the space and give it the letter D.



  • 0_1532638980066_disk1.PNG



  • diskpart
    select disk 0
    create partition primary
    select partition 5
    format fs=ntfs label="DATA" quick
    assign
    list disk
    list part
    list vol
    


  • @obsolesce I don't have to run any firewall powershell commands. The steps I listed above are literally all I need to do. I did this on a server about 10 days ago. Installed perfectly on a Dell R420.


Log in to reply