Nextcloud 12 / CentOS 7 -- Memcache Issue



  • Enable Memcache

    nano /var/www/html/nextcloud/config/config.php
    'memcache.locking' => '\OC\Memcache\Redis',
    'memcache.local' => '\OC\Memcache\Redis',
        'redis' => array(
        'host' => 'localhost',
        'port' => 6379,
    ),
    

    Restart the webserver

    systemctl restart httpd
    

    The moment I do this, nextcloud no longer functions. I'm assuming I formatted it incorrectly?

    
    <?php
    $CONFIG = array (
      'instanceid' => 'oc7z4ncng4ne',
      'passwordsalt' => 'Pf7kbjmRF1BtAaS3NEkcQCWgSL8S2o',
      'secret' => 'BBM526bC9SCz9Bw+/Q29wbnruBOpLqdFK4X6KJ5KG9khd8DR',
      'trusted_domains' =>
      array (
        0 => '192.168.1.202',
        1 => 'nc.mydomain.com',
      ),
      'datadirectory' => '/var/www/html/nextcloud/data',
      'overwrite.cli.url' => 'http://nc.mydomain.com',
      'dbtype' => 'mysql',
      'version' => '12.0.4.3',
      'dbname' => 'nextcloud',
      'dbhost' => 'localhost',
      'dbport' => '',
      'dbtableprefix' => 'oc_',
      'dbuser' => 'admin account',
      'dbpassword' => 'pw',
      'installed' => true,
      'htaccess.RewriteBase' => '/',
      'memcache.locking' => '\OC\Memcache\Redis',
      'memcache.local' => '\OC\Memcache\Redis',
        'redis' => array(
        'host' => 'localhost',
        'port' => 6379,
      ),
    );
    


  • Is 6379 open?



  • @momurda yessir



  • Youre using redis instead of mysql/mariadb or mongo?
    Is your www-data/apache user part of redis group?



  • @momurda said in Nextcloud 12 / CentOS 7 -- Memcache Issue:

    Youre using redis instead of mysql/mariadb or mongo?
    Is your www-data/apache user part of redis group?

    It is not instead of mariadb. That is not what is happening here.



  • @momurda I'm using MariaDB



  • Did you create the config.php file manually or copy the config.sample.php file, renamed it and modified it?
    Make sure apache is the owner.

    Can you provide the status of httpd?

    systemctl status httpd
    

    You can try setting SELinux to permissive to troubleshoot in case that could be the issue?

    # Permissive
    setenforce 0
    
    # Set it back to enforcing after you are done
    setenforce 1
    


  • @black3dynamite said in Nextcloud 12 / CentOS 7 -- Memcache Issue:

    systemctl status httpd

    Interesting. It's pointing to /var/www/nextcloud instead of /var/www/html/nextcloud. I actually had this occur already and fixed it but something else is pointing there as well.

    
    [[email protected] ~]# systemctl status httpd -l
    ● httpd.service - The Apache HTTP Server
       Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2018-02-07 15:19:57 EST; 2h 16min ago
         Docs: man:httpd(8)
               man:apachectl(8)
     Main PID: 996 (httpd)
       Status: "Total requests: 737; Current requests/sec: 0.1; Current traffic: 204 B/sec"
       CGroup: /system.slice/httpd.service
               ├─ 996 /usr/sbin/httpd -DFOREGROUND
               ├─1458 /usr/sbin/httpd -DFOREGROUND
               ├─1460 /usr/sbin/httpd -DFOREGROUND
               ├─1518 /usr/sbin/httpd -DFOREGROUND
               ├─1520 /usr/sbin/httpd -DFOREGROUND
               ├─1522 /usr/sbin/httpd -DFOREGROUND
               ├─1523 /usr/sbin/httpd -DFOREGROUND
               ├─1905 /usr/sbin/httpd -DFOREGROUND
               ├─2041 /usr/sbin/httpd -DFOREGROUND
               ├─2072 /usr/sbin/httpd -DFOREGROUND
               └─2126 /usr/sbin/httpd -DFOREGROUND
    
    Feb 07 15:19:54 nextcloud systemd[1]: Starting The Apache HTTP Server...
    Feb 07 15:19:56 nextcloud httpd[996]: AH00112: Warning: DocumentRoot [/var/www/nextcloud] does not exist
    Feb 07 15:19:56 nextcloud httpd[996]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::e37c:3451:aee8:1731. Set the 'ServerName' directive globally to suppress this message
    Feb 07 15:19:57 nextcloud systemd[1]: Started The Apache HTTP Server.
    


  • @wirestyle22 said in Nextcloud 12 / CentOS 7 -- Memcache Issue:

    @black3dynamite said in Nextcloud 12 / CentOS 7 -- Memcache Issue:

    systemctl status httpd

    Interesting. It's pointing to /var/www/nextcloud instead of /var/www/html/nextcloud. I actually had this occur already and fixed it but something else is pointing there as well.

    
    [[email protected] ~]# systemctl status httpd -l
    ● httpd.service - The Apache HTTP Server
       Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2018-02-07 15:19:57 EST; 2h 16min ago
         Docs: man:httpd(8)
               man:apachectl(8)
     Main PID: 996 (httpd)
       Status: "Total requests: 737; Current requests/sec: 0.1; Current traffic: 204 B/sec"
       CGroup: /system.slice/httpd.service
               ├─ 996 /usr/sbin/httpd -DFOREGROUND
               ├─1458 /usr/sbin/httpd -DFOREGROUND
               ├─1460 /usr/sbin/httpd -DFOREGROUND
               ├─1518 /usr/sbin/httpd -DFOREGROUND
               ├─1520 /usr/sbin/httpd -DFOREGROUND
               ├─1522 /usr/sbin/httpd -DFOREGROUND
               ├─1523 /usr/sbin/httpd -DFOREGROUND
               ├─1905 /usr/sbin/httpd -DFOREGROUND
               ├─2041 /usr/sbin/httpd -DFOREGROUND
               ├─2072 /usr/sbin/httpd -DFOREGROUND
               └─2126 /usr/sbin/httpd -DFOREGROUND
    
    Feb 07 15:19:54 nextcloud systemd[1]: Starting The Apache HTTP Server...
    Feb 07 15:19:56 nextcloud httpd[996]: AH00112: Warning: DocumentRoot [/var/www/nextcloud] does not exist
    Feb 07 15:19:56 nextcloud httpd[996]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::e37c:3451:aee8:1731. Set the 'ServerName' directive globally to suppress this message
    Feb 07 15:19:57 nextcloud systemd[1]: Started The Apache HTTP Server.
    

    Check your DocumentRoot setting in /etc/httpd/conf/httpd.conf.



  • @black3dynamite Yeah it was actually the old config, not the new ssl.conf version. I still changed it so that fixed the error.

    Feb 07 17:40:15 nextcloud systemd[1]: Starting The Apache HTTP Server...
    Feb 07 17:40:15 nextcloud httpd[2407]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::e37c:3451:aee8:1731. Set the 'ServerName' directive globally to suppress this message
    Feb 07 17:40:15 nextcloud systemd[1]: Started The Apache HTTP Server.
    

    ServerName directive is contained within my vhost file, so no idea why it's kicking that back at me.



  • @black3dynamite Alright, fixed. I thought including conf.modules.d/*.conf overwrote the ServerName entry in http.conf?



  • The "Strict-Transport-Security" HTTP header is not configured to at least "15552000" seconds. For enhanced security we recommend enabling HSTS as described in our security tips.
    
    No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our documentation.
    Please double check the installation guides ↗, and check for any errors or warnings in the log.
    

    Still an issue though. If I try to enable memcache nextcloud is no longer functional



  • @wirestyle22 said in Nextcloud 12 / CentOS 7 -- Memcache Issue:

    The "Strict-Transport-Security" HTTP header is not configured to at least "15552000" seconds. For enhanced security we recommend enabling HSTS as described in our security tips.
    
    No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our documentation.
    Please double check the installation guides ↗, and check for any errors or warnings in the log.
    

    Still an issue though. If I try to enable memcache nextcloud is no longer functional

    Check your /etc/httpd/conf.d/ssl.conf to see if Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains" is there.

    It looks like this.

    ##
    ## SSL Virtual Host Context
    ##
    
    <VirtualHost _default_:443>
    
    # General setup for the virtual host, inherited from global configuration
    #DocumentRoot "/var/www/html"
    #ServerName www.example.com:443
    
    # Enable HTTP Strict Transport Security
    <IfModule mod_headers.c>
        Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
    </IfModule>
    ...
    


  • @black3dynamite It's there, but I'm still getting the above error


Log in to reply