Unable to ping FQDN .local hosts from Fedora 26



  • I came across an issue on Fedora 26 where I was unable to ping the FQDN address of anything .local (server.domain.local). It was weird because I could ping the IP, I could ping the server without the .domain.local, nslookup server.domain.local would show the correct results, as would dig, but using the FQDN with .local just did not work.

    After some digging around, I found that editing the following file and changing the line below and rebooting resolved the issue:

    # Edit this file:  /etc/avahi/avahi-daemon.conf
    
    # Uncomment the below line:
    domain-name=local
    
    # Change the above line to ".local" (add a period):
    domain-name=.local
    

    Then reboot.

    Problem resolved.

    I'm not sure what exactly was happening, but you'd think something like this would work out-of-box. Just one more thing to configure added to the list...



  • @tim_g said in Unable to ping FQDN .local hosts from Fedora 26:

    I came across an issue on Fedora 26 where I was unable to ping the FQDN address of anything .local (server.domain.local). It was weird because I could ping the IP, I could ping the server without the .domain.local, nslookup server.domain.local would show the correct results, as would dig, but using the FQDN with .local just did not work.

    After some digging around, I found that editing the following file and changing the line below and rebooting resolved the issue:

    # Edit this file:  /etc/avahi/avahi-daemon.conf
    
    # Uncomment the below line:
    domain-name=local
    
    # Change the above line to ".local" (add a period):
    domain-name=.local
    

    Then reboot.

    Problem resolved.

    I'm not sure what exactly was happening, but you'd think something like this would work out-of-box. Just one more thing to configure added to the list...

    Or just don't use .local? 🙂



  • @tim_g said in Unable to ping FQDN .local hosts from Fedora 26:

    I came across an issue on Fedora 26 where I was unable to ping the FQDN address of anything .local (server.domain.local). It was weird because I could ping the IP, I could ping the server without the .domain.local, nslookup server.domain.local would show the correct results, as would dig, but using the FQDN with .local just did not work.

    After some digging around, I found that editing the following file and changing the line below and rebooting resolved the issue:

    # Edit this file:  /etc/avahi/avahi-daemon.conf
    
    # Uncomment the below line:
    domain-name=local
    
    # Change the above line to ".local" (add a period):
    domain-name=.local
    

    Then reboot.

    Problem resolved.

    I'm not sure what exactly was happening, but you'd think something like this would work out-of-box. Just one more thing to configure added to the list...

    I notice that too. But I see it has them making us stop using .local for FQDN.
    Have you notice that most if not all distro uses .localdomain instead of .local when doing a clean install?



  • @jaredbusch said in Unable to ping FQDN .local hosts from Fedora 26:

    @tim_g said in Unable to ping FQDN .local hosts from Fedora 26:

    I came across an issue on Fedora 26 where I was unable to ping the FQDN address of anything .local (server.domain.local). It was weird because I could ping the IP, I could ping the server without the .domain.local, nslookup server.domain.local would show the correct results, as would dig, but using the FQDN with .local just did not work.

    After some digging around, I found that editing the following file and changing the line below and rebooting resolved the issue:

    # Edit this file:  /etc/avahi/avahi-daemon.conf
    
    # Uncomment the below line:
    domain-name=local
    
    # Change the above line to ".local" (add a period):
    domain-name=.local
    

    Then reboot.

    Problem resolved.

    I'm not sure what exactly was happening, but you'd think something like this would work out-of-box. Just one more thing to configure added to the list...

    Or just don't use .local? 🙂

    Nothing wrong with .local. It's not worth switching.



  • @black3dynamite said in Unable to ping FQDN .local hosts from Fedora 26:

    @tim_g said in Unable to ping FQDN .local hosts from Fedora 26:

    I came across an issue on Fedora 26 where I was unable to ping the FQDN address of anything .local (server.domain.local). It was weird because I could ping the IP, I could ping the server without the .domain.local, nslookup server.domain.local would show the correct results, as would dig, but using the FQDN with .local just did not work.

    After some digging around, I found that editing the following file and changing the line below and rebooting resolved the issue:

    # Edit this file:  /etc/avahi/avahi-daemon.conf
    
    # Uncomment the below line:
    domain-name=local
    
    # Change the above line to ".local" (add a period):
    domain-name=.local
    

    Then reboot.

    Problem resolved.

    I'm not sure what exactly was happening, but you'd think something like this would work out-of-box. Just one more thing to configure added to the list...

    I notice that too. But I see it has them making us stop using .local for FQDN.
    Have you notice that most if not all distro uses .localdomain instead of .local when doing a clean install?

    There's no need for that silly limitation. I should be able to have a domain called whatever I want, and when I ping or go to it by FQDN, it should work if DNS is set up right.



  • I think you might be able to add using
    search=domain.com domain.local
    in resolv.conf or ifcfg-eth0 file



  • @momurda said in Unable to ping FQDN .local hosts from Fedora 26:

    I think you might be able to add using
    search=domain.com domain.local
    in resolv.conf or ifcfg-eth0 file

    resolve.conf already had domain.local. So the issue had to be elsewhere.



  • I don't remember where I found it, but there was another possible solution to fix it by changing a line in /etc/nsswitch.conf

    # Default setting
    hosts:      files mdns4_minimal [NOTFOUND=return] dns myhostname
    
    # Noticed dns is now in front of mdns4_minimal
    hosts:      files dns mdns4_minimal [NOTFOUND=return] myhostname
    

Log in to reply