The week from printer hell...



  • So I'm fighting a printer issue right now. HP LaserJet P4015n. It is mapped through a print server that's Server '03. It's shared. The IP is .213. Now, I cannot ping it. I can ping other printers shared through the same server. The user trying to print to it can print from a proprietary program for hotels called Galaxy. It's a PMS (Property Management System). However, printing from Word, Excel, Notepad, Outlook or anything else hangs the queue and never work. If you go in and cancel all those documents, which cancel fine, the printer goes back to a ready state.

    I have checked drivers. That's not it. They had a IP scanning program of some sort on there. It scans and finds the IP but the hostname is some weird and long string. It detects it as an HP device though. The other HP printers, also LaserJets (just other models) are working, pinging, all of it, fine. I have not yet had the users print a config page. That will be my first step tomorrow.

    I know what you're thinking. It's USB. Well, the Galaxy program can only print to network printers, so that's not an option. It's not connected USB to the server as where it's located in the building is nowhere near the servers.

    For the life of me I cannot figure out why one would work and the other wouldn't. I know ICMP packets aren't blocked internally. I can't access the web interface of the device. I've thought about IP address conflicts, a failing NIC on the device, bad cable, etc. I am not located or anywhere near this location so testing those personally is out of the question. I am going to try a couple of things tomorrow, primarily getting that config page.

    Next, an HP LaserJet M401n. The thing would be plugged in to the network but not work. If you unplugged the network connection and tried installing it via USB, it would install and even show as ready but never print. We couldn't figure out how to get this thing working. We removed and reinstalled drivers, etc. Nothing.

    Well, stupid me forgot KISS. We fought all this time to map it (they were trying by IP and I was going to go through the print server like the rest of their printers were). I never had the guy reset the network settings. So, I removed the printer and driver from the workstation completely, he reset the network settings (which took more than 5 minutes for some odd reason) and let it pull via DHCP. It finally did and then I switched it all to static, added to the server, shared it out and huzzah! It works!

    Combine that with a network newly added to a domain where everyone had static IPs set with the wrong DNS servers so no one can get online and we can't really get remote access and you have what's been a majority of my week. I'm backed up on tickets I really need to address and just literally don't have time to. I would work overtime if I had to! But I can't...and here we go...lol

    Glad it's Friday coming up! TGIF

    Thanks,
    A.J.



  • Sounds like you are having a lot of "fun" over there 🙂



  • @scottalanmiller said:

    Sounds like you are having a lot of "fun" over there 🙂

    You have no idea...you don't even want to know how some of these networks and/or servers are laid out...



  • I really hate printers.



  • @Reid-Cooper said:

    I really hate printers.

    I actually like them. I'm VERY good with them. This week just seems to be the week of printers. Chaos theory...



  • @Reid-Cooper said:

    I really hate printers.

    Here Here!



  • had a similar problem after phasing out an old dns server. had a few stations that were static (rest were dhcp). The static computers were obviously pointed at the old dns server...which was dead. Set the static pcs to the new dns, flush and registered the dns on the computers..and fixed it right up.



  • Have you tried turning it on and off again? 😉

    (In this context, it IS patronising)

    /jk



  • @scottalanmiller said:

    Sounds like you are having a lot of "fun" over there 🙂

    Haha Yes I told him before its really Fun 🙂


Log in to reply