Install Elastix 2.5 on CloudatCost - Not Possible :(


  • Service Provider

    I reimaged my [email protected] machine to CentOS 6.5 and did the basics.

    yum-y update
    yum -y install epel-release
    yum -y install nano fail2ban htop sysstat
    cd /tmp
    wget http://www.sourceforge.net/projects/elastix/files/Elastix%20PBX%20Appliance%20Software/2.5.0/Elastix-2.5.0-Stable-x86_64-bin-21oct2014.iso/download
    mkdir /mnt/iso
    mount -t iso9660 -o loop /tmp/Elastix-2.5.0-Stable-x86_64-bin-21oct2014.iso /mnt/iso
    nano /etc/yum.repos.d/elastix-cd.repo
    

    [elastix-cd]
    name=Elastix RPM Repo CD
    baseurl=file:///mnt/iso/
    gpgcheck=0
    enabled=1

    yum install elastix
    

    The Problem, Packages are too new? Those look like they are wanting CentOS 5 packages?

    --> Finished Dependency Resolution
    Error: Package: spamassassin-3.3.1-4.el5.x86_64 (elastix-cd)
    		   Requires: perl(:MODULE_COMPAT_5.8.8)
    		   Available: 4:perl-5.8.8-41.el5.x86_64 (elastix-cd)
    			   perl(:MODULE_COMPAT_5.8.8)
    		   Available: 4:perl-5.10.1-136.el6.x86_64 (base)
    			   Not found
    		   Installing: 4:perl-5.10.1-136.el6_6.1.x86_64 (updates)
    			   Not found
    Error: Package: python-daemon-1.5.2-3.el5.noarch (elastix-cd)
    		   Requires: python(abi) = 2.4
    		   Installed: python-2.6.6-52.el6.x86_64 (@base)
    			   python(abi) = 2.6
    		   Available: python-2.4.3-56.el5.x86_64 (elastix-cd)
    			   python(abi) = 2.4
    Error: Package: 2009020507:asterisk-11.13.0-0.x86_64 (elastix-cd)
    		   Requires: libcurl.so.3()(64bit)
    		   Available: curl-7.15.5-17.el5_9.x86_64 (elastix-cd)
    			   libcurl.so.3()(64bit)
    		   Installed: curl-7.19.7-40.el6_6.4.x86_64 (@updates)
    			   Not found
    		   Available: curl-7.19.7-37.el6_5.3.x86_64 (base)
    			   Not found
    		   Available: curl-7.19.7-40.el6_6.1.x86_64 (updates)
    			   Not found
    		   Available: curl-7.19.7-40.el6_6.3.x86_64 (updates)
    			   Not found
    Error: Package: 2009020507:asterisk-11.13.0-0.x86_64 (elastix-cd)
    		   Requires: librpmio-4.4.so()(64bit)
    		   Available: rpm-libs-4.4.2.3-34.el5.x86_64 (elastix-cd)
    			   librpmio-4.4.so()(64bit)
    		   Installed: rpm-libs-4.8.0-38.el6_6.x86_64 (@updates)
    			   Not found
    		   Available: rpm-libs-4.8.0-37.el6.i686 (base)
    			   Not found
    Error: Package: python-paramiko-1.7.6-2.noarch (elastix-cd)
    		   Requires: python(abi) = 2.4
    		   Installed: python-2.6.6-52.el6.x86_64 (@base)
    			   python(abi) = 2.6
    		   Available: python-2.4.3-56.el5.x86_64 (elastix-cd)
    			   python(abi) = 2.4
    Error: Package: py-Asterisk-0.5.2-1.noarch (elastix-cd)
    		   Requires: python(abi) = 2.4
    		   Installed: python-2.6.6-52.el6.x86_64 (@base)
    			   python(abi) = 2.6
    		   Available: python-2.4.3-56.el5.x86_64 (elastix-cd)
    			   python(abi) = 2.4
    Error: Package: elastix-portknock-0.0.1-0.x86_64 (elastix-cd)
    		   Requires: libpcap.so.0.9.4()(64bit)
    		   Available: 14:libpcap-0.9.4-15.el5.x86_64 (elastix-cd)
    			   libpcap.so.0.9.4()(64bit)
    		   Available: 14:libpcap-1.4.0-1.20130826git2dbcaa1.el6.i686 (base)
    			   Not found
    Error: Package: 1:perl-Archive-Tar-1.39.1-1.el5_5.2.noarch (elastix-cd)
    		   Requires: perl(:MODULE_COMPAT_5.8.8)
    		   Available: 4:perl-5.8.8-41.el5.x86_64 (elastix-cd)
    			   perl(:MODULE_COMPAT_5.8.8)
    		   Available: 4:perl-5.10.1-136.el6.x86_64 (base)
    			   Not found
    		   Installing: 4:perl-5.10.1-136.el6_6.1.x86_64 (updates)
    			   Not found
    Error: Package: 2009020507:asterisk-11.13.0-0.x86_64 (elastix-cd)
    		   Requires: librpm-4.4.so()(64bit)
    		   Available: rpm-libs-4.4.2.3-34.el5.x86_64 (elastix-cd)
    			   librpm-4.4.so()(64bit)
    		   Installed: rpm-libs-4.8.0-38.el6_6.x86_64 (@updates)
    			   Not found
    		   Available: rpm-libs-4.8.0-37.el6.i686 (base)
    			   Not found
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

  • Service Provider

    Elastix 2 is a CentOS 5 based system only.


  • Service Provider

    @scottalanmiller said:

    Elastix 2 is a CentOS 5 based system only.

    Hrmf, I thought 2.5 was able to go on 6.5, bleh. Yet another reason I do not like Elastix anymore.


  • Service Provider

    @JaredBusch said:

    @scottalanmiller said:

    Elastix 2 is a CentOS 5 based system only.

    Hrmf, I thought 2.5 was able to go on 6.5, bleh. Yet another reason I do not like Elastix anymore.

    I don't believe so, I think only 3 can do CentOS 6. The need for CentOS 5 has been a huge issue for years.


  • Service Provider

    Asterisk GUI is not there yet in usability. It functions, but the usability is just lacking yet.

    I am leery of FreePBX due to the Sangoma buy out.

    Elastix is only stable on an old as dirt system.

    Just damnit.