Problem migrating vlans from 3Com Baseline to Cisco C3750X



  • Hi.

    I'm migrating a 3Com Baseline router for a new Cisco C3750X, everything works but I have problem with 1 Vlan.

    In 3Com I have this configuration, an Ubitiqui Wifi with two Vlan (one for Lan (Vlan 3) and one for Guest (Vlan 99) in 3Com port 38

    In 3Com port 20 I connect to Pfsense Firewall and Captive portal service to provide Wifi to the guest (Vlan 99)

    This is 3com Configuration:

    3com.jpg

    *#

    interface GigabitEthernet1/0/38

    port link-type trunk

    undo port trunk permit vlan 1

    port trunk permit vlan 3 99

    port trunk pvid vlan 3

    stp edged-port enable

    interface GigabitEthernet1/0/20

    port link-type trunk

    undo port trunk permit vlan 1

    port trunk permit vlan 99

    stp edged-port enable

    #*

    I try to replicate the same in a Cisco C3750X but I'm unable to make it works.

    This is how I have configured the ports:

    *interface GigabitEthernet2/0/38

    switchport access vlan 3

    switchport trunk allowed vlan 99

    switchport trunk encapsulation dot1q

    switchport mode trunk

    interface GigabitEthernet2/0/20

    switchport trunk allowed vlan 99

    switchport trunk encapsulation dot1q

    switchport mode trunk*

    Could someone help me with this configuration ?

    Thanks a lot.



  • Problem solve.

    In Cisco Switch you cannot add an Access port to a Trunk port, instead you need to create a native Vlan and add the Vlan to the Trunk configuration.

    This is the correct way:

    interface GigabitEthernet2/0/38
    switchport trunk allowed vlan 3,99
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 3
    switchport mode trunk
    end

    Regards


Log in to reply