Running Xrdp on Ubuntu



  • @scottalanmiller said in Running Xrdp on Ubuntu:

    @JaredBusch said in Running Xrdp on Ubuntu:

    Are you just wanting RDP from Ubuntu to Windows? I use Remmina on Fedora with Cinnamon.

    I think that he is trying to run XRDP, the server.

    Ah, read that backwards. Apparently, I need more coffee.



  • Have you tried looking in /etc/X11/Xwrapper.config ?

    Make sure that you have...

    allowed_users = anybody


  • Is your VNC server running correctly? Use netstat to see if it is listening.



  • There's a couple of things to check.

    The first and foremost is make sure your distro is using X and not Wayland. Someone here pointed out the right file to check for that. In Fedora, You check /etc/gdm/custom.conf, you uncomment the line #WaylandEnable=false

    Thanks to @black3dynamite for the pointers on Fedora.

    I'll echo @StrongBad 's suggestion to check /etc/X11/Xwrapper.config -- if it doesn't exist, then create it with the settings he listed.

    You will also have better performance with a desktop environment like MATE or XFCE, rather than Cinnamon or Gnome.



  • Also, what version of Ubuntu are you using?



  • Ran into this tonight ...Screenshot from 2019-02-04 20-16-38.png



  • @dafyre said in Running Xrdp on Ubuntu:

    Also, what version of Ubuntu are you using?

    ~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 18.04.1 LTS
    Release:	18.04
    Codename:	bionic
    


  • @StrongBad said in Running Xrdp on Ubuntu:

    Have you tried looking in /etc/X11/Xwrapper.config ?

    Make sure that you have...

    allowed_users = anybody
    

    It was set as

    allowed_users=console
    

    updated.



  • Post change - Repeats,.. can't get out of it asking... but - step forward...
    2019-02-04 20_35_54-Window.png



  • Ha... joy

    Can't even sign in at the local. Select UserName, enter password, repeats.... sigh..

    FML



  • uname -r
    4.15.0-45-generic
    
    [email protected]:~$ sudo apt-get autoremove --purge
    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up grub-efi-amd64-signed (1.93.11+2.02-2ubuntu8.10) ...
    /boot/vmlinuz-4.15.0-43201901161620-generic is unsigned.
    E: Your kernels are not signed with a key known to your firmware. This system will fail to boot in a Secure Boot environment.
    dpkg: error processing package grub-efi-amd64-signed (--configure):
     installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 1
    Errors were encountered while processing:
     grub-efi-amd64-signed
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    [email protected]:~$ dpkg -l | tail -n +6 | grep -E 'linux-image-[0-9]+'
    rc  linux-image-4.15.0-29-generic                      4.15.0-29.31                                 amd64        Signed kernel image generic
    rc  linux-image-4.15.0-43-generic                      4.15.0-43.46                                 amd64        Signed kernel image generic
    ii  linux-image-4.15.0-44-generic                      4.15.0-44.47                                 amd64        Signed kernel image generic
    ii  linux-image-4.15.0-45-generic                      4.15.0-45.48                                 amd64        Signed kernel image generic
    
    


  • Before I say anything more, I have a question... Is this a system that's you're going to use locally and remotely, or will you be using it via RDP mostly?



  • @dafyre said in Running Xrdp on Ubuntu:

    Before I say anything more, I have a question... Is this a system that's you're going to use locally and remotely, or will you be using it via RDP mostly?

    For the now, it's sitting right here next to my desktop. But the idea is to be able to remote both ways (remmina works fine to Windows) so I only need to use the one keyboard/mouse/monitor(s).

    I could use VNC - if I could get it to work... but for some reason it's 'failing'..

    now,.. reversing the recent update/ installs I've done I get:

    Setting up grub-efi-amd64-signed (1.93.11+2.02-2ubuntu8.10) ...
    /boot/vmlinuz-4.15.0-43201901161620-generic is unsigned.
    E: Your kernels are not signed with a key known to your firmware. This system will fail to boot in a Secure Boot environment.
    dpkg: error processing package grub-efi-amd64-signed (--configure):
     installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 1
    Processing triggers for libc-bin (2.27-3ubuntu1) ...
    Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
    Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Errors were encountered while processing:
     grub-efi-amd64-signed
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    

    Looking at the listed kernels now:

    :~$ dpkg -l | tail -n +6 | grep -E 'linux-image-[0-9]+'
    rc  linux-image-4.15.0-29-generic                      4.15.0-29.31                                 amd64        Signed kernel image generic
    rc  linux-image-4.15.0-43-generic                      4.15.0-43.46                                 amd64        Signed kernel image generic
    pi  linux-image-4.15.0-44-generic                      4.15.0-44.47                                 amd64        Signed kernel image generic
    pi  linux-image-4.15.0-45-generic                      4.15.0-45.48                                 amd64        Signed kernel image generic
    
    

    Odd that 44 and 45 were listed as ii and now so as pi



  • Not sure what to do about the EFI issue....

    What I do when I want to use mine like that is set up x11vnc-server and then run it through XRDP (and choose the console option). It's faster than stock VNC... Don't ask me why, lol. I haven't gotten instructions for that yet, I don't think.

    If I remember right, after a reboot, you have to connect, close the connection, and then reconnect back using the XRDP+VNC option. I don't have any installation instructions for that setup on hand though. I can work it out and post them if you like.



  • @dafyre said in Running Xrdp on Ubuntu:

    Not sure what to do about the EFI issue....

    What I do when I want to use mine like that is set up x11vnc-server and then run it through XRDP (and choose the console option). It's faster than stock VNC... Don't ask me why, lol. I haven't gotten instructions for that yet, I don't think.

    If I remember right, after a reboot, you have to connect, close the connection, and then reconnect back using the XRDP+VNC option. I don't have any installation instructions for that setup on hand though. I can work it out and post them if you like.

    This is likely where I went 'rouge' in that I didn't use x11vnc-server.. I had notes on that,.. at least I believe and have misplaced them. so I had forget that.

    As I was starting to have other 'OS' Kernel issues (the mouse and keyboard wasn't working correctly) I nuked that partition from Windows, and will rebuild. Maybe it'll survive as I am of course getting grub 'errors' since that partition is gone.