Exchange on-prem HTTP not redirecting



  • I am getting stumped on this one. I was cross-checking some other environments to make sure co-workers environments are up-to-snuff (pretty standard... fresh set of eyes).

    I noticed there are 3 environments with on-prem Exchange that don't automatically redirect from HTTP to HTTPS. They require SSL, and I looked at issue tracking and we do get a lot of tickets saying "email doesn't work" with a simple response of "you have to put HTTPS". So, I went down the road of fixing that.

    All 3 will be on Office 365 Q2 next year, but I'd like to fix it in the meantime. The 3 environments are Exchange 2010, 2013, and 2016 (all on the latest possible CUs).

    Worth noting that I've tried this using various systems on different networks and also using various browsers, thinking maybe it was something on the endpoint side (cached, browser-related, etc).

    The most complete guide I've found (albeit, it's 2010) and through a ton of threads finding that it still applies to 2013/2016 is this... https://www.vspbreda.nl/nl/exchange/1409/

    I've also gone to C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\web.config and tried adjusting the following line: <httpRedirect enabled="false" destination="https://mail.domain.com/owa"; childOnly="true" />

    Anyone got any ideas?

    Edit: I'm not receiving an error page, where I'd need to do an absolute link in the Error Pages section of IIS; nonetheless, I had tried that anyway.


Log in to reply