Migrating SnipeIT to new server



  • I have a snipe-it server (an old one, setup and upgraded through old versions to 4 now (4.1.0 build beta2). Had some issues and was unable to move forward to the latest version from that. I have around 700+ assets on it and wanted to setup a new server with latest version and migrate the data over to the new one.

    I setup another CentOS7 version (i know that the common choice at ML now is Fedora, I need to test it out, but wanted to concentrate on snipe-it migration first to get it up and running on latest version). Installed snipe-it, went through the initial pre-flight configuration and got the first page on snipe-it. From there, i tried to use the SQL file from old server (which i got from the old server via admin panel backup, which has the sql file and 3 folders (storage, config & public). The moment i restore the db, and replace these 3 folders, the site starts showing the default Apache welcome page.

    I thought it might be due to some configuration issues, and tried on a new setup again but this time used the snipeit.sh. All i did on the server was to install git and updated the server. Then ran snipeit.sh which did the rest (install apache, php 7.1, composer etc and setting up snipe-it) Got the site up and running, and again after restoring the old data back to the welcome page.

    Anyone here did a migration successfully to another server?



  • And if i run php artisan config:clear

    PHP Fatal error:  Uncaught Error: Class 'Log' not found in /var/www/html/snipeit/app/Exceptions/Handler.php:39
    Stack trace:
    #0 /var/www/html/snipeit/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(320): App\Exceptions\Handler->report(Object(Symfony\Component\Debug\Exception\FatalThrowableError))
    #1 /var/www/html/snipeit/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(132): Illuminate\Foundation\Console\Kernel->reportException(Object(Symfony\Component\Debug\Exception\FatalThrowableError))
    #2 /var/www/html/snipeit/artisan(35): Illuminate\Foundation\Console\Kernel->handle(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
    #3 {main}
      thrown in /var/www/html/snipeit/app/Exceptions/Handler.php on line 39


  • Tried another setup, this time after the initial setup, i just imported the SQL file and the site was fine with the old server data. Later on carefully checked and compared the differences in public, storage and config folder and moved data over to the new server (it was just the images) and cleared cache. Everything seems to be working fine as intended.


Log in to reply