NextCloud skipping files based on extension



  • Hello all,
    New NextCloud installation, Ubuntu Server 17.10, I got it to work just fine right out of the box (the only "major" change being the data folder). I downloaded the client (also under Ubuntu) configured a few folders, and as far as I can tell, they're all getting backed up successfully, with the exception of the default blacklist list of files/extensions. All is well except for one problem. I have a folder with a few video files in various formats (avi, flv, mpeg, mp4, etc) and they all get copied over EXCEPT for the mp4 files. It's not a size issue, I have larger files getting copied over just fine. The files not being copied are anywhere between 30-500 mb.

    The client reports an error (sorry, not at home right now, can't copy paste) along the lines of the "server replied: Forbidden (Sabre\DAV\Exception\Forbidden)"

    Any idea where I might look for the cause?



  • mp4 files is not included in the ignored files.



  • Do you have any apps in Nextcloud enabled that could be blocking mp4 files?



  • You probably need to go into the client settings and uncheck the ask for confirmation before sync folders larger than 500 MB box.

    0_1516756776986_be83d5b2-7c8d-42c9-a43b-c8d8a4a9da67-image.png



  • @jaredbusch Thanks. As stated in my original post tho, the files are not near that limit, and larger files are being transferred. Also, that checkbox is already unchecked.

    @black3dynamite The only apps are the ones that came pre-installed by default. I didn't add or remove any files from the standard installation.

    Just to add to this, looking at the "not synced" on the client side, I see other files, but those I can already tell why. They have "non-standard" characters in the filename. So I'm guessing that's causing an issue. In the case of those mp4 however, there's no unusual characters, the filenames are not unusually long.

    This was on 12.0.4. I just saw that .5 is out, so I'm updating it in case that helps, but that being said, is there anywhere on the server side where I can find exclusion filters?

    Edit:
    Upon further digging, this doesn't appear to be based on file extension, as I did find multiple mp4 files in different folders. I'm at a loss as to why some of the files don't get copied over. And just to add to earlier comments, the larger file (in one of the folder where files don't get copied) is about 180 megs.





  • On the client-side, are you using Windows? If so, try disabling your antivirus to see if its interfering with the syncing?



  • @dbeato no, I don't think so. It's not happening after a "move to a different server". Files were not moved manually, they were done by the client. I reindexed (occ) in case it helped, but no difference.

    @black3dynamite Not windows, Ubuntu 17.10.


Log in to reply