Unable to add Japanese IME keyboard to Korora 25 Cinnamon

  • Service Provider

    So I switched. Great. But now, I cannot figure out how to add the Japanese IME keyboard layout to Korora.

    Google results are kicking back answers for Fedora 20 and nothing matches up.

    I know how to add a keyboard layout. That is easy. There are like 6 Japanese options listed. But none of them are the IME keyboard.

  • Service Provider

    And I had apparently found the solution but it did not show up until I rebooted.

    dnf install -y ibus-anthy

  • Service Provider

    So to completely answer the question I posited.

    Install ibus-anthy

    dnf -y install ibus-anthy

    Next run input selector from the CLI or GUI.

    Change the Input method from "No Input Method" to "IBus"

    Note, the preferences link here does NOT work for me.

    Log out and back in, and you will see the language selector up by the clock in the tray.


    Right click and choose preferences.

    Switch to the Input Method tab and click Add.

    Select the language you want to add.

    Select the input type for the language. In this case we want Anthy in order to get the Romaji entry of the Kana.

    As a side note, my wife does not use the Kana Kanji input method. I am not sure how many Japanese actually use that input method. The one time I put my laptop into that mode, she could not type.

    After adding Anthy, you can click prefernces and make any custom changes you want.


    The other thing you will want to do is setup a key combo to switch languages.
    I like the alt + backtick (grave)
    Click the button after the next method and setup whatever key combo you want.



Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.