Gnome 3 RHEL 7 and dconf



  • So I need to make some Gnome 3 changes for SCAP. However I'm still failing a couple checks even though they seem to be in place.

    Disable User Administration, Disable Power Settings, and Disable Geolocation.

    In /etc/dconf/db/local.d/00-security-settings I have:

    [org/gnome/desktop/lockdown]
    disable-applications-handlers=true
    user-administration-disabled=true
    
    [org/gnome/settings-daemon/plugins/power]
    active=false
    
    [org/gnome/system/location]
    enabled=false
    

    My lock file /etc/dconf/db/local.d/locks/00-security-settings has:

    /org/gnome/desktop/lockdown/disable-applications-handlers
    /org/gnome/desktop/lockdown/user-administration-disabled
    /org/gnome/settings-damon/plugins/power/active
    org/gnome/system/location/enabled
    

    All are locked except for location. I can check and uncheck in dconf-editor which is weird. But I'm still failing the test on all of them. Any ideas?



  • Afraid that I never do Gnome 3 tweaking.



  • @scottalanmiller said in Gnome 3 RHEL 7 and dconf:

    Afraid that I never do Gnome 3 tweaking.

    Thanks. I think a good bit of it is pointless but oh well.



  • So I found out that a couple of the other failures I had were due to misspellings in their check scripts. Without going back through everything, I'm assuming that's what's happening here.

    Things like this line

    user-administration-disabled=true
    

    failing because the check was looking for

    user-administratrion-enabled=true
    

    Both a misspelling and the wrong key value.


Log in to reply