Building Elastix 4 via RPM Repo


  • Service Provider

    Doing some work today getting an Elastix 4 server built on a cloud platform on CentOS 7. This, of course, requires some additional work compared to a normal install where you are able to just use the ISO installation method. So rather than just figure it out, I decided that it would be better to script the install. Not hard at all, here you go. This is not a fast install and far from perfect, but thus far, it works.

    #!/bin/bash
    # SAM's Elastix 4 on CentOS 7 Installation and Build Script
    # Tested on Digital Ocean, Must be Run as Root
    
    yum -y install epel-release
    yum -y install htop glances screen fail2ban wget sysstat net-tools
    yum -y update
    dd if=/dev/zero of=/swapfile1 bs=1024 count=1048576
    chown root:root /swapfile1
    chmod 0600 /swapfile1
    mkswap /swapfile1
    swapon /swapfile1
    echo '/swapfile1 none swap sw 0 0' >> /etc/fstab
    cd /tmp
    wget https://sourceforge.net/projects/elastix/files/Elastix%20PBX%20Appliance%20Software/4.0.0/Elastix-4.0.74-Stable-x86_64-bin-10Feb2016.iso/download
    mv download elastix4.iso
    mkdir /mnt/elastix4
    mount -o loop /tmp/elastix4.iso /mnt/elastix4/
    cat > /etc/yum.repos.d/Elastix.repo <<EOF
    [Elastix-cd]
    name=Elastix-cd
    baseurl=file:///mnt/elastix4/
    gpgcheck=0
    enabled=1
    EOF
    cd /mnt/elastix4/Elastix
    for i in $(ls); do yum -y install $i; done
    for i in $(ls); do yum -y install $i; done
    systemctl enable mariadb.service
    systemctl enable httpd
    systemctl enable firewalld
    systemctl start firewalld
    firewall-cmd --zone=public --add-port=443/tcp --permanent
    firewall-cmd --reload
    systemctl start mariadb
    /etc/init.d/elastix-firstboot start && reboot
    

    This build asks for two passwords at the end. It will automatically reboot and you should be able to log in with the username admin and the second password that you provided once the reboot completes.

    https://ipofyourserver/

    While this build process works, I must add this warning here... Elastix 4 has proven to be very flaky and I am not recommending that it be used at this time. Hopefully the Elastix team will get things working well and updated regularly, but at the moment this is not the case. If you are interested in this purely to see what Elastix 4 is like, go for it. If you want to run a system in product, I highly recommend that you look at FreePBX instead. Same basic technologies but far better support and much more up to date and used far more heavily today. We will all do our best to support you on Elastix, but you will have a much better time on FreePBX with the current state of things.


  • Service Provider

    After the initial install and reboot you will need to run these commands in order for its reboot setup to be successful - they missed a few steps in their configuration script...

    systemctl enable mariadb.service
    systemctl enable httpd.server
    reboot
    

    Only after doing this and rebooting will the console setup script function.



  • I get a bunch of errors during the elastix installation. Is this "normal" or am I doing something wrong?

       Installing : php-gd-5.4.16-36.el7_1.x86_64                                                                                    212/252
       Installing : php-tcpdf-6.2.11-1.el7.noarch                                                                                    213/252
        0:adding group asterisk...
     usermod: user 'asterisk' does not exist
     error: %pre(elastix-framework-2.5.0-6.noarch) scriptlet failed, exit status 6
     Error in PREIN scriptlet in rpm package elastix-framework-2.5.0-6.noarch
       Installing : elastix-im-2.5.0-1.noarch                                                                                        215/252
     error: elastix-framework-2.5.0-6.noarch: install failed
     /var/tmp/rpm-tmp.bm201q: line 3: elastix-menumerge: command not found
     chown: invalid user: ‘asterisk.asterisk’
       Installing : elastix-addons-2.5.0-2.noarch                                                                                    216/252
     /var/tmp/rpm-tmp.pP4EPM: line 4: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.pP4EPM: line 12: elastix-dbprocess: command not found
     CentOS base install too new, removing PostgreSQL repository...
     chown: invalid user: ‘asterisk.asterisk’
       Installing : elastix-extras-2.5.0-1.noarch                                                                                    217/252
     /var/tmp/rpm-tmp.1gGKnY: line 3: elastix-menumerge: command not found
     chown: invalid user: ‘asterisk.asterisk’
       Installing : RoundCubeMail-0.3.1-12.noarch                                                                                    218/252
     warning: user asterisk does not exist - using root
     warning: user asterisk does not exist - using root
     warning: user asterisk does not exist - using root
     warning: user asterisk does not exist - using root
     warning: user asterisk does not exist - using root
     /var/tmp/rpm-tmp.5qLoJn: line 4: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.5qLoJn: line 11: elastix-dbprocess: command not found
     warning: %post(RoundCubeMail-0.3.1-12.noarch) scriptlet failed, exit status 127
     Non-fatal POSTIN scriptlet failure in rpm package RoundCubeMail-0.3.1-12.noarch
       Installing : libXt-1.1.4-6.1.el7.x86_64                                                                                       219/252
       Installing : ghostscript-9.07-18.el7.x86_64                                                                                   220/252
       Installing : 20150304:hylafax-4.3.11-1rh7.x86_64                                                                              221/252
     #########################################################
     #            HylaFAX installation complete!             #
     #                                                       #
     #      You should now run /usr/sbin/faxsetup to         #
     #       create or update HylaFAX configuration          #
     #      before you can begin using the software.         #
     #                                                       #
     #########################################################
     Creating symbolic link: ln -s /usr/share/ghostscript/9.07/Resource/Init/Fontmap.GS /usr/share/ghostscript/9.07/lib/Fontmap.GS
     Creating symbolic link: ln -s /usr/share/fonts/default/Type1/n022004l.afm /usr/share/fonts/default/Type1/Courier-Bold
       Installing : liballogsmat-2.0.7-1.el7.centos.x86_64                                                                           222/252
       Installing : libgsmat-2.0.8-0.el7.centos.x86_64                                                                               223/252
       Installing : MySQL-python-1.2.3-11.el7.x86_64                                                                                 224/252
       Installing : pyparsing-1.5.6-9.el7.noarch                                                                                     225/252
       Installing : systemtap-sdt-devel-2.6-10.el7_1.x86_64                                                                          226/252
       Installing : 1:perl-ExtUtils-ParseXS-3.18-2.el7.noarch                                                                        227/252
       Installing : 4:perl-devel-5.16.3-285.el7.x86_64                                                                               228/252
       Installing : perl-ExtUtils-Install-1.58-285.el7.noarch                                                                        229/252
       Installing : perl-ExtUtils-MakeMaker-6.68-3.el7.noarch                                                                        230/252
       Installing : spamassassin-3.4.0-1.el7.x86_64                                                                                  231/252
       Installing : elastix-email_admin-2.5.0-2.noarch                                                                               232/252
     Error unpacking rpm package elastix-email_admin-2.5.0-2.noarch
     error: unpacking of archive failed on file /var/www/html/libs/cyradm.php;56104c46: cpio: open
       Installing : 2:xinetd-2.3.15-12.el7.x86_64                                                                                    233/252
     error: elastix-email_admin-2.5.0-2.noarch: install failed
       Installing : tftp-server-5.2-11.el7.x86_64                                                                                    234/252
       Installing : 1:python-lockfile-0.9.1-4.el7.noarch                                                                             235/252
       Installing : python-daemon-1.6-4.el7.noarch                                                                                   236/252
       Installing : libusbx-1.0.15-4.el7.x86_64                                                                                      237/252
       Installing : 1:libusb-0.1.4-3.el7.x86_64                                                                                      238/252
     Looking for legacy zapata/zaptel configuration...
       Installing : dahdi-2.10.0.1-3.el7.centos.x86_64                                                                               239/252
     Scanning for supported devices...
     The following detected devices were written to /etc/dahdi/modules :
     
     # Autogenerated by /usr/sbin/dahdi_genconf (Dahdi::Config::Gen::Modules) on Sat Oct  3 17:46:04 2015
     # If you edit this file and execute /usr/sbin/dahdi_genconf again,
     # your manual changes will be LOST.
     
     
     End of module list for detected devices.
     Adding new user asterisk...
       Installing : 2009020507:asterisk-11.15.0-2.el7.centos.x86_64                                                                  240/252
     Adding calltokenoptional directive to iax_general_custom.conf for IAXMODEM compatibility...
     No MOHDIR directive found in /etc/amportal.conf, setting to mohmp3 ...
     Replacing instances of moh with mohmp3 in /etc/asterisk/musiconhold.conf ...
       Installing : iaxmodem-1.2.0-2.el7.centos.x86_64                                                                               241/252
       Installing : elastix-fax-2.5.0-2.noarch                                                                                       242/252
     /var/tmp/rpm-tmp.0dN4gB: line 54: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.0dN4gB: line 63: elastix-dbprocess: command not found
     chmod: cannot access ‘/var/www/db/fax.db’: No such file or directory
     warning: %post(elastix-fax-2.5.0-2.noarch) scriptlet failed, exit status 1
     Non-fatal POSTIN scriptlet failure in rpm package elastix-fax-2.5.0-2.noarch
       Installing : elastix-system-2.5.0-2.noarch                                                                                    243/252
     /var/tmp/rpm-tmp.Kk42xM: line 4: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.Kk42xM: line 12: elastix-dbprocess: command not found
       Installing : elastix-reports-2.5.0-3.noarch                                                                                   244/252
     /var/tmp/rpm-tmp.0xcCW1: line 3: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.0xcCW1: line 12: elastix-dbprocess: command not found
       Installing : asterisk-perl-1.03-0.noarch                                                                                      245/252
       Installing : elastix-my_extension-2.5.0-1.noarch                                                                              246/252
     /var/tmp/rpm-tmp.qBIyFF: line 3: elastix-menumerge: command not found
     Error: no such table: menu
     Error: no such table: acl_resource
     Error: no such table: acl_group
       Installing : elastix-endpointconfig2-2.5.0-1.noarch                                                                           247/252
     /var/tmp/rpm-tmp.AYj7HY: line 4: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.AYj7HY: line 12: elastix-dbprocess: command not found
     Redirecting to /bin/systemctl restart  httpd.service
     /var/tmp/rpm-tmp.AYj7HY: line 22: elastix-menuremove: command not found
       Installing : freePBX-2.11.0-20.noarch                                                                                         248/252
     Assumed ISO installation. Delayed database installation until first Elastix boot...
     Backing up old /etc/asterisk/extensions.conf as /etc/asterisk/extensions.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/iax.conf as /etc/asterisk/iax.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/sip.conf as /etc/asterisk/sip.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/features.conf as /etc/asterisk/features.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/sip_notify.conf as /etc/asterisk/sip_notify.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/res_odbc.conf as /etc/asterisk/res_odbc.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/logger.conf as /etc/asterisk/logger.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/confbridge.conf as /etc/asterisk/confbridge.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/cel.conf as /etc/asterisk/cel.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/cel_odbc.conf as /etc/asterisk/cel_odbc.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/rtp.conf as /etc/asterisk/rtp.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/udptl.conf as /etc/asterisk/udptl.conf.old_freePBX-2.11.0-20
     Backing up old /etc/asterisk/http.conf as /etc/asterisk/http.conf.old_freePBX-2.11.0-20
     ln: failed to create symbolic link ‘/var/www/html/images/notify_critical.png’: No such file or directory
     Replacing instances of moh with mohmp3 in /etc/asterisk/musiconhold_additional.conf ...
     Replacing instances of moh with mohmp3 in /etc/asterisk/musiconhold.conf ...
     Replacing instances of moh with mohmp3 in /etc/asterisk/musiconhold_custom.conf ...
     creando directorio /var/www/address_book_images
       Installing : elastix-agenda-2.5.0-2.noarch                                                                                    249/252
     /var/tmp/rpm-tmp.mNB2PW: line 4: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.mNB2PW: line 13: elastix-dbprocess: command not found
       Installing : elastix-pbx-2.5.0-4.noarch                                                                                       250/252
     File extensions_override_freepbx.conf in asterisk exits, verifying macro record-enable and hangupcall exists...
     macros elastix was written.
     /etc/asterisk/sip_notify_custom.conf exists, verifying the inclusion of sip_notify_custom_elastix.conf
     including sip_notify_custom_elastix.conf...
     /var/tmp/rpm-tmp.EdFUvx: line 79: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.EdFUvx: line 88: elastix-dbprocess: command not found
     Error: no such table: acl_resource
     Error: no such table: acl_group
     PHP Warning:  require_once(/var/www/html/libs/paloSantoDB.class.php): failed to open stream: No such file or directory in /tmp/new_module/pbx/setup/installer.php on line 30
     PHP Fatal error:  require_once(): Failed opening required '/var/www/html/libs/paloSantoDB.class.php' (include_path='.:/usr/share/pear:/usr/share/php') in /tmp/new_module/pbx/setup/installer.php on line 30
     /var/tmp/rpm-tmp.EdFUvx: line 132: elastix-menuremove: command not found
     warning: %post(elastix-pbx-2.5.0-4.noarch) scriptlet failed, exit status 127
     Non-fatal POSTIN scriptlet failure in rpm package elastix-pbx-2.5.0-4.noarch
       Installing : elastix-security-2.5.0-1.noarch                                                                                  251/252
     /var/tmp/rpm-tmp.y3u92a: line 4: elastix-menumerge: command not found
     /var/tmp/rpm-tmp.y3u92a: line 12: elastix-dbprocess: command not found
       Installing : elastix-2.5.0-1.noarch                                                                                           252/252
     
     Installed:
       elastix.noarch 0:2.5.0-1
     
     Dependency Installed:
       MySQL-python.x86_64 0:1.2.3-11.el7                               RoundCubeMail.noarch 0:0.3.1-12
       apr.x86_64 0:1.4.8-3.el7                                         apr-util.x86_64 0:1.5.2-6.el7
       asterisk.x86_64 2009020507:11.15.0-2.el7.centos                  asterisk-perl.noarch 0:1.03-0
       autogen-libopts.x86_64 0:5.18-5.el7                              cups-libs.x86_64 1:1.6.3-17.el7_1.1
       cyrus-imapd.x86_64 0:2.4.17-8.el7_1                              cyrus-imapd-utils.x86_64 0:2.4.17-8.el7_1
       dahdi.x86_64 0:2.10.0.1-3.el7.centos                             dhcp.x86_64 12:4.2.5-36.el7.centos
       dialog.x86_64 0:1.2-4.20130523.el7                               elastix-addons.noarch 0:2.5.0-2
       elastix-agenda.noarch 0:2.5.0-2                                  elastix-endpointconfig2.noarch 0:2.5.0-1
       elastix-extras.noarch 0:2.5.0-1                                  elastix-fax.noarch 0:2.5.0-2
       elastix-firstboot.noarch 0:2.5.0-2                               elastix-im.noarch 0:2.5.0-1
       elastix-my_extension.noarch 0:2.5.0-1                            elastix-pbx.noarch 0:2.5.0-4
       elastix-portknock.x86_64 0:0.0.1-0                               elastix-reports.noarch 0:2.5.0-3
       elastix-security.noarch 0:2.5.0-1                                elastix-system.noarch 0:2.5.0-2
       festival.x86_64 0:1.96-28.el7                                    festival-lib.x86_64 0:1.96-28.el7
       festival-speechtools-libs.x86_64 0:1.2.96-28.el7                 festvox-slt-arctic-hts.noarch 0:0.20061229-28.el7
       flac-libs.x86_64 0:1.3.0-5.el7_1                                 fontconfig.x86_64 0:2.10.95-7.el7
       fontpackages-filesystem.noarch 0:1.44-8.el7                      freePBX.noarch 0:2.11.0-20
       gdbm-devel.x86_64 0:1.10-8.el7                                   ghostscript.x86_64 0:9.07-18.el7
       ghostscript-fonts.noarch 0:5.50-32.el7                           glibc-devel.x86_64 0:2.17-78.el7
       glibc-headers.x86_64 0:2.17-78.el7                               gsm.x86_64 0:1.0.13-11.el7
       hdparm.x86_64 0:9.43-5.el7                                       httpd.x86_64 0:2.4.6-31.el7.centos.1
       httpd-tools.x86_64 0:2.4.6-31.el7.centos.1                       hylafax.x86_64 20150304:4.3.11-1rh7
       iaxmodem.x86_64 0:1.2.0-2.el7.centos                             iksemel.x86_64 0:1.4-6.el7
       kernel-headers.x86_64 0:3.10.0-229.14.1.el7                      lcms2.x86_64 0:2.5-4.el7
       libICE.x86_64 0:1.0.8-7.el7                                      libSM.x86_64 0:1.2.1-7.el7
       libX11.x86_64 0:1.6.0-2.1.el7                                    libX11-common.noarch 0:1.6.0-2.1.el7
       libXau.x86_64 0:1.0.8-2.1.el7                                    libXext.x86_64 0:1.3.2-2.1.el7
       libXfont.x86_64 0:1.4.7-3.el7_1                                  libXi.x86_64 0:1.7.2-2.1.el7
       libXpm.x86_64 0:3.5.10-5.1.el7                                   libXt.x86_64 0:1.1.4-6.1.el7
       libXtst.x86_64 0:1.2.2-2.1.el7                                   libaio.x86_64 0:0.3.109-12.el7
       liballogsmat.x86_64 0:2.0.7-1.el7.centos                         libao.x86_64 0:1.1.0-8.el7
       libasyncns.x86_64 0:0.8-7.el7                                    libc-client.x86_64 0:2007f-4.el7.1
       libdb-devel.x86_64 0:5.3.21-17.el7_0.1                           libfontenc.x86_64 0:1.1.1-5.el7
       libgsmat.x86_64 0:2.0.8-0.el7.centos                             libmcrypt.x86_64 0:2.5.8-13.el7
       libogg.x86_64 2:1.3.0-7.el7                                      libopenr2.x86_64 0:1.3.3-1.el7.centos
       libpng.x86_64 2:1.5.13-5.el7                                     libpri.x86_64 0:1.4.15-0.el7.centos
       libsndfile.x86_64 0:1.0.25-9.el7                                 libsrtp.x86_64 0:1.4.5-2.20131218gitdf78ccdcc.el7.centos
       libss7.x86_64 0:1.0.1-3.el7.centos                               libtidy.x86_64 0:0.99.0-31.20091203.el7
       libtiff-tools.x86_64 0:4.0.3-14.el7                              libtool-ltdl.x86_64 0:2.4.2-20.el7
       libusb.x86_64 1:0.1.4-3.el7                                      libusbx.x86_64 0:1.0.15-4.el7
       libvorbis.x86_64 1:1.3.3-8.el7                                   libwat.x86_64 0:1.0.25-0
       libxcb.x86_64 0:1.9-5.el7                                        libxslt.x86_64 0:1.1.28-5.el7
       libzip.x86_64 0:0.10.1-8.el7                                     lockdev.x86_64 0:1.0.4-0.13.20111007git.el7
       mailcap.noarch 0:2.1.41-2.el7                                    mailman.x86_64 3:2.1.15-21.el7_1
       mariadb.x86_64 1:5.5.44-1.el7_1                                  mariadb-server.x86_64 1:5.5.44-1.el7_1
       mgetty.x86_64 0:1.1.36-28.el7                                    mod_ssl.x86_64 1:2.4.6-31.el7.centos.1
       mysql-to-mariadb-server.noarch 0:1.0-0                           net-snmp-agent-libs.x86_64 1:5.7.2-20.el7_1.1
       net-snmp-libs.x86_64 1:5.7.2-20.el7_1.1                          nmap.x86_64 2:6.40-4.el7
       nmap-ncat.x86_64 2:6.40-4.el7                                    ntp.x86_64 0:4.2.6p5-19.el7.centos.1
       ntpdate.x86_64 0:4.2.6p5-19.el7.centos.1                         openfire.x86_64 0:3.7.1-1
       opus.x86_64 0:1.0.2-6.el7                                        perl.x86_64 4:5.16.3-285.el7
       perl-Archive-Tar.noarch 0:1.92-2.el7                             perl-Business-ISBN.noarch 0:2.06-2.el7
       perl-Business-ISBN-Data.noarch 0:20120719.001-2.el7              perl-CGI.noarch 0:3.63-4.el7
       perl-Carp.noarch 0:1.26-244.el7                                  perl-Compress-Raw-Bzip2.x86_64 0:2.061-3.el7
       perl-Compress-Raw-Zlib.x86_64 1:2.061-4.el7                      perl-Convert-BinHex.noarch 0:1.119-20.el7
       perl-Crypt-OpenSSL-Bignum.x86_64 0:0.04-18.el7                   perl-Crypt-OpenSSL-RSA.x86_64 0:0.28-7.el7
       perl-Crypt-OpenSSL-Random.x86_64 0:0.04-21.el7                   perl-DBD-MySQL.x86_64 0:4.023-5.el7
       perl-DBI.x86_64 0:1.627-4.el7                                    perl-DB_File.x86_64 0:1.830-6.el7
       perl-Data-Dumper.x86_64 0:2.145-3.el7                            perl-Data-UUID.x86_64 0:1.219-3.el7
       perl-Date-Manip.noarch 0:6.41-2.el7                              perl-Digest.noarch 0:1.17-245.el7
       perl-Digest-HMAC.noarch 0:1.03-5.el7                             perl-Digest-MD5.x86_64 0:2.52-3.el7
       perl-Digest-SHA.x86_64 1:5.85-3.el7                              perl-Encode.x86_64 0:2.51-7.el7
       perl-Encode-Detect.x86_64 0:1.01-13.el7                          perl-Encode-Locale.noarch 0:1.03-5.el7
       perl-Error.noarch 1:0.17020-2.el7                                perl-Exporter.noarch 0:5.68-3.el7
       perl-ExtUtils-Install.noarch 0:1.58-285.el7                      perl-ExtUtils-MakeMaker.noarch 0:6.68-3.el7
       perl-ExtUtils-Manifest.noarch 0:1.61-244.el7                     perl-ExtUtils-ParseXS.noarch 1:3.18-2.el7
       perl-FCGI.x86_64 1:0.74-8.el7                                    perl-File-Listing.noarch 0:6.04-7.el7
       perl-File-Path.noarch 0:2.09-2.el7                               perl-File-Temp.noarch 0:0.23.01-3.el7
       perl-Filter.x86_64 0:1.49-3.el7                                  perl-Getopt-Long.noarch 0:2.40-2.el7
       perl-HTML-Parser.x86_64 0:3.71-4.el7                             perl-HTML-Tagset.noarch 0:3.20-15.el7
       perl-HTTP-Cookies.noarch 0:6.01-5.el7                            perl-HTTP-Daemon.noarch 0:6.01-5.el7
       perl-HTTP-Date.noarch 0:6.02-8.el7                               perl-HTTP-Message.noarch 0:6.06-6.el7
       perl-HTTP-Negotiate.noarch 0:6.01-5.el7                          perl-HTTP-Tiny.noarch 0:0.033-3.el7
       perl-IO-Compress.noarch 0:2.061-2.el7                            perl-IO-HTML.noarch 0:1.00-2.el7
       perl-IO-Socket-INET6.noarch 0:2.69-5.el7                         perl-IO-Socket-IP.noarch 0:0.21-4.el7
       perl-IO-Socket-SSL.noarch 0:1.94-3.el7                           perl-IO-Zlib.noarch 1:1.10-285.el7
       perl-LWP-MediaTypes.noarch 0:6.02-2.el7                          perl-MIME-tools.noarch 0:5.505-1.el7
       perl-Mail-DKIM.noarch 0:0.39-8.el7                               perl-Mail-IMAPClient.noarch 0:3.34-1.el7
       perl-Mail-SPF.noarch 0:2.8.0-4.el7                               perl-MailTools.noarch 0:2.12-2.el7
       perl-Net-DNS.x86_64 0:0.72-5.el7                                 perl-Net-Daemon.noarch 0:0.48-5.el7
       perl-Net-HTTP.noarch 0:6.06-2.el7                                perl-Net-LibIDN.x86_64 0:0.12-15.el7
       perl-Net-SMTP-SSL.noarch 0:1.01-13.el7                           perl-Net-SSLeay.x86_64 0:1.55-3.el7
       perl-NetAddr-IP.x86_64 0:4.069-3.el7                             perl-Package-Constants.noarch 1:0.02-285.el7
       perl-Parse-RecDescent.noarch 0:1.967009-5.el7                    perl-PathTools.x86_64 0:3.40-5.el7
       perl-PlRPC.noarch 0:0.2020-14.el7                                perl-Pod-Escapes.noarch 1:1.04-285.el7
       perl-Pod-Perldoc.noarch 0:3.20-4.el7                             perl-Pod-Simple.noarch 1:3.28-4.el7
       perl-Pod-Usage.noarch 0:1.63-3.el7                               perl-Scalar-List-Utils.x86_64 0:1.27-248.el7
       perl-Socket.x86_64 0:2.010-3.el7                                 perl-Socket6.x86_64 0:0.23-15.el7
       perl-Storable.x86_64 0:2.45-3.el7                                perl-Sys-Syslog.x86_64 0:0.33-3.el7
       perl-Test-Harness.noarch 0:3.28-2.el7                            perl-Text-ParseWords.noarch 0:3.29-4.el7
       perl-Time-HiRes.x86_64 4:1.9725-3.el7                            perl-Time-Local.noarch 0:1.2300-2.el7
       perl-TimeDate.noarch 1:2.30-2.el7                                perl-URI.noarch 0:1.60-9.el7
       perl-WWW-RobotRules.noarch 0:6.02-5.el7                          perl-constant.noarch 0:1.27-2.el7
       perl-devel.x86_64 4:5.16.3-285.el7                               perl-libs.x86_64 4:5.16.3-285.el7
       perl-libwww-perl.noarch 0:6.05-2.el7                             perl-macros.x86_64 4:5.16.3-285.el7
       perl-parent.noarch 1:0.225-244.el7                               perl-podlators.noarch 0:2.5.1-3.el7
       perl-threads.x86_64 0:1.87-4.el7                                 perl-threads-shared.x86_64 0:1.43-6.el7
       perl-version.x86_64 3:0.99.07-2.el7                              php.x86_64 0:5.4.16-36.el7_1
       php-IDNA_Convert.noarch 0:0.8.0-2.el7                            php-PHPMailer.noarch 0:5.2.9-1.el7
       php-Smarty.noarch 0:3.1.21-1.el7                                 php-bcmath.x86_64 0:5.4.16-36.el7_1
       php-cli.x86_64 0:5.4.16-36.el7_1                                 php-common.x86_64 0:5.4.16-36.el7_1
       php-gd.x86_64 0:5.4.16-36.el7_1                                  php-imap.x86_64 0:5.4.16-3.el7
       php-jpgraph.noarch 0:3.0.7-0                                     php-mbstring.x86_64 0:5.4.16-36.el7_1
       php-mcrypt.x86_64 0:5.4.16-3.el7                                 php-mysql.x86_64 0:5.4.16-36.el7_1
       php-pdo.x86_64 0:5.4.16-36.el7_1                                 php-pear.noarch 1:1.9.4-21.el7
       php-pear-DB.noarch 0:1.7.14-6.el7                                php-process.x86_64 0:5.4.16-36.el7_1
       php-simplepie.noarch 0:1.3.1-4.el7                               php-soap.x86_64 0:5.4.16-36.el7_1
       php-tcpdf.noarch 0:6.2.11-1.el7                                  php-tidy.x86_64 0:5.4.16-3.el7
       php-xml.x86_64 0:5.4.16-36.el7_1                                 poppler-data.noarch 0:0.4.6-3.el7
       portreserve.x86_64 0:0.0.5-10.el7                                postgresql-libs.x86_64 0:9.2.13-1.el7_1
       procmail.x86_64 0:3.22-34.el7_0.1                                pulseaudio-libs.x86_64 0:3.0-30.el7
       py-Asterisk.noarch 0:0.5.2-1.fc17                                pyOpenSSL.x86_64 0:0.13.1-3.el7
       pyparsing.noarch 0:1.5.6-9.el7                                   python-cjson.x86_64 0:1.1.0-5.el7
       python-crypto.x86_64 0:2.6.1-1.el7.centos                        python-daemon.noarch 0:1.6-4.el7
       python-dns.noarch 0:1.11.1-2.20140901git9329daf.el7              python-ecdsa.noarch 0:0.11-3.el7.centos
       python-eventlet.noarch 0:0.16.1-1.el7.centos                     python-greenlet.x86_64 0:0.4.2-3.el7
       python-lockfile.noarch 1:0.9.1-4.el7                             python-paramiko.noarch 0:1.15.1-1.el7
       python-tempita.noarch 0:0.5.1-6.el7                              sharutils.x86_64 0:4.13.3-8.el7
       sox.x86_64 0:14.4.1-6.el7                                        spamassassin.x86_64 0:3.4.0-1.el7
       spandsp.x86_64 0:0.0.6-0.10.pre21.el7                            speex.x86_64 0:1.2-0.19.rc1.el7
       systemtap-sdt-devel.x86_64 0:2.6-10.el7_1                        t1lib.x86_64 0:5.1.2-14.el7
       tftp-server.x86_64 0:5.2-11.el7                                  unixODBC.x86_64 0:2.3.1-10.el7
       urw-fonts.noarch 0:2.4-16.el7                                    vsftpd.x86_64 0:3.0.2-9.el7
       wavpack.x86_64 0:4.60.1-9.el7                                    xinetd.x86_64 2:2.3.15-12.el7
       xorg-x11-font-utils.x86_64 1:7.5-18.1.el7
     
     Failed:
       elastix-email_admin.noarch 0:2.5.0-2                                elastix-framework.noarch 0:2.5.0-6
     
     Complete!

  • Service Provider

    Mine did not have an issue creating the needed user account.


  • Service Provider

    Doing a second build using these instructions. I put it all together in one script and it ran right through, rebooted and the setup screen came up for Elastix on the console. So far so good.


  • Service Provider

    Updated the script to be a bit more robust, seems to work now. The one step you have to manually edit one of the files that has errors in it. Details in another script. Basically the entire section dealing with "acl_user" has to be commented out.



  • @scottalanmiller said:

    At this point you have to log in via a console (which rules out doing this on platforms like AWD and Azure that lack the console option without a lot more work.) This has been tested in the past on Rackspace and in this particular case on Digital Ocean. On the console you will need to fill out the necessary settings to allow the system to configure passwords and the like.

    reply

    Hello Scott. I've tried on Azure/CentOS7.1 but when step "yum -y install elastic-framework" is done, the root privilege are removed because the instruction inside elastix-framework-4.0.0-1.noarch.rpm to change /etc/sudoers file. That situation on Azure is killing because the root users are disable by default. Do you have any workaround idea? I've tied to rebuild the rpm but it didn't work. I really appreciate any help you can provide.


  • Service Provider

    The issue there is Azure and some other providers modifying CentOS and not using either CentOS itself (in the case of the first provider changing out the kernel itself!) and Azure modifying default behaviour. Likely you could work around this on Azure by enabling root.

    I would recommend testing out Digital Ocean or Rackspace. I would avoid Azure for PBX usage. PBXs are very sensitive to latency and performance and Azure is not on par with Amazon, Rackspace, DO, etc.


  • Service Provider

    On Azure have you tried running with "sudo" if you are not the root user? Or have you tried sudo -i su to get to root?



  • @scottalanmiller I did with sudo.


  • Service Provider

    @ailton-cardozo welcome to the community, by the way!


  • Service Provider

    I have not used CentOS 7 on Azure, does sudo -i su not allow you to become root, even with it disabled?



  • @scottalanmiller Thanks for listening.


  • Service Provider

    @ailton.cardozo said:

    @scottalanmiller Thanks for listening.

    No problem!



  • @scottalanmiller Unfortunately not. But I will try on Amazon.


  • Service Provider

    Wow, that's so weird. How does Azure modify CentOS to that degree, and why?

    I suspect no issues on Amazon, they use Xen the same as Rackspace. Digital Ocean uses KVM.



  • @scottalanmiller Before starting the script I saw that it's possible to renable root user based in our discussion. Now i think It will work.


  • Service Provider

    Oh good, that makes more sense that it is only off by default, not removed completely!



  • Got this installed except for the same error I see here (http://mangolassi.it/topic/6319/elastix-4-install-errors-with-sqlite-unable-to-update-admin-password/6) Any resolution to this?

    The database asterisk is there with a table called "ampusers" where it looks like passwords are stored in a field called "password_sha1".

    I had no luck with UPDATE (ing) that table and setting password_sha1=SHA1("newpassword") WHERE user="admin"

    Feels so close.



  • @scottalanmiller tried removing this section, but then no password is set for the admin account. I seem installed, but cannot log in.0_1455624120651_capture.PNG . Am trying on digitalocean as well with centOS 7.

    Also, the line "systemctl enable httpd.server" produces file not found error.


  • Service Provider

    @nick what does rpm -qa | grep httpd return?



  • @nick Hello, i´m too in the same part of problem... please if you have any update, let me know. regards!



  • I get that request:

    [[email protected] ~]# rpm -qa | grep httpd
    httpd-2.4.6-40.el7.centos.x86_64
    httpd-tools-2.4.6-40.el7.centos.x86_64


  • Service Provider

    @rialejo said:

    I get that request:

    [[email protected] ~]# rpm -qa | grep httpd
    httpd-2.4.6-40.el7.centos.x86_64
    httpd-tools-2.4.6-40.el7.centos.x86_64

    So systemctl enable httpd.server doesn't work but systemctl start httpd.server does?



  • @scottalanmiller I think no...

    [[email protected] ~]# systemctl start httpd.server
    Failed to start httpd.server.service: Unit httpd.server.service failed to load: No such file or directory.

    &

    [[email protected] ~]# systemctl enable httpd.server
    Failed to execute operation: No such file or directory


  • Service Provider

    If it fails to start, how are you getting to the web page shown in the example?


  • Service Provider

    Try systemctl start httpd



  • @scottalanmiller That works... but the user and pass faill...

    Could you please confirm the user and pass default?

    [[email protected] ~]# systemctl start httpd

    And its true.. im asked the same, it say error to enable that but showme the initial webpage...


  • Service Provider

    @rialejo said:

    And its true.. im asked the same, it say error to enable that but showme the initial webpage...

    It's because you are getting the name wrong. The .server is not part of the name. Remove that.



  • @rialejo said:

    systemctl start httpd

    To access your Elastix System, using a separate workstation (PC/MAC/Linux)
    Open the Internet Browser using the following URL:
    http://xxx.xxx.xxx.xx

    [[email protected] ~]# systemctl start httpd
    [[email protected] ~]#



Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.