**** You Dropbox Program! The Neverending Dropbox Nightmare [SOLVED]



  • So I've been trying for nearly a month now to figure out why I could install Dropbox but not open it. Here is a log of the things I tried and how I finally fixed the root issue.

    • Tried uninstalling and reinstalling
    • Tried uninstalling with Revo, followed by running CCleaner and Eusing (each step I rebooted after)

    These were the basic steps. However, it still didn't fix it. So finally, tonight I went to oldapps.com and downloaded a Dropbox 2.x version of the software. I installed that, and this version was able to open! However, it was only because of this version that I determined root cause.

    For some reason, which I'm assuming is so you can have multiple users with multiple Dropbox installs on one machine, Dropbox installs to your Roaming AppData folder. It needs permissions to not only this folder, but the Temp directory in %LocalAppData%. This program actually gave me an error I could derive info from, whereas the version 3.x Dropbox installs just refused to open.

    I tried applying permissions to those folders and reopening the program but to no avail. Now what's weird is that Domain Admins are set to have Full Control over all these folders, and my user is a Domain Admin. However, I went to the C:\Users\ajstringham directory and applied Full Control with replacing the permissions of child objects for my individual user, ajstringham. After I did that and applied it, suddenly Dropbox worked!

    It was a ****ing permissions issue all along! SO FRUSTRATING! I don't know what was the golden ticket it needed but it's working. However, what confuses me is why it suddenly just stopped working in the first place...whatever. It's doing it's initial sync now and I'm happy.

    Hope this helps someone!

    Thanks,
    A.J.



  • This is a perfect example to explain again why I love Linux permissions over Windows permissions...



  • Thanks for the follow up.