Getting a version of certbot that works on debian stretch



  • This is probably a very temporary issue. But it exists today.
    debian stretch main repos only have certbot .10 available.
    To make a site use https today you need to be using .21+ since theyve updated how they do ACME challenge. New way isnt supported in .10.

    So to change your existing debian version of python-certbot-apache
    sudo apt remove python-certbot-apache
    sudo apt autoremove This removes the unused packages that python-certbot-apache used.

    nano /etc/apt/sources.list
    add

    # debian stretch-backports
    deb http://ftp.debian.org/debian stretch-backports main
    

    Save and exit
    run
    sudo apt install python-certbot-apache -t stretch-backports
    You will get the newer version .23 that works with new challenge system. I probably could have just used apt-get upgrade after adding the backports repo without removing the old packages.



  • @momurda said in Getting a version of certbot that works on debian stretch:

    This is probably a very temporary issue. But it exists today.
    debian stretch main repos only have certbot .10 available.
    To make a site use https today you need to be using .21+ since theyve updated how they do ACME challenge. New way isnt supported in .10.

    So to change your existing debian version of python-certbot-apache
    sudo apt remove python-certbot-apache
    sudo apt autoremove This removes the unused packages that python-certbot-apache used.

    nano /etc/apt/sources.list
    add

    # debian stretch-backports
    deb http://ftp.debian.org/debian stretch-backports main
    

    Save and exit
    run
    sudo apt install python-certbot-apache -t stretch-backports
    You will get the newer version .23 that works with new challenge system. I probably could have just used apt-get upgrade after adding the backports repo without removing the old packages.

    which version of Debian?



  • @dbeato said in Getting a version of certbot that works on debian stretch:

    @momurda said in Getting a version of certbot that works on debian stretch:

    This is probably a very temporary issue. But it exists today.
    debian stretch main repos only have certbot .10 available.
    To make a site use https today you need to be using .21+ since theyve updated how they do ACME challenge. New way isnt supported in .10.

    So to change your existing debian version of python-certbot-apache
    sudo apt remove python-certbot-apache
    sudo apt autoremove This removes the unused packages that python-certbot-apache used.

    nano /etc/apt/sources.list
    add

    # debian stretch-backports
    deb http://ftp.debian.org/debian stretch-backports main
    

    Save and exit
    run
    sudo apt install python-certbot-apache -t stretch-backports
    You will get the newer version .23 that works with new challenge system. I probably could have just used apt-get upgrade after adding the backports repo without removing the old packages.

    which version of Debian?

    Must Debian 8 since Debian 9 is stretch.



  • 9., the main repo still at .10



  • @momurda said in Getting a version of certbot that works on debian stretch:

    9., the main repo still at .10

    Got it, I didn’t see the title too I see it says Stretch, I should have known.


Log in to reply