Having trouble setting up CODE with Centos 7, can you help ?



  • Using combination of :
    https://www.collaboraoffice.com/code/
    and
    https://nextcloud.com/collaboraonline/

    Using latest up-to-date Centos Minimal 7

    My goal is just to create the CODE instance and open it in my browser, I know it is not functional site more like a service, but it should open up in my browser with the help of Apache or Nginx, neither is working cause I feel the installation steps are missing something.

    CentOS 7 (at least 7.2)
    
    Please type the following commands into the shell as root:
    
    # import the signing key
    wget https://www.collaboraoffice.com/repos/CollaboraOnline/CODE-centos7/repodata/repomd.xml.key && rpm --import repomd.xml.key
    # add the repository URL to yum
    yum-config-manager --add-repo https://www.collaboraoffice.com/repos/CollaboraOnline/CODE-centos7
    # perform the installation
    yum install loolwsd CODE-brand
    

    First of all I noticed even when doing the above steps I have to use yum --nogpgcheck, and after installating and setup apache, it is like the application of loolwsd or CODE is not starting, I tried to debug by running :
    loolwsd
    but it complained that it needs the lool user account, so I logged it using that and I ran it, and it asked for SSL key/cert/chain which I supplied then it gave me this:

    -bash-4.2$ loolwsd
    File not found: /usr/bin/discovery.xml
    <shutdown>-00970 20:24:03.973598 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507
    <shutdown>-00970 20:24:03.973751 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507
    <shutdown>-00970 20:24:03.973767 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507
    <shutdown>-00970 20:24:03.973781 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507
    <shutdown>-00970 20:24:03.973797 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507
    

    Surely I am doing something wrong, the site instructions seemes to be very easy, I have setup Apache server as proxy, and when I go to it and HTTP the normal site it works, but HTTPS states:

    This site can’t be reached
    192.168.1.13 refused to connect.

    Thanks in advance.



  • @emad-r
    SELiniux permissions?
    Firewall for https not configured?



  • @black3dynamite

    Both are disabled and not active in this testing environment.



  • @emad-r

    Fake Comment to make the post go back up and more people see it to help... corrupt comment.


Log in to reply
 

Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.