Openfire Export/Import users failing



  • I have Openfire Installed on Windows Server using the local embedded DB which is Hsqldb

    And now after much usage, and getting to know it more and what it can perform using Jingle plugin, it is time to properly treat it and install it on Centos 7 server.

    I have successfully finished that task and have Prod server running on Windows with all the users, and Centos fresh install with no user but admin, so I want to copy the users to the Linux server, Do note that Centos OpenFire is using MariaDB.

    The Plugin is failing with ''The import file does not match the user schema''

    I tried:

    Do a search and replace and take out all the extra <Password/> (But I didnt have any extra)
    Removing the <roster> element
    Using DB visualizor and having access to the local embedded Hsqldb DB, which I did get access but failed to extract any useful data.
    Replacing the previous domain with the new domain in the exported XML file.

    Nothing worked.

    I just want to find a way to export the
    User with

    his username/password/name to the Centos Openfire

    No need for Rooster/Groups



  • NVM this was fixed after a last ditch of founding this :

    https://www.igniterealtime.org/projects/openfire/plugins-beta.jsp

    Do note although the versions and history of the beta plugins look the same, but after downloading them and using the BETA file import/export everything worked as it should.

    I was using the latest stable OF which is 4.1.3 and latest stable import/export plugin 2.6.0 however using the one at BETA page shown above fixed the issue.


  • Service Provider

    That was an easy one :)


Log in to reply
 

Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.