Solution: .NET 3.5 install errors & Win 8.1



  • Encountered a problem this week while setting up some Win 8.1 VMs to be used for a PaaS solution. The problem was not new, but none of the usual TechNet quick-fixes were doing it this time. I'm sure you've all had the dotnetfx35 failures, resolved them with the usual group policy updates or removing the dreaded .NET rollup KBs. Maybe you had to use the offline client distribution or DISM from source media. After trying all this I was still staring at a failed install with the same generic error.

    I took a break. A beer break actually, and in this case Flat Tire's Citradelic was my Newton's Apple.

    I remembered 4 years ago when all the Engineers ran out and got windows 8 and the tried to reinstall their Autodesk software on it. There was something I had to do then, that I was forgetting now, and the canned forum responses just weren't going back that far.

    bonk

    I raced in and downloaded Microsoft's "dotnet removal tool" and removed .NET 1 & 1.1 which weren't even listed under Windows Settings as available features to add/remove, but were built into the OS. After a reboot I ran DSIM offline from the source media still mounted on my VM. After a subjective eternity at 64% ... 100% .NET 2, 3, & 3.5 installed successfully! Then immediately began repeating the process on the other 5 VMs which had all been cloned with the same embedded issue.

    So no real message here but for this, don't forget that Windows is built much like the cities of Europe ... directly on top of the foundations that were already there. Hope this helps someone, or at lease provided a good Thursday afternoon read. Live long and prosper!


Log in to reply
 

Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.