FreePBX, Qualify time, and "Unreachable" extensions



  • I have a client with a cloud hosted PBX (FreePBX). There are about 75 extensions at the client. This morning, phones are not ringing properly and going strait to VM when dialing an extension from and IVR. Looking at the peer list and console, it is because the extensions are unregistering. One phone was fixed by rebooting it.

    What has changed since yesterday? Well, the client is busy today and lots of traffic going on on the network. Could it be that their router/firewall simply cant handle all the concurrent SIP registrations? What can be done to help the problem? Changing the qualify time on extensions to something less? Right now the qualify time is at 60.



  • That would be one sad router. SIP is like HTTP.... one channel for a lot of connections. RTP does the separate extensions, sometimes that is where the problem is.

    Look for a UDP governor turned on somewhere. Some routers do that as some kind of half assed security mechanism.



  • What router do you have?



  • I read somewhere that turning on RTP KeepAlive in the SIP settings helps this exact issue, but I haven't tried it yet. Any experience with that particular setting?

    Unfortunately It's probably most likely an issue on their end with congestion. They have an old Netgear router. SRX-5308 with Firmware 4.3.3-8.



  • Netgear has been known specifically to have that UDP throttle, look for it to be on.



  • I'll see what I can find. Any comment on the RTP keep alive setting?



  • @scottalanmiller So without being on site tonight, I' checked some videos online to see if I could get an idea of the interface of the router. I found one that goes along with what you're recommending. See below. from this screen grab, it looks like you can disable session limits altogether, or increase the timeout of UDP to whatever you want. 0_1472170888420_ProSafe Session Limit.png



  • @fuznutz04 I think it would be under "attack checks"



  • The only option I saw under attack checks in the video is to disable UDP flood attacks.



  • @fuznutz04 said in FreePBX, Qualify time, and "Unreachable" extensions:

    The only option I saw under attack checks in the video is to disable UDP flood attacks.

    That's it, disable that.


Log in to reply