GPO tools - suggestions?



  • I have a GPO that works perfectly on one OU... so I copied.. added some functions to it.. and now the new one fails to do what the old one did.

    Any suggestions on a tool to help me figure out what I did wrong? I'm stare and compared them but just can't find any mistakes.



  • Is the new GPO showing up in the RSOP?



  • Yes it was. When I was looking at the GPO diag from Group Policy Manager I saw that my new GPOs were seeing a computer account was not being assigned to the OU it was in. I don't understand why that was.

    To 'force' it to work I checked the settings on the GPO to enforce - this seemed to solve the problem. After trying my Windows 8 systems on their GPO - I copied the Win 8 GPO and modified to match what I needed for the Win 7 machines and it worked.



  • @Dashrender said:

    Yes it was. When I was looking at the GPO diag from Group Policy Manager I saw that my new GPOs were seeing a computer account was not being assigned to the OU it was in. I don't understand why that was.

    To 'force' it to work I checked the settings on the GPO to enforce - this seemed to solve the problem. After trying my Windows 8 systems on their GPO - I copied the Win 8 GPO and modified to match what I needed for the Win 7 machines and it worked.

    In that case, it sounds like one of the other GPOs applied to that object may have conflicting settings. Turning Enforce on for the GPO increased its precedence for application, overriding any related settings on higher-level GPOs.



  • That's just it.. RSOP (or whatever the GPM runs as a sorta equivalent) showed no other GPOs being applied.

    The systems weren't being assigned to the OU they were in, even though they were clearly in said OU, so the GPO wasn't being applied to them. It was very odd.


Log in to reply