Hyper-V/Cisco 2960 Switch issues


  • Banned

    I'm having an issue which I'm pretty sure is with a config on the 2960x switch for our Hyper-V lab/WDS stuff.

    The base OS is now getting network fine, the VM get DHCP but can't communicate over the network. I think it's some default setting on the Cisco 2960x. Almost seems like Port Security Max Mac addresses is configured but there is nothing configured for it unless it is default now.. If so how do I disable it?


  • Banned

    Turns out it wasn't the switch but the fact that it's nested in ESXi, it's always worked before but this fixed it. Had to enable Promiscuous mode on the vSwitches.

    0_1450815219175_upload-5b6de03f-404c-4584-ae4d-6768f810415e



  • Out of curiosity... Why are you doing nested ESXi?



  • @dafyre said:

    Out of curiosity... Why are you doing nested ESXi?

    did he mean nested ESXi? or was he talking about the nested software defined networking that exists inside ESXi.


  • Banned

    @dafyre said:

    Out of curiosity... Why are you doing nested ESXi?

    Hyper-V is nested inside ESXi.. Don't really have easy physical access to any servers they all in our Datacenter running Vsphere. Would take the technicians longer to get it installed on another box than it's worth.



  • @Jason said:

    @dafyre said:

    Out of curiosity... Why are you doing nested ESXi?

    Hyper-V is nested inside ESXi.. Don't really have easy physical access to any servers they all in our Datacenter running Vsphere. Would take the technicians longer to get it installed on another box than it's worth.

    I gotcha. Yeah... I ran into that problem too when I first started at this employer. They didn't want me to do my Hyper-V setup on hardware initially, but then I convinced them because they didn't want to make changes to production VMware servers, lol.


  • Banned

    @dafyre said:

    I gotcha. Yeah... I ran into that problem too when I first started at this employer. They didn't want me to do my Hyper-V setup on hardware initially, but then I convinced them because they didn't want to make changes to production VMware servers, lol.

    We have so many of them it doesn't matter. We have them with Trunked with the production lan and the Test Lan, we use the same physical hosts for both.


Log in to reply