Office365 and aliases



  • I've added an alias to a user's O365 account. when an email comes to that alias account the user has no easy way of knowing which actual email address it came to. Is there a way to configure O365 to give an indication to the user that an email came to the alias instead of their normal email address?

    Nothing seems obvious in the Exchange Admin area.



  • Is he using Outlook? You can use the "To:" view to see to which address the emails were sent. You can also create a rule to filter them into a folder by "To:".



  • This user is using Outlook 2010. The To Field only shows the user's name. If they click on their name they see their 'normal' email address, not the alias.



  • I get this with onsite Exchange as well. The only way I've found is to view the properties in Outlook and look in the Internet Headers where the original alias address used is displayed. Would love know an easier way.



  • @Carnival-Boy said:

    I get this with onsite Exchange as well. The only way I've found is to view the properties in Outlook and look in the Internet Headers where the original alias address used is displayed. Would love know an easier way.

    Then you are doing something different than my setups because I see the correct To value with my onsite exchange. I have not done this with Office 365 yet. I will have to test.



  • I just tested my own on-prem Exchange and the same thing that happens to my client happens to me. it only shows my name. I was pretty sure in the past it did tell me it went to the alias address, but perhaps I was smokin' something.



  • @JaredBusch said:

    @Carnival-Boy said:

    I get this with onsite Exchange as well. The only way I've found is to view the properties in Outlook and look in the Internet Headers where the original alias address used is displayed. Would love know an easier way.

    Then you are doing something different than my setups because I see the correct To value with my onsite exchange. I have not done this with Office 365 yet. I will have to test.

    How are you adding the alias? I have opened my user account in EMC, go to the E-mail Addresses tab, and add a new address. I tested by using my home email to send a message and it came right through, but it was listed as being addressed to my normal address that is until I dig into the headers (no thanks).



  • OK finally have a few minutes to do some googling on this question and I ran into this post.

    http://www.howto-outlook.com/faq/aliases.htm

    About half way down they give two ways to work with aliases inside an Exchange environment. Neither are really desirable.



  • This worked.

    Instructions for the Exchange administrator;

    Create a mail enabled Active Directory Distribution Group with the name of the user you want to create an email alias for. You can do this via the Exchange Management Console (so not in Outlook!).
    Set the primary reply email address of that Distribution Group to the alias for the user.
    Add the user this alias is for as a member to the Distribution Group.
    Set “Sent As” permissions on the Distribution Group for the user who this alias is for via Active Directory Users and Computers or via PowerShell;
        Active Directory Users and Computers
        Set your view to “Advanced Features” (via the View menu), open the Contact and select the Security tab. Now add the user who this alias should belong to and select the “Send As” permission.
        PowerShell (AKA; Exchange Management Shell or EMS);
        Get-Group -Identity "Group Name" | Add-ADPermission -user "Domain\Username" -ExtendedRights "Send As"
    

    Note:
    In Exchange 2007/2010/2013 or Office 365, you can also do this by creating a mail enabled Active Directory Contact with the alias address as its “External E-mail Address” and create an Exchange Transport Rule to deliver it to the user’s mailbox. To set the “Send As” permissions on the Contact for the owner of the alias, you can use Active Directory Users and Computers or the following PowerShell command;
    Get-Contact -Identity "Contact Name" | Add-ADPermission -user "Domain\Username" -ExtendedRights "Send As"



  • It is entirely possible I am mixing up memory.. I will tinker later tonight on this if I remember when I sit down to work tonight.


Log in to reply