NIS and NFS and YP in Ubuntu Server 14.04



  • I need to configure the NIS and NFS in the Ubuntu Server and I dont know how to configure this???



  • NIS is the "new" name for YP (Yellow Pages.) It was just a rename like in the 1990s, the two are the same system.



  • Are you sure that you mean to use NIS (insecure?) That is a terribly old system. I've not seen anyone consider using it since the early 2000s. It's very easy to use, but ancient. I last implemented it around 2006 and it was ancient then.



  • First you need to get NIS installed:

    sudo apt-get install portmap nis


  • I have to configure NIS and NFS for one MAster Server and other slave servers also.How to configure it?I have installed the portmap nis as mentioned above



  • @Lakshmana said:

    I have to configure NIS and NFS for one MAster Server and other slave servers also.How to configure it?I have installed the portmap nis as mentioned above

    Does this guide work to get you started?

    http://www.server-world.info/en/note?os=Ubuntu_12.04&p=nis&f=2



  • I have tried to configure by the above method yesterday,there are some errors came in the process which was present in that website.

    For me some errors are coming in the process,I followed from the above website



  • Can you tell us what those errors are?



  • sysv-rc-conf ypbind on

    Line does not exists in my server.Why?



  • now installed the above thing but the error i face after installation is given below

    [email protected]:~$ sysv-rc-conf ypbind on
    Can't create /var/lib/sysv-rc-conf : Permission denied at /usr/sbin/sysv-rc-conf line 454.



  • I have followed the website given below but no use in configuration

    http://www.server-world.info/en/note?os=Ubuntu_13.04&p=nis&f=2



  • @Lakshmana said:

    now installed the above thing but the error i face after installation is given below

    [email protected]:~$ sysv-rc-conf ypbind on
    Can't create /var/lib/sysv-rc-conf : Permission denied at /usr/sbin/sysv-rc-conf line 454.

    You forgot the "sudo" before that line.



  • NOw NFS configured and tested but there is an issue in the NIS configuration only and the NIS server has issue given below

    [email protected]:/var/yp# service ypbind start
    start: Job failed to start

    NIS client has issue as given below

    [email protected]:~# ypdomainname
    test
    [email protected]:~# ypcat passwd
    No such map passwd.byname. Reason: Can't bind to server which serves this domain
    [email protected]:~# ypcat hosts
    No such map hosts.byname. Reason: Can't bind to server which serves this domain



  • There is no need to test NIS functions if the NIS server hasn't started yet. If the service can't start, you know that it isn't going to work. This is like telling us that the car isn't steering well right after demonstrating that it hasn't started yet.

    So we must start by figuring out why it isn't starting and fix that. When something doesn't work, since it throws no useful error messages, we need to start by looking at the logs to see what it is telling us.



  • My NIS Client Configuration Step by step process is given below if any error please inform

    nano /etc/yp.conf
    
      GNU nano 2.2.6             File: /etc/yp.conf                       Modified  
    
    #
    # yp.conf       Configuration file for the ypbind process. You can define
    #               NIS servers manually here if they can't be found by
    #               broadcasting on the local net (which is the default).
    #
    #               See the manual page of ypbind for the syntax of this file.
    #
    # IMPORTANT:    For the "ypserver", use IP addresses, or make sure that
    #               the host is in /etc/hosts. This file is only interpreted
    #               once, and if DNS isn't reachable yet the ypserver cannot
    #               be resolved and ypbind won't ever bind to the server.
    
    # ypserver ypserver.network.com
    domain test.com server shiva.test.com
    
    [email protected]:~# nano /etc/nsswitch.conf 
    
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat nis
    group:            compat nis
    shadow:         compat nis
    
    hosts:          files mdns4_minimal [NOTFOUND=return] dns nis
    networks:       files
    
    protocols:       db files
    services:        db files
    ethers:            db files
    rpc:                 db files
    
    [email protected]:~# nano /etc/pam.d/common-session
    
      GNU nano 2.2.6         File: /etc/pam.d/common-session                        
    
    # since the modules above will each just jump around
    session required                        pam_permit.so
    # The pam_umask module will set the umask according to the system default in
    # /etc/login.defs and user settings, solving the problem of different
    # umask settings with different shells, display managers, remote sessions etc.
    # See "man pam_umask".
    session optional                        pam_umask.so
    # and here are more per-package modules (the "Additional" block)
    session required        pam_unix.so
    session optional        pam_systemd.so
    # end of pam-auth-update config
    session optional        pam_mkhomedir.so skel=/etc/skel umask=077
    
    [email protected]:~# reboot
    
    [email protected]:~# ypwhich
    ypwhich: Can't communicate with ypbind
    [email protected]:~# ypcat passwd
    No such map passwd.byname. Reason: Can't bind to server which serves this domain
    [email protected]:~# ypcat hosts
    No such map hosts.byname. Reason: Can't bind to server which serves this domain
    [email protected]:~#


  • Client side output for digging domain name

    [email protected]:~$ dig test.com any
    
    ; <<>> DiG 9.9.5-3ubuntu0.1-Ubuntu <<>> test.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16217
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 8, AUTHORITY: 2, ADDITIONAL: 3
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;test.com.			IN	ANY
    
    ;; ANSWER SECTION:
    test.com.		7200	IN	SOA	ns65.worldnic.com. namehost.worldnic.com. 115070707 10800 3600 604800 3600
    test.com.		7200	IN	TXT	"google-site-verification=kW9t2V_S7WjOX57zq0tP8Ae_WJhRwUcZoqpdEkvuXJk"
    test.com.		7200	IN	MX	10 mx.spamexperts.com.
    test.com.		7200	IN	MX	20 fallbackmx.spamexperts.eu.
    test.com.		7200	IN	MX	30 lastmx.spamexperts.net.
    test.com.		3600	IN	A	69.172.200.235
    test.com.		7200	IN	NS	ns66.worldnic.com.
    test.com.		7200	IN	NS	ns65.worldnic.com.
    
    ;; AUTHORITY SECTION:
    test.com.		7200	IN	NS	ns66.worldnic.com.
    test.com.		7200	IN	NS	ns65.worldnic.com.
    
    ;; ADDITIONAL SECTION:
    ns65.worldnic.com.	171249	IN	A	207.204.40.133
    ns66.worldnic.com.	171249	IN	A	207.204.21.133
    
    ;; Query time: 841 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Jul 16 18:50:33 IST 2015
    ;; MSG SIZE  rcvd: 396
    
    [email protected]:~$


  • I edited your posts for readability.



  • You are getting way too deep when your errors are very shallow. Right now it looks like NIS isn't running yet:

    [email protected]:~# ypwhich
    ypwhich: Can't communicate with ypbind
    [email protected]:~# ypcat passwd
    No such map passwd.byname. Reason: Can't bind to server which serves this domain
    

    Before you are doing all of this.... just look and see if NIS is running. Just this command on your NIS server:

    netstat -tulpn


  • Or query the NIS service and ask it if it is running.



  • Have firewall ports been opened for RPCBIND and whatever else is needed?



  • How to open ports for the NIS and NFS in iptables?
    I have followed the below to link configure for the NIS configurattion now.

    https://help.ubuntu.com/community/SettingUpNISHowTo

    But I was not able to open the ports I have given in the website

    I have also installed the iptables-persistent in the ubuntu server but the default path to edit rules was not able to identify.

    When I use the rules for the port I have opened means the error coming here is
    Bad Argument"IP"



  • @Lakshmana said:

    How to open ports for the NIS and NFS in iptables?

    Same way as the other times you opened ports in iptables. Just change the port numbers. For now, while you are trying to figure things out, just turn iptables off.



  • @Lakshmana said:

    When I use the rules for the port I have opened means the error coming here is
    Bad Argument"IP"

    Instead of describing the issue in cases like this, supply the screen shot or a copy/paste of the commands that fail and the error. In almost all cases it's just a typo or missed argument. In every case we will ask you to do this. So instead of making us ask, just start by providing the information so we can assist more quickly.



  • Configured Properly and now it is working



  • What was wrong?



  • I have not mentioned the server at /etc/hosts and ypbind does not happen because of this option the whole setup has issue.



  • I am guessing that you do not have all of your servers listed in DNS and that might be causing the problem requiring /etc/hosts to have an entry?



  • You can use IP addresses in your configuration files too, instead of hostnames if you are lacking DNS.



  • OK.