FreePBX call not routing



  • Only difference is the destination, well, and the incoming DID #



  • @Dashrender said in FreePBX call not routing:

    Only difference is the destination, well, and the incoming DID #

    Anything different under Advanced or Other?



  • Also, try setting them to the same destination until it works, just in case it is a destination issue.



  • Skyetell sends an 11 digit number so basically your number with a 1 added by default unless you change it to send only 10 digits your inbound route is missing a one.

    14029733266



  • @scottalanmiller said in FreePBX call not routing:

    Also, try setting them to the same destination until it works, just in case it is a destination issue.

    No change, still "not in service"



  • @Romo said in FreePBX call not routing:

    Skyetell sends an 11 digit number so basically your number with a 1 added by default unless you change it to send only 10 digits your inbound route is missing a one.

    14029733266

    While this was not specifically the issue - it did lead me in a direction, found a change I missed on the Skyetel side - testing now.



  • @Dashrender - I haven't used Skyetel yet but do they have an inbound setting like voip.ms does? On voip.ms there is the device type under inbound settings - "IP PBX Server, Asterisk, or Softswitch" or "ATA device, IP Phone or Softphone".



  • OK anyone reading this in the future,

    Skyetel has the option to set the SIP Format as seen here. Following their instructions for use with FreePBX requires changing this to +1NPANxxxxxx from 1NPANxxxxxx, then FreePBX will drop the +1...

    In my case, since I didn't originally make this change, FreePBX wasn't dropping the 1 (It was looking for +1, didn't find it so it did nothing) and therefore my number didn't match.

    alt text



  • @syko24 said in FreePBX call not routing:

    @Dashrender - I haven't used Skyetel yet but do they have an inbound setting like voip.ms does? On voip.ms there is the device type under inbound settings - "IP PBX Server, Asterisk, or Softswitch" or "ATA device, IP Phone or Softphone".

    Not that I know of, this is the trunk settings on the Skyetel side
    de015bcb-3147-436b-ab21-3ae12db9401b-image.png

    FYI - my problem is now fixed, after I changed the SIP Format option.



  • @Dashrender said in FreePBX call not routing:

    OK anyone reading this in the future,

    Skyetel has the option to set the SIP Format as seen here. Following their instructions for use with FreePBX requires changing this to +1NPANxxxxxx from 1NPANxxxxxx, then FreePBX will drop the +1...

    In my case, since I didn't originally make this change, FreePBX wasn't dropping the 1 (It was looking for +1, didn't find it so it did nothing) and therefore my number didn't match.

    It is not their instructions. it is my instructions.

    The guidance you were given, and that is stated in my instructions, is that you want your DID to be in a clean format within your PBX.

    Skyetel, which defaults to the stupid NANPA format of 1NPANXXXXXX, gives you have no easy method built in to FreePBX to strip the 1, and thus have clean 10 digit numbers everywhere within your call flow.

    So to fix that, you tell Skyetel to set your inbound calls to an actual standard called E.164. Then you tell your trunk that it is expecting calls in that standard, and that you are in the US, by using the built in context from-pstn-e164-us. This results in the context stripping the +1 from the inbound call prior to any other processing by your PBX. Thus you only ever see 10 digit numbers in caller ID and redial history on the phones.



  • @Dashrender said in FreePBX call not routing:

    Quick googling has lead me to an IP missmatch on the Skyetel trunk, so the system is rejecting the call basically.

    Dunno WTF you searched up, but it was wrong as shit.

    Also, basic logic tells you that if the call is hitting your PBX it is impossible for it to be a firewall issue.



  • @Romo said in FreePBX call not routing:

    Skyetell sends an 11 digit number so basically your number with a 1 added by default unless you change it to send only 10 digits your inbound route is missing a one.

    14029733266

    See my previous reply, but changing it to a 10 digit number is jsut as bad as the stupid 11 digit number.

    Standards are a good thing.





  • @Dashrender if oyu are going to ignore my recommendations, then just create an any/any inbound route and point it someplace. Then you would never have had this problem.

    Of course, when you tried to specifically route the DID to something later, it woudl not have worked, as it would not match and fail to the any/any route. but meh. At least you would not have been thinking of unrelated things like firewall.



  • @JaredBusch said in FreePBX call not routing:

    @Dashrender if oyu are going to ignore my recommendations, then just create an any/any inbound route and point it someplace. Then you would never have had this problem.

    Of course, when you tried to specifically route the DID to something later, it woudl not have worked, as it would not match and fail to the any/any route. but meh. At least you would not have been thinking of unrelated things like firewall.

    I didn't ignore anything, I like your reasoning, but I had only ever setup DIDs from Skyetel one time before, and I had forgotten about that setting - but the mention of the 11 digit versus 10 reminded me of that change (your change) and I made it and life is grand.

    Thanks!


Log in to reply