Urbackup is not backing up my windows clients.



  • Re: UrBackup - How is it working for you?

    I've done it all. I didn't find much information to help in the Urbackup forum. In fact the support there is very simplistic, the community doesn't help much. Can you help me? I followed his tutorial and installed the backup server on my CentOS 7. I installed the client on my windows server 2012. Urbackup Server found it, but it is still waiting on the client. And in the web log presents the error below.

    Client log for file backup. It is a windows server 2012 R2 server

    2019-10-21 00:03:04: WARNING: Info not found at ‘e:’ - reindexing
    2019-10-21 10:22:48: Loaded -fileserv- plugin
    2019-10-21 10:22:48: Loaded -fsimageplugin- plugin
    2019-10-21 10:22:48: Loaded -cryptoplugin- plugin
    2019-10-21 10:22:48: SQLite: recovered 148 frames from WAL file C:\Program Files\UrBackup\urbackup\backup_client.db-wal code: 283
    2019-10-21 10:22:48: urbackupserver: Server started up successfully!
    2019-10-21 10:22:48: FileSrv: Backup privileges set successfully
    2019-10-21 10:22:48: FileSrv: Backup privileges set successfully (SE_SECURITY_NAME)
    2019-10-21 10:22:48: FileSrv: Backup privileges set successfully (SE_RESTORE_NAME)
    2019-10-21 10:22:48: Started UrBackupClient Backend…
    2019-10-21 10:22:48: FileSrv: Binding UDP socket at port 35622…
    2019-10-21 10:22:48: FileSrv: done.
    2019-10-21 10:22:48: FileSrv: Disabling new behavior…
    2019-10-21 10:22:48: FileSrv: Binding ipv6 UDP socket at port 35622…
    2019-10-21 10:22:48: FileSrv: done.
    2019-10-21 10:22:48: FileSrv: Disabling new behavior…
    2019-10-21 10:22:48: Filesystem. Vol="?\Volume{bcf267a6-6f7d-11e4-80b4-806e6f6e6963}" Name=“reservado pelo sistema” Type=“ntfs” VPaths=0 Size=366997504
    2019-10-21 10:22:48: FileSrv: Servername: -ADVW12ACD01-
    2019-10-21 10:22:48: FileSrv: Server started up successfully
    2019-10-21 10:22:48: FileSrv: UDP Thread started
    2019-10-21 10:22:48: Bootable flag set for volume
    2019-10-21 10:22:48: Found potential candidate: ?\Volume{bcf267a6-6f7d-11e4-80b4-806e6f6e6963}\ Score: 3
    2019-10-21 10:22:48: Filesystem. Vol="?\Volume{dc3f6609-7068-11e4-80ba-00090ffe0001}" Name=“dados” Type=“ntfs” VPaths=1 Size=53683941376
    2019-10-21 10:22:48: Bootable flag not set for volume
    2019-10-21 10:22:48: Filesystem. Vol="?\Volume{32630790-7115-11e4-80bb-00090ffe0001}" Name=“copia de sombra” Type=“ntfs” VPaths=1 Size=10734268416
    2019-10-21 10:22:48: Bootable flag not set for volume
    2019-10-21 10:22:48: Filesystem. Vol="?\Volume{bcf267a7-6f7d-11e4-80b4-806e6f6e6963}" Name="" Type=“ntfs” VPaths=1 Size=42580570112
    2019-10-21 10:22:48: Filesystem is System partition. Skipping…
    2019-10-21 10:22:48: urbackupserver: No available slots… starting new Worker
    2019-10-21 10:22:48: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:22:49: Internet mode not enabled
    2019-10-21 10:22:49: Looking for old Sessions… 0 sessions
    2019-10-21 10:22:49: Final path: E:\Arquivos
    2019-10-21 10:22:49: Final path: E:\Backup_AD
    2019-10-21 10:22:49: Filesystem. Vol="?\Volume{bcf267ae-6f7d-11e4-80b4-806e6f6e6963}" Name="" Type="" VPaths=1 Size=-1
    2019-10-21 10:22:49: GetVolumeInformation failed with error code 21. Skipping…
    2019-10-21 10:22:49: Filesystem. Vol="?\Volume{8c4dd971-dd60-11e9-8147-806e6f6e6963}" Name="" Type="" VPaths=1 Size=-1
    2019-10-21 10:22:49: GetVolumeInformation failed with error code 21. Skipping…
    2019-10-21 10:22:49: Selected volume ?\Volume{bcf267a6-6f7d-11e4-80b4-806e6f6e6963}
    2019-10-21 10:22:49: System dir: C:\Windows
    2019-10-21 10:22:49: Volpath: .\C:
    2019-10-21 10:22:49: Device is not GPT formatted (0)
    2019-10-21 10:22:49: Found no EFI System Partition
    2019-10-21 10:22:49: ClientService cmd: #ILTBzjuCKLUHV22DgLfFT#1CHANNEL capa=64&token=cA2XSY0u8YgxZbJAATsR&restore_version=1&virtual_client=
    2019-10-21 10:22:49: New channel: Number of Channels: 1
    2019-10-21 10:23:40: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:23:50: ClientService cmd: PONG
    2019-10-21 10:24:31: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:24:49: ClientService cmd: PONG
    2019-10-21 10:25:23: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:25:49: Internet mode not enabled
    2019-10-21 10:25:49: ClientService cmd: PONG
    2019-10-21 10:26:15: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:26:49: ClientService cmd: PONG
    2019-10-21 10:27:07: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:27:50: ClientService cmd: PONG
    2019-10-21 10:27:59: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:28:50: ClientService cmd: PONG
    2019-10-21 10:28:51: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:29:43: ClientService cmd: STATUS#pw=UYjSSGKJfje2USeLHYeGQtT3qQSnq5
    2019-10-21 10:29:50: ClientService cmd: PONG

    Backup server log. It is a CentOS 7 server.

    2019-10-21 10:25:01: Starting HTTP-Server on port 55414
    2019-10-21 10:25:01: ERROR: HTTP: Failed binding socket to port 55414. Another instance of this application may already be active and bound to this port.
    2019-10-21 10:25:01: Started UrBackup…
    2019-10-21 10:25:01: Removing temporary files…
    2019-10-21 10:25:01: Recreating temporary folder…
    Backupfolder not set
    2019-10-21 10:25:01: Image mounting disabled: Backupfolder not set
    2019-10-21 10:25:01: Testing if backup destination can handle subvolumes and snapshots…
    Backupfolder not set
    2019-10-21 10:25:01: Backup destination cannot handle subvolumes and snapshots. Snapshots disabled.
    2019-10-21 10:25:01: Testing if backup destination can handle filesystem transactions…
    2019-10-21 10:25:01: Testing for hardlinks in backup destination…
    2019-10-21 10:25:01: Could create hardlink at backup destination. Hardlinks enabled.
    2019-10-21 10:25:01: Testing for reflinks in backup destination…
    2019-10-21 10:25:01: Reflink ioctl failed. errno=95
    2019-10-21 10:25:01: Could not create reflink at backup destination. Reflinks disabled. Operation not supported (code: 95)
    2019-10-21 10:25:01: Binding to interface ens32 (ipv4) for broadcasting…
    2019-10-21 10:25:01: Broadcasting on ipv4 interface ens32 addr 192.168.254.6
    2019-10-21 10:25:01: Binding to interface ens32 (ipv6) for broadcasting…
    2019-10-21 10:25:01: Broadcasting on ipv6 interface ens32 addr 2804:7f7:a5ad:125d:527f:83f2:7a0c:f4e2
    2019-10-21 10:25:01: Binding to interface ens32 (ipv6) for broadcasting…
    2019-10-21 10:25:01: Broadcasting on ipv6 interface ens32 addr fe80::7742:4a4a:ee89:5e14
    2019-10-21 10:25:01: UrBackup Server start up complete.
    2019-10-21 10:25:01: ERROR: Failed binding SOCKET to Port 55413
    2019-10-21 10:25:01: ERROR: Error while starting listening to ports. Stopping server.
    2019-10-21 10:25:01: Exited Loop
    2019-10-21 10:25:01: Deleting at…
    2019-10-21 10:25:01: Deleting SelectThreads…
    2019-10-21 10:25:01: Deleting lbs…
    2019-10-21 10:25:01: Shutting down plugins…



  • Pinging @DustinB3403 who uses UrBackup a lot.



  • @scottalanmiller said in Urbackup is not backing up my windows clients.:

    Pinging @DustinB3403 who uses UrBackup a lot.

    Actually I don't. I've tested it and it does work well, I just don't have a use case for it where I'm at.



  • @marcos-souza said in Urbackup is not backing up my windows clients.:

    2019-10-21 10:25:01: ERROR: Failed binding SOCKET to Port 55413

    Disable SELinux would be my first guess. Also stop the firewall service. Then restart UrBackup.

    sudo setenforce 0
    sudo systemctl stop firewalld
    

    If that works, then turn one back on and do it again.

    Then the other.

    Troubleshoot the one that breaks things.



  • But as a bit of guidance to @marcos-souza I've never really had great success with getting the server to install on anything other than Ubuntu and Windows - not sure as to why. . ..

    Out of curiosity have you opened the ports through firewall-cmd?

    firewall-cmd --permanent --add-port=55413
    firewall-cmd --permanent --add-port=55414
    firewall-cmd --reload



  • Here is the complete list of required ports.


Log in to reply