Updating to Fedora 30 Gives Pix Error



  • Doing an upgrade from Fedora 29 to Fedora 30 and you get...

    Error: 
     Problem: package pix-1.8.2-1.fc29.x86_64 requires libexiv2.so.26()(64bit), but none of the providers can be installed
      - exiv2-libs-0.26-12.fc29.x86_64 does not belong to a distupgrade repository
      - problem with installed package pix-1.8.2-1.fc29.x86_64
    (try to add '--skip-broken' to skip uninstallable packages)
    

    This seems to happen with most normal workstation installs of Fedora. Easiest thing to do is simply remove Pix.

    sudo dnf remove pix -y
    

    Your update should work fine after that.



  • @scottalanmiller said in Updating to Fedora 30 Gives Pix Error:

    Doing an upgrade from Fedora 29 to Fedora 30 and you get...

    Error: 
     Problem: package pix-1.8.2-1.fc29.x86_64 requires libexiv2.so.26()(64bit), but none of the providers can be installed
      - exiv2-libs-0.26-12.fc29.x86_64 does not belong to a distupgrade repository
      - problem with installed package pix-1.8.2-1.fc29.x86_64
    (try to add '--skip-broken' to skip uninstallable packages)
    

    This seems to happen with most normal workstation installs of Fedora. Easiest thing to do is simply remove Pix.

    sudo dnf remove pix -y
    

    Your update should work fine after that.

    I don't ever use it. But, yeah it is there by default.