Resolved - Zabbix - Errors Installing on Fedora 29



  • Resolved - Don't try running 4.2 on Fedora. As @JaredBusch shows below, 3.0 can be done.

    I am trying to install Zabbix on Fedora 29. I don't know if using Fedora is the reason I am getting these errors, but thought I would ask. I am running the installation and get broken dependencies. I tried dnf (and yum).

     Problem 1: cannot install the best candidate for the job
      - nothing provides libevent-2.0.so.5()(64bit) needed by zabbix-server-mysql-4.2.1-1.el7.x86_64
      - nothing provides libnetsnmp.so.31()(64bit) needed by zabbix-server-mysql-4.2.1-1.el7.x86_64
     Problem 2: cannot install the best candidate for the job
      - nothing provides php-mysql needed by zabbix-web-mysql-4.2.1-1.el7.noarch
     Problem 3: both package zabbix-agent-4.2.1-1.el7.x86_64 and zabbix-server-pgsql-4.2.1-1.el7.x86_64 obsolete zabbix
      - cannot install the best candidate for the job
      - nothing provides libevent-2.0.so.5()(64bit) needed by zabbix-server-pgsql-4.2.0-1.el7.x86_64
      - nothing provides libnetsnmp.so.31()(64bit) needed by zabbix-server-pgsql-4.2.0-1.el7.x86_64
      - nothing provides libevent-2.0.so.5()(64bit) needed by zabbix-server-pgsql-4.2.1-1.el7.x86_64
      - nothing provides libnetsnmp.so.31()(64bit) needed by zabbix-server-pgsql-4.2.1-1.el7.x86_64
    =========================================================================================================================================================================================================
     Package                                                  Architecture                                Version                                          Repository                                   Size
    =========================================================================================================================================================================================================
    Skipping packages with broken dependencies:
     zabbix-server-mysql                                      x86_64                                      4.2.1-1.el7                                      zabbix                                      2.3 M
     zabbix-server-pgsql                                      x86_64                                      4.2.0-1.el7                                      zabbix                                      2.3 M
     zabbix-server-pgsql                                      x86_64                                      4.2.1-1.el7                                      zabbix                                      2.3 M
     zabbix-web-mysql                                         noarch                                      4.2.1-1.el7                                      zabbix                                      8.8 k
    
    Transaction Summary
    =========================================================================================================================================================================================================
    Skip  4 Packages
    
    Nothing to do.
    Complete!
    
    


  • Not all of your info is included. What was the source of the Zabbix packages? By their name, those are RHEL / CentOS packages, not Fedora packages. So different libraries.



  • From Zabbix official repository

    Zabbix SIA provides official RPM and DEB packages for:

    • Red Hat Enterprise Linux
    • Debian
    • Ubuntu LTS


  • A quick search definitely suggests that current Fedora or Ubuntu are not options. Only LTS releases are supported. And if you Google it, any search for Fedora just shows people using CentOS.



  • @scottalanmiller said in Zabbix - Errors Installing on Fedora 29:

    A quick search definitely suggests that current Fedora or Ubuntu are not options. Only LTS releases are supported. And if you Google it, any search for Fedora just shows people using CentOS.

    That would be it. I will set it up on CentOS. Thanks for the info.



  • @scottalanmiller said in Resolved - Zabbix - Errors Installing on Fedora 29:

    A quick search definitely suggests that current Fedora or Ubuntu are not options. Only LTS releases are supported. And if you Google it, any search for Fedora just shows people using CentOS.

    A bad quick search.....
    https://mangolassi.it/topic/16508/install-zabbix-on-fedora-27

    And FYI, this is what is showing available on my Fedora 29 desktop.
    869bdcd4-c07d-4158-bd40-038b325db508-image.png
    1d3afedc-0c91-414e-9cfd-48876cb1680b-image.png



  • @JaredBusch Maybe it's because that is 3.0, not 4.2?



  • @wrx7m said in Resolved - Zabbix - Errors Installing on Fedora 29:

    @JaredBusch Maybe it's because that is 3.0, not 4.2?

    You didn't say you had to have 4.2. You simply asked to get Zabbix on Fedora.



  • @JaredBusch Correct, I did not state that. However, my OP shows the version as 4.2. So, the issue is that I can't install the latest version available on Fedora. I will update the OP.