Exchange 2013 Remote (Socket Error)



  • Sorry I know this is a vague question but has anyone seen or know what Remote (Socket Error) refers to on Exchange 2013?

    The logs on the receive connector show everything is ok up until the part where is should say message queued for delivery. Instead is says Remote(Socket Error).

    This seems to only be happening when one sender tries to email us. All other external email seems to be fine. The mail flows like this:

    1. The person trying to email us is sending from Exchange hosted O365
    2. Goes to our external spam filter
    3. Goes to our Exchange server

    The external spam filter is passing the message. I have whitelisted the senders address both at the external filter as well as on the Exchange server. Not sure why our server is not liking messages from this sender.

    Any thoughts???

    Thanks



  • Not sure if this helps

    <,RSET,
    >,250 2.0.0 Resetting,
    <,XPROXYFROM SID=08D692858755D4E6 IP=104.227.248.206 PORT=33612 DOMAIN=engclustn3.stage.casg 
    SEQNUM=1 PERMS=1073 AUTHSRC=Anonymous,
    >,250 XProxyFrom accepted,
    <,MAIL FROM:<[email protected]> SIZE=0 AUTH=<>,
    *,SMTPSubmit SMTPSubmitForMLS SMTPAcceptAnyRecipient SMTPAcceptAuthenticationFlag SMTPAcceptAnySender 
    SMTPAcceptAuthoritativeDomainSender BypassMessageSizeLimit SMTPSendEXCH50 SMTPAcceptEXCH50    
    AcceptRoutingHeaders AcceptForestHeaders AcceptOrganizationHeaders SendRoutingHeaders SendForestHeaders    
    SendOrganizationHeaders SendAs SMTPSendXShadow SMTPAcceptXShadow SMTPAcceptXProxyFrom    
    SMTPAcceptXSessionParams SMTPAcceptXMessageContextADRecipientCache 
    SMTPAcceptXMessageContextExtendedProperties SMTPAcceptXMessageContextFastIndex SMTPAcceptXAttr 
    SMTPAcceptXSysProbe,Set Session Permissions
    *,08D69CFF87392E6C;2019-02-27T22:45:48.477Z;3,receiving message
    <,RCPT TO:<[email protected]>,
    >,250 2.1.0 Sender OK,
    >,250 2.1.5 Recipient OK,
    <,DATA,
    >,354 Start mail input; end with <CRLF>.<CRLF>,
    *,,receiving message with InternetMessageId 
    <[email protected]od.outlook.com>    
    -,,Remote(SocketError)


  • @syko24 said in Exchange 2013 Remote(Socket Error):

    The external spam filter is passing the message. I have whitelisted the senders address both at the external filter as well as on the Exchange server.

    Sounds like a protocol issue between the two.



  • @scottalanmiller said in Exchange 2013 Remote (Socket Error):

    @syko24 said in Exchange 2013 Remote(Socket Error):

    The external spam filter is passing the message. I have whitelisted the senders address both at the external filter as well as on the Exchange server.

    Sounds like a protocol issue between the two.

    Between our exchange and the spam filter or our exchange and the senders O365?



  • @scottalanmiller We receive emails from O365 accounts all the time. The socket error only seems to show up when sent from this one person's email address. I have asked him to send two test emails. One with the original content and CC my personal gmail account and then just a small test email with a subject and quick hello in the body. I want to see if there is something odd with any attachments that he is sending to us.



  • @syko24 said in Exchange 2013 Remote (Socket Error):

    @scottalanmiller We receive emails from O365 accounts all the time. The socket error only seems to show up when sent from this one person's email address.

    Oh, very weird.



  • So I received the test email but not the original email that had an attachment in it. My guess is there is an issue with the attachment. Not sure what format the attachment is in but I’m thinking somethings not right there.



  • Does the message trace in Exchange tell you anything? I know that when I had on-prem exchange and barracuda, I had weird issues where the attachment size restrictions being smaller/more restrictive on the Exchange server exhibited this behavior. The barracuda delivered, but Exchange rejected due to policy.