Kindle not detecting in AntiX Linux



  • Hi Team,
    To go with the Light Weight OS i am using AntiX Linux which is good in performance for me as of now.The same laptop installed with Zorin OS and ubuntu 18.04 which detected and automounted the Kindle device.When i have installed AntiX Linux the OS is not detecting the Kindle Device

    Tried Calibre which also fails in mounting.Help needed to access or mount my Kindle in AntiX Linux.

    Tried :
    Installed MTP,Checked Mount location nothing is showing.

    Output for reference:

    [email protected]:~# dme
    dmenu dmenu_path dmenu_run dmenu_run_hlwm dmesg
    [email protected]:~# dmesg | grep Kindle
    [ 719.666905] scsi 6:0:0:0: Direct-Access Kindle Internal Storage 0310 PQ: 0 ANSI: 2

    [email protected]:~# lsusb
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 004: ID 04f2:b3aa Chicony Electronics Co., Ltd
    Bus 001 Device 003: ID 0489:e062 Foxconn / Hon Hai
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 002: ID 1949:0004 Lab126, Inc. Amazon Kindle 3/4/Paperwhite
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    [email protected]:~$ uname -r
    4.9.146-antix.1-amd64-smp

    Packages installed for tried to mount

    [email protected]:~# sudo apt-get install libmtp-common
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libmtp-common is already the newest version (1.1.13-1).
    libmtp-common set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    [email protected]:~# sudo apt-get install python=pymtp
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Version 'pymtp' for 'python' was not found
    [email protected]:~# sudo apt-get install python-pymtp
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Recommended packages:
    python-id3
    The following NEW packages will be installed:
    python-pymtp
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 13.0 kB of archives.
    After this operation, 64.5 kB of additional disk space will be used.
    Get:1 http://mirror.0x.sg/debian stretch/main amd64 python-pymtp all 0.0.6-1.1 [13.0 kB]
    Fetched 13.0 kB in 0s (14.9 kB/s)
    Selecting previously unselected package python-pymtp.
    (Reading database ... 182534 files and directories currently installed.)
    Preparing to unpack .../python-pymtp_0.0.6-1.1_all.deb ...
    Unpacking python-pymtp (0.0.6-1.1) ...
    Setting up python-pymtp (0.0.6-1.1) ...
    [email protected]:~# sudo apt-get install mtp-tools
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    mtp-tools is already the newest version (1.1.13-1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    [email protected]:~# sudo apt-get install libmtp9
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libmtp9 is already the newest version (1.1.13-1).
    libmtp9 set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    [email protected]:~# sudo apt-get install libmtp-doc
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    libmtp-doc
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 375 kB of archives.
    After this operation, 3,542 kB of additional disk space will be used.
    Get:1 http://mirror.0x.sg/debian stretch/main amd64 libmtp-doc all 1.1.13-1 [375 kB]
    Fetched 375 kB in 3s (115 kB/s)
    Selecting previously unselected package libmtp-doc.
    (Reading database ... 182548 files and directories currently installed.)
    Preparing to unpack .../libmtp-doc_1.1.13-1_all.deb ...
    Unpacking libmtp-doc (1.1.13-1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up libmtp-doc (1.1.13-1) ...
    [email protected]:~# sudo apt-get install libmtp-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
    libusb-1.0-0-dev
    Recommended packages:
    libusb-1.0-doc
    The following NEW packages will be installed:
    libmtp-dev libusb-1.0-0-dev
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 123 kB of archives.
    After this operation, 384 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://mirror.0x.sg/debian stretch/main amd64 libusb-1.0-0-dev amd64 2:1.0.21-1 [72.7 kB]
    Get:2 http://mirror.0x.sg/debian stretch/main amd64 libmtp-dev amd64 1.1.13-1 [50.6 kB]
    Fetched 123 kB in 0s (156 kB/s)
    Selecting previously unselected package libusb-1.0-0-dev:amd64.
    (Reading database ... 182764 files and directories currently installed.)
    Preparing to unpack .../libusb-1.0-0-dev_2%3a1.0.21-1_amd64.deb ...
    Unpacking libusb-1.0-0-dev:amd64 (2:1.0.21-1) ...
    Selecting previously unselected package libmtp-dev:amd64.
    Preparing to unpack .../libmtp-dev_1.1.13-1_amd64.deb ...
    Unpacking libmtp-dev:amd64 (1.1.13-1) ...
    Setting up libusb-1.0-0-dev:amd64 (2:1.0.21-1) ...
    Setting up libmtp-dev:amd64 (1.1.13-1) ...
    [email protected]:~# sudo apt-get install libmtp-dbg
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    libmtp-dbg
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 291 kB of archives.
    After this operation, 328 kB of additional disk space will be used.
    Get:1 http://mirror.0x.sg/debian stretch/main amd64 libmtp-dbg amd64 1.1.13-1 [291 kB]
    Fetched 291 kB in 1s (166 kB/s)
    Selecting previously unselected package libmtp-dbg:amd64.
    (Reading database ... 182781 files and directories currently installed.)
    Preparing to unpack .../libmtp-dbg_1.1.13-1_amd64.deb ...
    Unpacking libmtp-dbg:amd64 (1.1.13-1) ...
    Setting up libmtp-dbg:amd64 (1.1.13-1) ...
    [email protected]:~# sudo apt-get install libmtp-common
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libmtp-common is already the newest version (1.1.13-1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    [email protected]:~# gmtp
    Detect: No raw devices found.

    CAlibre Error when tried from terminal
    [email protected]:~# calibre
    DBusExport: Failed to connect to DBUS session bus, with error: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally with the following error: dbus-launch: /opt/calibre/lib/libdbus-1.so.3: version `LIBDBUS_PRIVATE_1.10.26' not found (required by dbus-launch)

    Traceback (most recent call last):
    File "site-packages/calibre/gui2/notify.py", line 171, in get_notifier
    File "site-packages/calibre/gui2/notify.py", line 88, in get_dbus_notifier
    File "site-packages/dbus/_dbus.py", line 211, in new
    File "site-packages/dbus/_dbus.py", line 100, in new
    File "site-packages/dbus/bus.py", line 122, in new
    DBusException: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally with the following error: dbus-launch: /opt/calibre/lib/libdbus-1.so.3: version `LIBDBUS_PRIVATE_1.10.26' not found (required by dbus-launch)


Log in to reply