Nextcloud pretty URLs



  • I tried enabling the pretty URLs in Nextcloud, but I think there is a step that is different. I was following this manual.

    This line does not work when following @JaredBusch's tutorial.

    sudo -u www-data php /var/www/nextcloud/occ maintenance:update:htaccess
    

    I think part of it is that the user name should be apache, but when I try that I get this:

    [[email protected] ~]# sudo -u apache php /var/www/nextcloud/occ maintenance:update:htaccess
    Could not open input file: /var/www/nextcloud/occ
    

    I am guessing something is different between the install I did following the instructions, and what nextcloud assumes. I think it probably has something to do with this:

    mod_env and mod_rewrite must be installed on your webserver and the .htaccess must be writable by the HTTP user.
    


  • @Donahue said in Nextcloud pretty URLs:

    This line does not work when following @JaredBusch's tutorial.

    sudo -u www-data php /var/www/nextcloud/occ maintenance:update:htaccess
    

    This is Debian/Ubuntu. You found that exact line in my tutorial?

    @Donahue said in Nextcloud pretty URLs:

    I think part of it is that the user name should be apache, but when I try that I get this:

    [[email protected] ~]# sudo -u apache php /var/www/nextcloud/occ maintenance:update:htaccess
    

    This is Fedora/RHEL, but you have the base path wrong. Fedora/RHEL uses /var/www/html as the root web directory for apache.



  • @JaredBusch said in Nextcloud pretty URLs:

    @Donahue said in Nextcloud pretty URLs:

    This line does not work when following @JaredBusch's tutorial.

    sudo -u www-data php /var/www/nextcloud/occ maintenance:update:htaccess
    

    This is Debian/Ubuntu. You found that exact line in my tutorial?

    This was in the nextcloud instructions.

    @Donahue said in Nextcloud pretty URLs:

    I think part of it is that the user name should be apache, but when I try that I get this:

    [[email protected] ~]# sudo -u apache php /var/www/nextcloud/occ maintenance:update:htaccess
    

    This is Fedora/RHEL, but you have the base path wrong. Fedora/RHEL uses var/www/html as the root web directory for apache.

    I figured it was something like that. I tried this and it seemed to work, although the URLs still arent shorter.

    [[email protected] ~]# sudo -u apache php /var/www/html/nextcloud/occ maintenance:update:htaccess
    The current PHP memory limit is below the recommended value of 512MB.
    .htaccess has been updated
    


  • @Donahue said in Nextcloud pretty URLs:

    when I try and go to the site, which I am trying to get to https://files.domain.local, I want that to bring up the nextcloud stuff. But it currently brings up the fedora test page. How do I disable the test page and make NC accessible from that URL?

    That's a totally different issue that you are discussing in this thread. I will fork that for you.



  • oh, I thought it was the same thing.


Log in to reply