Remote Desktop Connection Prerequisites



  • Having an issue that I'm not sure is "the nature of the beast", but rather my own ignorance swinging back to smack me in the face.

    After restarting any of our servers, you are not able to remote into them until you have logged in with Admin credentials on the servers locally (within VMware web portal for the VM's). This affects both bare metal and VM servers, and it's an issue whether I try remoting into them from Windows 7 client, or Windows 10 client with my credentials, or any of my fellow Admins.

    This leads me to believe that I've not set the Allow Remote Desktop Connections up correctly, or missed a step somewhere.

    Here's what I've done:

    "Allow remote connections to this computer" - Checked

    "Allow connections only from computers running Remote Desktop with Network Level Authentication (recommended) - Checked

    Under "Select Users" I have all of our individual Admin usernames added, as well as the Domain Admins Security Group (which each of the Admin users are a part of). Example: CONTOSO\gijones, CONTOSO\myboss, CONTOSO\Domain Admins.

    Honestly this is only a slight annoyance, but being who I am I feel like I want to know if there is something I'm doing wrong here. Any help would be appreciated.



  • @g-i-jones

    Just guessing but I would take a look a the services for Remote Desktop and see what startup configuration they have and under what credentials they are running.

    I suspect that when you log in certain services are started that should have been running before that.

    Also do a bare installation without joining a domain so you have a fresh install to reference.
    I'd also check the "allow remote desktop from any version" option.



  • Does it work with a local account or have you only tried domain accounts?



  • @pete-s Services>Remote Desktop Services>Properties>Startup Type was set to Manual on all the servers. :🤦🏽♂

    Haven't tested it yet, but if I had to guess, that'd be the issue. Thanks!



  • @g-i-jones said in Remote Desktop Connection Prerequisites:

    @pete-s Services>Remote Desktop Services>Properties>Startup Type was set to Manual on all the servers. :🤦🏽♂

    Haven't tested it yet, but if I had to guess, that'd be the issue. Thanks!

    Hmmm I'm pretty sure my Services are setup that way as well by default (Manual start), and I don't have this issue. If I restart a VM and then RDP into it from my desktop, it connects right away without requiring local logon first. I'm waiting on one of my servers to finish updates so that I can verify for sure though. Be back in a few hours... 🙄 🔫



  • Check the Remote Desktop services to see what account type they are using to log on and startup type.



  • Yeah so I'm running a Server 2016 VM and after I reboot it, I can log on from RDP no issue. Same settings as you listed in OP. Must be something else.

    After a reboot, can you ping the server before logging in locally? If it's running any applications/services, are they accessible prior to login?

    I've had one server act in this fashion before, and it just wouldn't connect to the network without logging into it locally. It was an older Server 2008 box, and did it intermittently. Never really looked that deep into it since it was one machine and once I logged in everything went to normal.



  • @zachary715 I confirmed that this was the issue across the board. Changed to Automatic Start and no more issues.



  • @g-i-jones That's interesting that we don't have the same issue then. Glad you got it resolved.


Log in to reply