Virt Viewer on Windows connection issues



  • I dont get it VNC works like charm but wanted to enhance it and use virt viewer but it does not work easily, and I tried placing the IP of the KVM host and not the VM but still errors out

    spice://192.168.1.32:5900

    2_1533833567157_2018-08-09 19_49_12-Virtual Machines - fedora.lxd.png 1_1533833567157_2018-08-09 19_49_39-.png 0_1533833567156_2018-08-09 19_51_53-Virtual Machines - fedora.lxd.png

    the downloaded vv has localhost IP 127.0.0.1 for some reason



  • Your VM is only set to allow localhost address only.



  • For the VMs you want to access using virt-viewer, change Address from localhost only to All interfaces.
    You might have to configure your firewall to allow access for port 5900 and higher.

    0_1533835536587_998710f5-36f0-4940-bd2e-34403a7799ae-image.png



  • @black3dynamite said in Virt Viewer on Windows connection issues:

    For the VMs you want to access using virt-viewer, change Address from localhost only to All interfaces.
    You might have to configure your firewall to allow access for port 5900 and higher.

    0_1533835536587_998710f5-36f0-4940-bd2e-34403a7799ae-image.png

    Yup your right, and we had to install VIrt-Manager on Linux GUI OS just to tick this option cause it is easier, cockpit-machines needs to have more advanced options.

    1_1533836381368_2018-08-09 20_38_26-Fedora 64-bit (Client) - VMware Workstation.png 0_1533836381367_2018-08-09 20_38_16-test (1) - Remote Viewer.png



  • @emad-r said in Virt Viewer on Windows connection issues:

    Yup your right, and we had to install VIrt-Manager on Linux GUI OS just to tick this option cause it is easier, cockpit-machines needs to have more advanced options.

    On the hypervisor, you can use sudo virsh edit vm1 to make the changes.

    # Localhost only
    #
    <graphics type='spice' autoport='yes'>
          <listen type='address'/>
    </graphics>
    
    # To listen to all interfaces
    #
    <graphics type='spice' autoport='yes' listen='0.0.0.0'>
          <listen type='address' address='0.0.0.0'/>
    </graphics>