Windows 10 ignoring display sleep inactivity settings



  • Before I conscript Microsoft's wonderful tech support on this issue, I figured I'd ask here for assistance as there are at least 100 people here smarter than me 🙂

    Deployed new Server 2016 instance with my typical GPOs for security and computer settings.
    I typically have monitor blank configured for 15 minutes and lock after blank.
    The customer has decided that 15 minutes is far too short and, despite my concerns, wants 120 minutes.
    No worries, I'll just change the GPO for those that need this.
    I change the Computer/Policies/Administrative Tools/System/Power Management/Sleep Settings to reflect this.
    The computers -- All Windows 10 Pro -- show 2 hours in their settings but cannot be changed by the user as this is pushed via GPO. All good right?

    We receive a phone call that the computers are still locking after 15 minutes.
    GPO looks good, Windows looks good.. As a test, let's remove the forced power plan from GPO and let a user adjust it.

    Reboot the computers and they default to 15 minutes for display sleep and allow changing to 2 hours.
    15 minutes later, the displays are all sleeping again. Arrgg!

    Ok, forgot that Windows 8+ have a "Interactive logon: Machine inactivity limit" that needs to be set and it's currently at 900 seconds.
    Let's change that to 7200 seconds and see.
    15 minutes later and the monitors are sleeping again.

    I have checked the powercfg (and restored default settings), registry, etc and all show that machine inactivity is 7200 seconds, power plan shows 2 hours but STILL the monitors blank after 15 minutes.

    Has anyone run into this before and can offer some assistance before I spent the next week back and forth with MS?

    Thanks!



  • Since you're using GPO for this can you run a gpresult from one of the endpoints that are affected and show us what is there? Odds are the GPO either is being superseded or isn't being applied at all.



  • @dustinb3403, thanks for the reply. I have checked and the "Winning GPO" is the correct policy. I have subsequently removed ALL power settings from GPO in hopes that setting locally on the PC would fix this issue and give me time to diagnose.

    While Windows 10 shows the correct settings in the "metro" settings screen as well under the advanced settings for a power plan, the screens still blank at 15 minutes and lock the device.

    I have no idea what would be overriding this, why, and where to look aside from the various powercfg commands and associated registry keys -- which all read correctly.



  • @manxam GPO is likely where this setting is being applied from, more than likely from a setting that doesn't get rewritten in the registry easily.

    GPupdate /force might correct this issue, if you have removed these devices from the applicable GPO scope, but without seeing what you have and the results from a client it's really difficult to help you.

    As a test you can create a new scope and put just a test device in there and see what is happening. .



  • Did you :

    Reboot the computers

    Before or after?

    I have checked the powercfg (and restored default settings), registry, etc and all show that machine inactivity is 7200 seconds, power plan shows 2 hours but STILL the monitors blank after 15 minutes.

    edit (I'm thinking basics here, Since you removed the GPO of All power settings. )



  • @wrcombs & @DustinB3403, I have performed a gpresults while the GPO was active and verified that the settings matched what was shown on the devices.
    After removing the power settings in GPO, performed a "gpupdate /force" JIC and after a reboot, I performed another gpresult and verified that there were no settings being applied.
    I then manually configured power settings on 2 PCs via control panel on the devices themselves and the issue persists.

    For a device where display sleep is configured for "NONE":

    powercfg /query shows the following :

    Subgroup GUID: 7516b95f-f776-4464-8c53-06167f40cc99  (Display)
        GUID Alias: SUB_VIDEO
        Power Setting GUID: 3c0bc021-c8a8-4e07-a973-6b14cbcb2b7e  (Turn off display after)
          GUID Alias: VIDEOIDLE
          Minimum Possible Setting: 0x00000000
          Maximum Possible Setting: 0xffffffff
          Possible Settings increment: 0x00000001
          Possible Settings units: Seconds
        Current AC Power Setting Index: 0x00000000
        Current DC Power Setting Index: 0x0000012c
    

    And the appropriate registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\3c0bc021-c8a8-4e07-a973-6b14cbcb2b7e
        Attributes    REG_DWORD    0x2
        Description    REG_EXPAND_SZ    @%SystemRoot%\system32\powrprof.dll,-402,Video power down timeout after idle detection.
        FriendlyName    REG_EXPAND_SZ    @%SystemRoot%\system32\powrprof.dll,-403,Video power down timeout
        ValueIncrement    REG_DWORD    0x1
        ValueMax    REG_DWORD    0xffffffff
        ValueMin    REG_DWORD    0x0
        ValueUnits    REG_EXPAND_SZ    @%SystemRoot%\system32\powrprof.dll,-80,Seconds
    

    I'll create a new scope on a test laptop that's on-site and will advise.

    Thanks!



  • @manxam said in Windows 10 ignoring display sleep inactivity settings:

    Before I conscript Microsoft's wonderful tech support on this issue, I figured I'd ask here for assistance as there are at least 100 people here smarter than me 🙂

    Deployed new Server 2016 instance with my typical GPOs for security and computer settings.
    I typically have monitor blank configured for 15 minutes and lock after blank.
    The customer has decided that 15 minutes is far too short and, despite my concerns, wants 120 minutes.
    No worries, I'll just change the GPO for those that need this.
    I change the Computer/Policies/Administrative Tools/System/Power Management/Sleep Settings to reflect this.
    The computers -- All Windows 10 Pro -- show 2 hours in their settings but cannot be changed by the user as this is pushed via GPO. All good right?

    We receive a phone call that the computers are still locking after 15 minutes.
    GPO looks good, Windows looks good.. As a test, let's remove the forced power plan from GPO and let a user adjust it.

    Reboot the computers and they default to 15 minutes for display sleep and allow changing to 2 hours.
    15 minutes later, the displays are all sleeping again. Arrgg!

    Ok, forgot that Windows 8+ have a "Interactive logon: Machine inactivity limit" that needs to be set and it's currently at 900 seconds.
    Let's change that to 7200 seconds and see.
    15 minutes later and the monitors are sleeping again.

    I have checked the powercfg (and restored default settings), registry, etc and all show that machine inactivity is 7200 seconds, power plan shows 2 hours but STILL the monitors blank after 15 minutes.

    Has anyone run into this before and can offer some assistance before I spent the next week back and forth with MS?

    Thanks!

    I have absolutely ran into this - ultimate I had to run cmd line commands to fix it. Let me dig them up.



  • In my case I wanted to kill sleep altogether.

     c:\windows\system32\powercfg.exe -change -monitor-timeout-ac 0
     c:\windows\system32\powercfg.exe -change -monitor-timeout-dc 0
     c:\windows\system32\powercfg.exe -change -disk-timeout-ac 0
     c:\windows\system32\powercfg.exe -change -disk-timeout-dc 0
     c:\windows\system32\powercfg.exe -change -standby-timeout-ac 0
     c:\windows\system32\powercfg.exe -change -standby-timeout-dc 0
     c:\windows\system32\powercfg.exe -change -hibernate-timeout-ac 0
     c:\windows\system32\powercfg.exe -change -hibernate-timeout-dc 0