Remote Desktop to Fedora 28?



  • So I've setup my old laptop with Fedora v28 workstation.

    What can I use to, (for want of the correct Linux terminology), RDP into my Fedora laptop when I'm out in the field?

    Not being command line savvy, it will need to be a GUI interface.

    Thanks.

    MODEDIT: Added tags.



  • @siringo said in Remote Desktop to Fedora 28?:

    So I've setup my old laptop with Fedora v28 workstation.

    What can I use to, (for want of the correct Linux terminology), RDP into my Fedora laptop when I'm out in the field?

    Not being command line savvy, it will need to be a GUI interface.

    Thanks.

    If you want RDP, install xrdp, start the service and enable it to run at boot.

    sudo dnf -y install xrdp
    sudo systemctl start xrdp
    sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp
    sudo firewall-cmd --reload
    

    Will install it, start the service, enable the service at boot time, and open the local firewall port for it.



  • I’ve been using NoMachine for awhile now.



  • @travisdh1 said in Remote Desktop to Fedora 28?:

    @siringo said in Remote Desktop to Fedora 28?:

    So I've setup my old laptop with Fedora v28 workstation.

    What can I use to, (for want of the correct Linux terminology), RDP into my Fedora laptop when I'm out in the field?

    Not being command line savvy, it will need to be a GUI interface.

    Thanks.

    If you want RDP, install xrdp, start the service and enable it to run at boot.

    sudo dnf -y install xrdp
    sudo systemctl start xrdp
    sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp
    sudo firewall-cmd --reload
    

    Will install it, start the service, enable the service at boot time, and open the local firewall port for it.

    Thanks @travisdh1 Does that allow me to use Windows' mstsc.exe and give me the Fedora desktop? Sounds too easy 😉



  • @siringo said in Remote Desktop to Fedora 28?:

    @travisdh1 said in Remote Desktop to Fedora 28?:

    @siringo said in Remote Desktop to Fedora 28?:

    So I've setup my old laptop with Fedora v28 workstation.

    What can I use to, (for want of the correct Linux terminology), RDP into my Fedora laptop when I'm out in the field?

    Not being command line savvy, it will need to be a GUI interface.

    Thanks.

    If you want RDP, install xrdp, start the service and enable it to run at boot.

    sudo dnf -y install xrdp
    sudo systemctl start xrdp
    sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp
    sudo firewall-cmd --reload
    

    Will install it, start the service, enable the service at boot time, and open the local firewall port for it.

    Thanks @travisdh1 Does that allow me to use Windows' mstsc.exe and give me the Fedora desktop? Sounds too easy 😉

    Yes it does. Linux can use RDP just like Windows does. Or you can use VNC, just like on Windows, too.



  • @travisdh1 said in Remote Desktop to Fedora 28?:

    @siringo said in Remote Desktop to Fedora 28?:

    So I've setup my old laptop with Fedora v28 workstation.

    What can I use to, (for want of the correct Linux terminology), RDP into my Fedora laptop when I'm out in the field?

    Not being command line savvy, it will need to be a GUI interface.

    Thanks.

    If you want RDP, install xrdp, start the service and enable it to run at boot.

    sudo dnf -y install xrdp
    sudo systemctl start xrdp
    sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp
    sudo firewall-cmd --reload
    

    Will install it, start the service, enable the service at boot time, and open the local firewall port for it.

    Went ahead and did all the above and it seems to work, but I don't log in.

    I get prompted for my username & password, but this comes up:

    alt text

    I installed TigerVNC the other week and only partially configured that, I wonder if that might be screwing up XRDP?

    How can I uninstall TigerVNC?

    I found that root can log in OK, but not my standard user account, which makes sense to me.

    OK, So XRDP needs my stadard account to be in a group called 'tsusers' as shown below:

    alt text

    I don't think there is a tsusers group, so I need to create that and add my account to the group.
    How do I do that?



  • Well I've got most of the bugs sorted out and things seem to be working.



  • dnf remove tigervnc-server



  • Thought I would give this ago also... this is what I ran into

    0_1530196404151_2018-06-28 10_32_43-192.168.10.148 - Remote Desktop Connection.png

    This is from Windows to Fedora.



  • To add a user to a specific group

    useradd -G {group-name} username should work. You likely will need to run under sudo to do this though.



  • @dustinb3403 said in Remote Desktop to Fedora 28?:

    To add a user to a specific group

    useradd -G {group-name} username should work. You likely will need to run under sudo to do this though.

    I like to use sudo gpasswd -a username groupname personally. but it all gets the job done.



  • @gjacobse said in Remote Desktop to Fedora 28?:

    Thought I would give this ago also... this is what I ran into

    0_1530196404151_2018-06-28 10_32_43-192.168.10.148 - Remote Desktop Connection.png

    This is from Windows to Fedora.

    Yep, that is what I was getting also. Can you log in with root?

    I was getting that error & the one I posted above. I rebooted several times for various reasons and things started to become a bit more reliable.

    Thanks everyone for the help.



  • @siringo said in Remote Desktop to Fedora 28?:

    @gjacobse said in Remote Desktop to Fedora 28?:

    Thought I would give this ago also... this is what I ran into

    0_1530196404151_2018-06-28 10_32_43-192.168.10.148 - Remote Desktop Connection.png

    This is from Windows to Fedora.

    Yep, that is what I was getting also. Can you log in with root?

    I was getting that error & the one I posted above. I rebooted several times for various reasons and things started to become a bit more reliable.

    Thanks everyone for the help.

    Here's what I have done since.

    Added my <USER> to the wheel usergroup and rebooted. Since, I seem to be able to sign in. but yes,.. I was able to sign in as <ROOT>



  • @dustinb3403 said in Remote Desktop to Fedora 28?:

    To add a user to a specific group

    useradd -G {group-name} username should work. You likely will need to run under sudo to do this though.

    If you don't add a -a it removes all secondary groups other than the one you define. You pretty much always want to do usermod -aG group user



  • @stacksofplates said in Remote Desktop to Fedora 28?:

    @dustinb3403 said in Remote Desktop to Fedora 28?:

    To add a user to a specific group

    useradd -G {group-name} username should work. You likely will need to run under sudo to do this though.

    If you don't add a -a it removes all secondary groups other than the one you define. You pretty much always want to do useradd -aG group user

    I guess using sudo gpasswd -a username groupname avoids remembering to add -aG?



  • @black3dynamite said in Remote Desktop to Fedora 28?:

    @stacksofplates said in Remote Desktop to Fedora 28?:

    @dustinb3403 said in Remote Desktop to Fedora 28?:

    To add a user to a specific group

    useradd -G {group-name} username should work. You likely will need to run under sudo to do this though.

    If you don't add a -a it removes all secondary groups other than the one you define. You pretty much always want to do useradd -aG group user

    I guess using sudo gpasswd -a username groupname avoids remembering to add -aG?

    Yeah. I've always done usermod but it's personal preference.

    However the only way I know of to remove a user from a group is gpasswd



  • It occurred to me just now, that you should not need a full reboot after adding the <user> to your group... All that should be needed is a log out/in

    @scottalanmiller or @JaredBusch - please correct me if I have that incorrect.



  • @gjacobse said in Remote Desktop to Fedora 28?:

    It occurred to me just now, that you should not need a full reboot after adding the <user> to your group... All that should be needed is a log out/in

    @scottalanmiller or @JaredBusch - please correct me if I have that incorrect.

    Log out and log in is all that is required to apply new group permissions.



  • Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    


  • @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    You can make anything a one line command if you want. Back when running IRIX if hit their 512 character limit and have to script a single command when compiling open source tools on that. Thankfully haven't run into that issue recently!



  • @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    You can shorten the second. If you do

    system to enable --now xrdp
    

    It will enable and start the service at the same time.



  • @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    Also why are you using a pipe?



  • @stacksofplates said in Remote Desktop to Fedora 28?:

    @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    Also why are you using a pipe?

    @stacksofplates said in Remote Desktop to Fedora 28?:

    @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    Also why are you using a pipe?

    That's a good point. For your continuing BASH shell learning @gjacobse, a pipe ~ | ~ passes the output of the first command to the one after it. So ls -lha | grep ".." lists all files including the hidden ones and then searches for any with .. in the string returned. When you just want to run commands one after the other, the proper concatenation been is &&



  • @travisdh1 said in Remote Desktop to Fedora 28?:

    @stacksofplates said in Remote Desktop to Fedora 28?:

    @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    Also why are you using a pipe?

    @stacksofplates said in Remote Desktop to Fedora 28?:

    @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    Also why are you using a pipe?

    That's a good point. For your continuing BASH shell learning @gjacobse, a pipe ~ | ~ passes the output of the first command to the one after it. So ~ ls -lha | grep ".." ~ lists all files including the hidden ones and then searches for any with .. in the string returned. When you just want to run commands one after the other, the proper concatenation been is ~ && ~

    What does ; means after a command?



  • @black3dynamite said in Remote Desktop to Fedora 28?:

    @travisdh1 said in Remote Desktop to Fedora 28?:

    @stacksofplates said in Remote Desktop to Fedora 28?:

    @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    Also why are you using a pipe?

    @stacksofplates said in Remote Desktop to Fedora 28?:

    @gjacobse said in Remote Desktop to Fedora 28?:

    Yes - I learn. here is the same command - but in just three lines:

    sudo dnf install xrdp -y
    sudo systemctl start xrdp | sudo systemctl enable xrdp
    sudo firewall-cmd --permanent --add-port=3389/tcp | sudo firewall-cmd --reload
    
    

    Also why are you using a pipe?

    That's a good point. For your continuing BASH shell learning @gjacobse, a pipe ~ | ~ passes the output of the first command to the one after it. So ~ ls -lha | grep ".." ~ lists all files including the hidden ones and then searches for any with .. in the string returned. When you just want to run commands one after the other, the proper concatenation been is ~ && ~

    What does ; means after a command?

    && will stop if the preceding command throws an error while a semicolon will run the following command no matter if the first one throws an error.



  • Does this make a difference if I am running Cinnamon on the Fedora workstation? I installed via the instructions provided in this thread. I can make a connection, but when the screen comes up, it is just a blank window with a blank button. Then clicking the blank button, brings me to the screen below. I cannot type anything in the first drop down. I use my fedora username and password (added to the wheel group) but it just goes back to the blank window. 0_1537976635887_IMG_4864.JPG



  • I just did a fresh install of Fedora 28 to update my instructions for this, however, I've discovered the by default Fedora 28 has switched to Wayland, and there's no working VNC server that I am aware of that works with it.

    This may be part of the problem.



  • @dafyre said in Remote Desktop to Fedora 28?:

    I just did a fresh install of Fedora 28 to update my instructions for this, however, I've discovered the by default Fedora 28 has switched to Wayland, and there's no working VNC server that I am aware of that works with it.

    This may be part of the problem.

    ScreenConnect also doesn't play nice w Wayland!



  • @dafyre said in Remote Desktop to Fedora 28?:

    I just did a fresh install of Fedora 28 to update my instructions for this, however, I've discovered the by default Fedora 28 has switched to Wayland, and there's no working VNC server that I am aware of that works with it.

    This may be part of the problem.

    Its been default to Wayland for awhile but you can switch it to Xorg.



  • @black3dynamite said in Remote Desktop to Fedora 28?:

    @dafyre said in Remote Desktop to Fedora 28?:

    I just did a fresh install of Fedora 28 to update my instructions for this, however, I've discovered the by default Fedora 28 has switched to Wayland, and there's no working VNC server that I am aware of that works with it.

    This may be part of the problem.

    Its been default to Wayland for awhile but you can switch it to Xorg.

    Yeah. Now I just need to figure out how to switch the greeter to X and I'll be happy.