StarWind VSAN crashes with USB device attached


  • Banned

    HI,

    I'm trying to run StarWind VSAN 8, when the StarWindService.exe service tries to start, it gets stuck in a Starting state, and is unable to be stopped or manually killed with Task Manager, Process Hacker or pskill64.exe. Windows is unable kill the process when it tries to shutdown/reboot as is running on a Windows 10 build 1607 VM which has the two USB 2 controllers from a Intel C602 chipset and two NEC uPD720200 USB 3 controllers on a SuperMicro X9DAE motherboard passed through to it. The host OS is VMware ESXi 6.0 U2. To the USB 3 controllers are attached a Bluetooth dongle, LogiTech wireless mouse dongle and a Pluggable USB 3 SATA HDD enclosure (model # USB3-SATA-UASP1). On the USB 2 controllers are attached a Aquaero 6 XT fan controller and a Unicomp keyboard.
    I've tried adding and removing the USB controllers and attached devices and narrowed down the incompatible device to the HDD enclosure. The enclosure uses a ASMedia 1053E chip and USB Attached SCSI Protocol. And to it is attached a Seagate 4TB TeraScale HDD (model # ST4000NC000). As soon as the enclosure is powered off, the StarWindService manages to finish starting and works fine.
    Does anyone have any ideas as to why this is SATA enclosure is causing StarWind to crash? I was hoping to use StarWind's VTL feature to enable me to use Veeam Backup & Replication to backup a 24TB volume to virtual tapes stored on external USB HDDs. I've also tried attaching the enclosure to another VM, and storing the VTL files on a symlink to a network share and it doesnt work either.

    Please help.

    I did not find the right solution from the internet.

    References:
    https://forums.starwindsoftware.com/viewtopic.php?f=5&t=4602

    Thanks!




  • Service Provider


  • Vendor

    Nice... I’ve opened a support case for that. Please stay tuned, Michael & Co will reach out soon.


  • Vendor

    OK, it turns out somebody is taking old bugs (2+ years old) reported on our forum and push them to the other forums. I have no idea why...


  • Service Provider

    @kooler said in StarWind VSAN crashes with USB device attached:

    OK, it turns out somebody is taking old bugs (2+ years old) reported on our forum and push them to the other forums. I have no idea why...

    They were using it to promote other links that were removed. It's link spamming.