dns issue? pertino



  • hi guys

    I have an odd query which i need some help with pls...

    I have 3 virtual servers.

    1x domain controller (internal: 10.10.4.5)
    1x fs01 file server (internal: 10.10.4.7)
    1x app01 server (rds) (internal: 10.10.4.6)

    All have pertino VPN client installed so users can access the APP01 and FS01 resources from anywhere.

    The servers have internal IP's (shown above) but also have an IP from Pertino on a 172.86.160.X range.

    Recently weve run into problems where random people at random times cant access the servers (not all at the same time. ie totally random). someones it may be 5 users cant access one server, but everyone else can, then another 10 users cant access another server but everyone else can and so forth - its random.

    ive checked event viewer and see this error recently which i think is related....

    The system failed to register pointer (PTR) resource records (RRs) for network adapter
    with settings:

           Adapter Name : {7F022283-1684-4AF5-AC79-07855C065DEA}
           Host Name : app01
           Adapter-specific Domain Suffix : hq.MYDOMAIN.local
           DNS server list :
             	10.10.4.5
           Sent update to server : <?>
           IP Address :
             10.10.4.6
    

    The cause was DNS server failure. This may be because the reverse lookup zone is busy or missing on the DNS server that your computer needs to update. In most cases, this is a minor problem because it does not affect normal (forward) name resolution.

    If reverse (address-to-name) resolution is required for your computer, you can manually retry DNS registration of the network adapter and its settings by typing 'ipconfig /registerdns' at the command prompt. If problems still persist, contact your DNS server or network systems administrator. See event details for specific error code information.

    Do i need to configure something in DNS?

    I manged to resolve the issue once i restart the Pertino services on the 'broken' server and then it works but it keeps happening and I need to fix it permanently. I have disabled IPV6 on all servers and on the Pertino adapter as i used to get IPV6 replies when pinging which I didnt want.

    PLEASE CAN YOU HELP? I'm not sure how to go about this one.
    Thanks



  • I do not know anything about that error.

    I trialed Pertino with the original AD integration and it broke shit bad. I never went back to trying it because I left Pertino after CradlePoint bought them.

    Sounds like this works better now though.



  • I also had Pertino, but it worked OK during the trial phase. After purchasing and trying a rollout, I could not get it working the way I needed it and it caused all sorts of issues with dynamic DNS updates in my AD environment. It actually prevented any automatic updates to records while installed. I ended up getting a refund after 2 months of trying to make it work with their support. This was right after they were bought by Cradlepoint.



  • What do you guys use as an alternative? ZeroTier?



  • @joel said in dns issue? pertino:

    What do you guys use as an alternative? ZeroTier?

    Yes, I am using ZeroTier, but not trying to use DNS. I do not have the user use case that you do.

    The few users that use it for more than RDP have a link by IP to the share they want.



  • Yeah, but ZeroTier also has the same issue unless you right click on the Network interface created by ZeroTier and uncheck the Register DNS option...

    0_1529584579296_a972a7ea-3c40-4731-ab31-43491a34b5b5-image.png

    Note: This does block the DNS server from adding the ZeroTier IP addresses into DNS.



  • I thought Pertino went End of Life unless you migrated to their NetCloud platform a month or so back? Note, they did have an outage yesterday that could have caused your issues... https://status.cradlepoint.com/



  • @smitherick said in dns issue? pertino:

    I thought Pertino went End of Life unless you migrated to their NetCloud platform a month or so back? Note, they did have an outage yesterday that could have caused your issues... https://status.cradlepoint.com/

    That is interesting. I am glad I pulled the plug on it.

    I am just using OpenVPN AS ("traditional" VPN).



  • I'm actually transitioning my personal ZT to be more of a Site-to-Site VPN.

    I have it installed on a system at home, and a system in my remote data center. Traffic between the house and data center goes through ZT. That's not really how it was designed to be used, but it works well in this scenario.



  • I use ZT for my personal systems and phone.



  • @smitherick said in dns issue? pertino:

    I thought Pertino went End of Life unless you migrated to their NetCloud platform a month or so back? Note, they did have an outage yesterday that could have caused your issues... https://status.cradlepoint.com/

    That's my understanding.



  • @jaredbusch said in dns issue? pertino:

    I do not know anything about that error.

    I trialed Pertino with the original AD integration and it broke shit bad. I never went back to trying it because I left Pertino after CradlePoint bought them.

    Sounds like this works better now though.

    That's why I keep getting emails from Cradlepoint. Sorry, no answer to the problem 🙂



  • Sorry for threadjacking - How is Cradlepoint with regards to their 4G routers? I might have a need for something like that at a secondary location that would only need access to our ERP system and doesn't have "affordable" internet available.



  • @wrx7m said in dns issue? pertino:

    Sorry for threadjacking - How is Cradlepoint with regards to their 4G routers? I might have a need for something like that at a secondary location that would only need access to our ERP system and doesn't have "affordable" internet available.

    I highly recommend them for that purpose.


Log in to reply