Anyone running Exchange 2016 on Server 2016?



  • I just purchased MS Exchange 2016 for my company as we are upgrading from 2010. Up until recently, only Server 2012 R2 was supported for running Exchange 2016 on but now I see 2016 is supported. Despite reading some MS tech articles, guides and requirement docs, I'm still not quite sure how well it works on 2016.. just being a bit cautious I guess.

    I just wanted to see if anyone here is running Exchage 2016 on Server 2016 and if you have any issues or anything. I don't mind installing it on 2012 R2 if I have to, but I'd really rather deploy to Server 2016 if I can.



  • @dave247 said in Anyone running Exchange 2016 on Server 2016?:

    I just purchased MS Exchange 2016 for my company as we are upgrading from 2010. Up until recently, only Server 2012 R2 was supported for running Exchange 2016 on but now I see 2016 is supported. Despite reading some MS tech articles, guides and requirement docs, I'm still not quite sure how well it works on 2016.. just being a bit cautious I guess.

    I just wanted to see if anyone here is running Exchage 2016 on Server 2016 and if you have any issues or anything. I don't mind installing it on 2012 R2 if I have to, but I'd really rather deploy to Server 2016 if I can.

    So far no issues here, has been running 3 months now.



  • @dbeato said in Anyone running Exchange 2016 on Server 2016?:

    @dave247 said in Anyone running Exchange 2016 on Server 2016?:

    I just purchased MS Exchange 2016 for my company as we are upgrading from 2010. Up until recently, only Server 2012 R2 was supported for running Exchange 2016 on but now I see 2016 is supported. Despite reading some MS tech articles, guides and requirement docs, I'm still not quite sure how well it works on 2016.. just being a bit cautious I guess.

    I just wanted to see if anyone here is running Exchage 2016 on Server 2016 and if you have any issues or anything. I don't mind installing it on 2012 R2 if I have to, but I'd really rather deploy to Server 2016 if I can.

    So far no issues here, has been running 3 months now.

    Cool, thanks. I also checked with some other folks who I know use it and they say the same.


  • Service Provider

    This is MS' bread and butter. While I've not tried it, if it is officially supported I'd have little concern.



  • @scottalanmiller said in Anyone running Exchange 2016 on Server 2016?:

    This is MS' bread and butter. While I've not tried it, if it is officially supported I'd have little concern.

    0_1527484744157_430b78c9-7eee-4e5f-bc84-fcbdfdf77a3e-image.png