Pi just boot with a new SD Card after failure


  • Banned

    HI,

    I know many topics is ongoing with SD Card issues, but still I didn't find any answer for the following behavior.
    One day to another my pi frozen. After a power cycle it doesn't boot up anymore, just red led. No green led flashed.
    After this point I'm not able to boot up anymore the pi with the sam SD Card. I have to format and install a totally new physical SD Card which works again well. It happened already with 2 SD Cards, now the 3rd is running. Power is 1200mpa it should not have any issues with that. The "broken" SD Cards just work perfectly in other machines like photo camera or PC.
    I tried the following troubleshooting:

    • reformat with MAC and Windows
    • install from scratch
    • clone the card
    • clone another card
    • wait a day without power and sd card plugged
      This is my second PI and I had no issues with the other one. Can anybody answer how come PI recognize the SD Card and don't accept it anymore?

    Please help.

    I didn't find the right solution from the Internet.

    References:
    https://www.raspberrypi.org/forums/viewtopic.php?t=68643

    Thanks!



  • Raspberry PI's a stupidly cheap SBC, so if you have issues like this you'd just get another one. Assuming you're using class 10 SD cards, I would sooner think the root cause is a defective Raspberry PI, not the SD card or the OS you have installed on it.



  • I had issues with our two PI's that run some TV's. Constant freezing, not booting after power cycle etc. Had to re-image the SD card several times a month.

    In the end gave up and bought a good quality Samsung Evo Plus Class10 32GB card. Now i have no issues, even get them to reboot every night and they boot every time



  • Most SD cards are not designed with running an OS in mind. The log files and swap when needed severally impact their life span. If it's just this one Pi, then you might want to try replacing the Pi as well.