Nextcloud large file upload issues



  • I've recently installed Nextcloud 13 via Jared's guide here to a Vultr storage instance.

    I have no problem uploading files directly to a folder in the web interface, but if I create a "File Drop" shared folder, then uploads bigger than just a couple MB to said shared link fail. Is there some setting for the file drop that I'm missing? I'm testing a ~245MB ISO file as a test upload.



  • As a temporary workaround I've just made a shared folder specifically for this customer and set permissions to "Allow upload and editing", which works just fine. Ultimately I'd like to have one File Drop link that allows uploads only. I'll keep digging on this.

    EDIT: both upload links respond the same way, the connection I was testing on after the initial test was faster so the upload was able to finish before the 30 second timeout.



  • In your php.ini file, you need to set these parameters to something large:

    php_value upload_max_filesize = 16G
    php_value post_max_size = 16G
    


  • I've not used the file drop thing beyond a simple test once, so I have no idea if there are issues with it.

    There are various HTTP/PHP restrictions that you have to modify to upload larger files.

    But as this size file works in a different mode, that should not be the problem.



  • I love the file drop functionality, it's so cool.



  • @scottalanmiller I've actually followed every step on this list:
    https://docs.nextcloud.com/server/13/admin_manual/configuration_files/big_file_upload_configuration.html

    It appears to be a timeout that only affects an upload when the user isn't logged in. Using the "File Drop" link you only get an upload status spinner indicating that it's working. Once enabled the "Allow upload and editing" option you can actually see a progress bar for the upload, which restarts after 30 seconds, twice, then fails. Which is similar to what I was seeing with the File Drop link, it would show failed after about a minute.

    When I'm logged in and uploading I just did a 1.5GB file no problem, took about 12 min.



  • Oh, I see. That's interesting.



  • Anybody willing to test this out and see if you notice the same behavior?



  • I'm testing now with a 3.8 GB ISO file. I can't remember if I tweaked mine to work with large uploads or not. I do know that there's some settings you should modify on your Nginx proxy if you have one.



  • @dafyre said in Nextcloud large file upload issues:

    I'm testing now with a 3.8 GB ISO file. I can't remember if I tweaked mine to work with large uploads or not. I do know that there's some settings you should modify on your Nginx proxy if you have one.

    I am running behind an NGINX proxy. I'll look into that too.

    Make sure you're testing an upload to a shared link, not actually through your user interface please 😇



  • @bnrstnr said in Nextcloud large file upload issues:

    @dafyre said in Nextcloud large file upload issues:

    I'm testing now with a 3.8 GB ISO file.  I can't remember if I tweaked mine to work with large uploads or not.  I do know that there's some settings you should modify on your Nginx proxy if you have one.
    

    I am running behind an NGINX proxy. I'll look into that too.

    Make sure you're testing an upload to a shared link, not actually through your user interface please 😇

    Yepp. I logged out and am using a private browser window, just to be sure, lol... It's still uploading.



  • Found it..... 🤦🏻♂

    First line in my Nginx conf file
    client_max_body_size 40M;

    Changed it to my max settings for NC and it's working now.



  • It REALLY seemed like it was time based.



  • I was about to report back that mine worked and send you my Nginx settings, lol.


Log in to reply