Installing the agent



  • Argh. Okay. On a plane now. Will look when I can. 😞



  • @scottalanmiller said in Installing the agent:

    @wls-itguy said in Installing the agent:

    @dustinb3403 said in Installing the agent:

    Do you have wget or curl installed, I believe debian comes with both. So either should work.

    wget worked for Debian. Ubuntu failed but that is because of root being disabled by default.

    Just switch into root. Ubuntu doesn't disable root, they just don't hand out the password.

    Yes, it it... https://help.ubuntu.com/community/RootSudo

    By default, the root account password is locked in Ubuntu.



  • Debian 9

    [email protected]:~# wget -q -O - https://gitlab.com/dutchcolonial/sodiumsuiteinstallers/raw/master/unix.sh | bash -s 79bcd200ab29ef4fac4adc5a34ff0a9b7d065146
    Hit:1 http://security.debian.org stretch/updates InRelease
    Hit:2 http://apt.postgresql.org/pub/repos/apt wheezy-pgdg InRelease            
    Ign:3 http://ftp.us.debian.org/debian stretch InRelease                        
    Hit:4 http://ftp.us.debian.org/debian stretch-updates InRelease              
    Hit:5 http://ftp.us.debian.org/debian stretch Release                    
    Hit:6 http://cdn-fastly.deb.debian.org/debian wheezy-backports InRelease
    Reading package lists... Done                                          
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      dctrl-tools debconf-utils libjs-sphinxdoc libjs-underscore libpgm-5.2-0
      libsodium18 libzmq5 python-backports-abc python-cffi-backend
      python-concurrent.futures python-croniter python-crypto python-cryptography
      python-dateutil python-enum34 python-idna python-ipaddress python-jinja2
      python-markupsafe python-msgpack python-openssl python-pyasn1
      python-requests python-singledispatch python-systemd python-tornado
      python-tz python-urllib3 python-yaml python-zmq salt-common
    Suggested packages:
      debtags python-crypto-dbg python-crypto-doc python-cryptography-doc
      python-cryptography-vectors python-enum34-doc python-jinja2-doc
      python-openssl-doc python-openssl-dbg python-psutil-doc doc-base
      python-socks python-mysqldb python-tornado-doc python-twisted python-ntlm
      python-mako salt-doc python-augeas
    The following NEW packages will be installed:
      dctrl-tools debconf-utils libjs-sphinxdoc libjs-underscore libpgm-5.2-0
      libsodium18 libzmq5 python-backports-abc python-cffi-backend
      python-concurrent.futures python-croniter python-crypto python-cryptography
      python-dateutil python-enum34 python-idna python-ipaddress python-jinja2
      python-markupsafe python-msgpack python-openssl python-psutil python-pyasn1
      python-requests python-singledispatch python-systemd python-tornado
      python-tz python-urllib3 python-yaml python-zmq salt-common salt-minion
    0 upgraded, 33 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    Need to get 6,175 kB/7,074 kB of archives.
    After this operation, 33.6 MB of additional disk space will be used.
    Get:1 http://ftp.us.debian.org/debian stretch/main amd64 dctrl-tools amd64 2.24-2+b1 [104 kB]
    Get:2 http://ftp.us.debian.org/debian stretch/main amd64 debconf-utils all 1.5.61 [56.6 kB]
    Get:3 http://ftp.us.debian.org/debian stretch/main amd64 libjs-underscore all 1.8.3~dfsg-1 [63.8 kB]
    Get:4 http://ftp.us.debian.org/debian stretch/main amd64 libjs-sphinxdoc all 1.4.9-2 [69.5 kB]
    Get:5 http://ftp.us.debian.org/debian stretch/main amd64 libpgm-5.2-0 amd64 5.2.122~dfsg-2 [157 kB]
    Get:6 http://ftp.us.debian.org/debian stretch/main amd64 libsodium18 amd64 1.0.11-2 [161 kB]
    Get:7 http://ftp.us.debian.org/debian stretch/main amd64 libzmq5 amd64 4.2.1-4 [200 kB]
    Get:8 http://ftp.us.debian.org/debian stretch/main amd64 python-backports-abc all 0.5-1 [6,050 B]
    Get:9 http://ftp.us.debian.org/debian stretch/main amd64 python-concurrent.futures all 3.0.5-3 [35.8 kB]
    Get:10 http://ftp.us.debian.org/debian stretch/main amd64 python-dateutil all 2.5.3-2 [51.3 kB]
    Get:11 http://ftp.us.debian.org/debian stretch/main amd64 python-tz all 2016.7-0.3 [33.7 kB]
    Get:12 http://ftp.us.debian.org/debian stretch/main amd64 python-croniter all 0.3.12-2 [12.6 kB]
    Get:13 http://ftp.us.debian.org/debian stretch/main amd64 python-markupsafe amd64 0.23-3 [14.4 kB]
    Get:14 http://ftp.us.debian.org/debian stretch/main amd64 python-jinja2 all 2.8-1 [111 kB]
    Get:15 http://ftp.us.debian.org/debian stretch/main amd64 python-msgpack amd64 0.4.8-1 [67.8 kB]
    Get:16 http://ftp.us.debian.org/debian stretch/main amd64 python-psutil amd64 5.0.1-1 [127 kB]
    Get:17 http://ftp.us.debian.org/debian stretch/main amd64 python-singledispatch all 3.4.0.3-2 [9,690 B]
    Get:18 http://ftp.us.debian.org/debian stretch/main amd64 python-systemd amd64 233-1 [32.6 kB]
    Get:19 http://ftp.us.debian.org/debian stretch/main amd64 python-tornado amd64 4.4.3-1 [313 kB]
    Get:20 http://ftp.us.debian.org/debian stretch/main amd64 python-yaml amd64 3.12-1 [119 kB]
    Get:21 http://ftp.us.debian.org/debian stretch/main amd64 python-zmq amd64 16.0.2-2 [243 kB]
    Get:22 http://ftp.us.debian.org/debian stretch/main amd64 salt-common all 2016.11.2+ds-1 [4,152 kB]
    Get:23 http://ftp.us.debian.org/debian stretch/main amd64 salt-minion all 2016.11.2+ds-1 [34.9 kB]
    Fetched 6,175 kB in 1s (3,811 kB/s)
    Extracting templates from packages: 100%
    Selecting previously unselected package dctrl-tools.
    (Reading database ... 94652 files and directories currently installed.)
    Preparing to unpack .../00-dctrl-tools_2.24-2+b1_amd64.deb ...
    Unpacking dctrl-tools (2.24-2+b1) ...
    Selecting previously unselected package debconf-utils.
    Preparing to unpack .../01-debconf-utils_1.5.61_all.deb ...
    Unpacking debconf-utils (1.5.61) ...
    Selecting previously unselected package libjs-underscore.
    Preparing to unpack .../02-libjs-underscore_1.8.3~dfsg-1_all.deb ...
    Unpacking libjs-underscore (1.8.3~dfsg-1) ...
    Selecting previously unselected package libjs-sphinxdoc.
    Preparing to unpack .../03-libjs-sphinxdoc_1.4.9-2_all.deb ...
    Unpacking libjs-sphinxdoc (1.4.9-2) ...
    Selecting previously unselected package libpgm-5.2-0:amd64.
    Preparing to unpack .../04-libpgm-5.2-0_5.2.122~dfsg-2_amd64.deb ...
    Unpacking libpgm-5.2-0:amd64 (5.2.122~dfsg-2) ...
    Selecting previously unselected package libsodium18:amd64.
    Preparing to unpack .../05-libsodium18_1.0.11-2_amd64.deb ...
    Unpacking libsodium18:amd64 (1.0.11-2) ...
    Selecting previously unselected package libzmq5:amd64.
    Preparing to unpack .../06-libzmq5_4.2.1-4_amd64.deb ...
    Unpacking libzmq5:amd64 (4.2.1-4) ...
    Selecting previously unselected package python-backports-abc.
    Preparing to unpack .../07-python-backports-abc_0.5-1_all.deb ...
    Unpacking python-backports-abc (0.5-1) ...
    Selecting previously unselected package python-cffi-backend.
    Preparing to unpack .../08-python-cffi-backend_1.9.1-2_amd64.deb ...
    Unpacking python-cffi-backend (1.9.1-2) ...
    Selecting previously unselected package python-concurrent.futures.
    Preparing to unpack .../09-python-concurrent.futures_3.0.5-3_all.deb ...
    Unpacking python-concurrent.futures (3.0.5-3) ...
    Selecting previously unselected package python-dateutil.
    Preparing to unpack .../10-python-dateutil_2.5.3-2_all.deb ...
    Unpacking python-dateutil (2.5.3-2) ...
    Selecting previously unselected package python-tz.
    Preparing to unpack .../11-python-tz_2016.7-0.3_all.deb ...
    Unpacking python-tz (2016.7-0.3) ...
    Selecting previously unselected package python-croniter.
    Preparing to unpack .../12-python-croniter_0.3.12-2_all.deb ...
    Unpacking python-croniter (0.3.12-2) ...
    Selecting previously unselected package python-crypto.
    Preparing to unpack .../13-python-crypto_2.6.1-7_amd64.deb ...
    Unpacking python-crypto (2.6.1-7) ...
    Selecting previously unselected package python-enum34.
    Preparing to unpack .../14-python-enum34_1.1.6-1_all.deb ...
    Unpacking python-enum34 (1.1.6-1) ...
    Selecting previously unselected package python-idna.
    Preparing to unpack .../15-python-idna_2.2-1_all.deb ...
    Unpacking python-idna (2.2-1) ...
    Selecting previously unselected package python-ipaddress.
    Preparing to unpack .../16-python-ipaddress_1.0.17-1_all.deb ...
    Unpacking python-ipaddress (1.0.17-1) ...
    Selecting previously unselected package python-pyasn1.
    Preparing to unpack .../17-python-pyasn1_0.1.9-2_all.deb ...
    Unpacking python-pyasn1 (0.1.9-2) ...
    Selecting previously unselected package python-cryptography.
    Preparing to unpack .../18-python-cryptography_1.7.1-3_amd64.deb ...
    Unpacking python-cryptography (1.7.1-3) ...
    Selecting previously unselected package python-markupsafe.
    Preparing to unpack .../19-python-markupsafe_0.23-3_amd64.deb ...
    Unpacking python-markupsafe (0.23-3) ...
    Selecting previously unselected package python-jinja2.
    Preparing to unpack .../20-python-jinja2_2.8-1_all.deb ...
    Unpacking python-jinja2 (2.8-1) ...
    Selecting previously unselected package python-msgpack.
    Preparing to unpack .../21-python-msgpack_0.4.8-1_amd64.deb ...
    Unpacking python-msgpack (0.4.8-1) ...
    Selecting previously unselected package python-openssl.
    Preparing to unpack .../22-python-openssl_16.2.0-1_all.deb ...
    Unpacking python-openssl (16.2.0-1) ...
    Selecting previously unselected package python-psutil.
    Preparing to unpack .../23-python-psutil_5.0.1-1_amd64.deb ...
    Unpacking python-psutil (5.0.1-1) ...
    Selecting previously unselected package python-urllib3.
    Preparing to unpack .../24-python-urllib3_1.19.1-1_all.deb ...
    Unpacking python-urllib3 (1.19.1-1) ...
    Selecting previously unselected package python-requests.
    Preparing to unpack .../25-python-requests_2.12.4-1_all.deb ...
    Unpacking python-requests (2.12.4-1) ...
    Selecting previously unselected package python-singledispatch.
    Preparing to unpack .../26-python-singledispatch_3.4.0.3-2_all.deb ...
    Unpacking python-singledispatch (3.4.0.3-2) ...
    Selecting previously unselected package python-systemd.
    Preparing to unpack .../27-python-systemd_233-1_amd64.deb ...
    Unpacking python-systemd (233-1) ...
    Selecting previously unselected package python-tornado.
    Preparing to unpack .../28-python-tornado_4.4.3-1_amd64.deb ...
    Unpacking python-tornado (4.4.3-1) ...
    Selecting previously unselected package python-yaml.
    Preparing to unpack .../29-python-yaml_3.12-1_amd64.deb ...
    Unpacking python-yaml (3.12-1) ...
    Selecting previously unselected package python-zmq.
    Preparing to unpack .../30-python-zmq_16.0.2-2_amd64.deb ...
    Unpacking python-zmq (16.0.2-2) ...
    Selecting previously unselected package salt-common.
    Preparing to unpack .../31-salt-common_2016.11.2+ds-1_all.deb ...
    Unpacking salt-common (2016.11.2+ds-1) ...
    Selecting previously unselected package salt-minion.
    Preparing to unpack .../32-salt-minion_2016.11.2+ds-1_all.deb ...
    Unpacking salt-minion (2016.11.2+ds-1) ...
    Setting up python-idna (2.2-1) ...
    Setting up libpgm-5.2-0:amd64 (5.2.122~dfsg-2) ...
    Setting up python-msgpack (0.4.8-1) ...
    Setting up python-urllib3 (1.19.1-1) ...
    Setting up python-yaml (3.12-1) ...
    Setting up python-crypto (2.6.1-7) ...
    Setting up python-backports-abc (0.5-1) ...
    Setting up libjs-underscore (1.8.3~dfsg-1) ...
    Setting up python-pyasn1 (0.1.9-2) ...
    Setting up debconf-utils (1.5.61) ...
    Setting up python-tz (2016.7-0.3) ...
    Setting up libjs-sphinxdoc (1.4.9-2) ...
    Setting up dctrl-tools (2.24-2+b1) ...
    Setting up python-markupsafe (0.23-3) ...
    Setting up python-dateutil (2.5.3-2) ...
    Setting up python-cffi-backend (1.9.1-2) ...
    Setting up openssh-server (1:7.4p1-10+deb9u2) ...
    Processing triggers for libc-bin (2.24-11+deb9u1) ...
    Setting up python-psutil (5.0.1-1) ...
    Setting up python-systemd (233-1) ...
    Setting up python-enum34 (1.1.6-1) ...
    Processing triggers for systemd (232-25+deb9u1) ...
    Setting up python-requests (2.12.4-1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up python-concurrent.futures (3.0.5-3) ...
    Setting up python-singledispatch (3.4.0.3-2) ...
    Setting up libsodium18:amd64 (1.0.11-2) ...
    Setting up python-croniter (0.3.12-2) ...
    Setting up python-ipaddress (1.0.17-1) ...
    Setting up rsyslog (8.24.0-1) ...
    Setting up libzmq5:amd64 (4.2.1-4) ...
    Setting up python-jinja2 (2.8-1) ...
    Setting up python-tornado (4.4.3-1) ...
    Setting up python-cryptography (1.7.1-3) ...
    Setting up python-zmq (16.0.2-2) ...
    Setting up salt-common (2016.11.2+ds-1) ...
    Setting up python-openssl (16.2.0-1) ...
    Setting up salt-minion (2016.11.2+ds-1) ...
    
    Configuration file '/etc/salt/minion'
     ==> File on system created by you or by a script.
     ==> File also in package provided by package maintainer.
       What would you like to do about it ?  Your options are:
        Y or I  : install the package maintainer's version
        N or O  : keep your currently-installed version
          D     : show the differences between the versions
          Z     : start a shell to examine the situation
     The default action is to keep your current version.
    *** minion (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing package salt-minion (--configure):
     end of file on stdin at conffile prompt
    Processing triggers for libc-bin (2.24-11+deb9u1) ...
    Processing triggers for systemd (232-25+deb9u1) ...
    Errors were encountered while processing:
     salt-minion
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    main: line 29: uuidgen: command not found
    Synchronizing state of salt-minion.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable salt-minion
    


  • This is because you already have Salt. This will take a bit more work. But can be done pretty easily.



  • Here is the latest issue:

    C:\WINDOWS\system32>choco uninstall salt-minion
    Chocolatey v0.10.8
    Uninstalling the following packages:
    salt-minion
    salt-minion is not installed. Cannot uninstall a non-existent package.
    
    Chocolatey uninstalled 0/1 packages. 1 packages failed.
     See the log for details (C:\ProgramData\chocolatey\logs\chocolatey.log).
    
    Failures
     - salt-minion - salt-minion is not installed. Cannot uninstall a non-existent package.
    
    If a package uninstall is failing and/or you've already uninstalled the
     software outside of Chocolatey, you can attempt to run the command
     with `-n` to skip running a chocolateyUninstall script, additionally
     adding `--skip-autouninstaller` to skip an attempt to automatically
     remove system-installed software. This will only remove the packaging
     files and not things like software installed to Programs and Features.
    
    If a package is failing because it is a dependency of another package
     or packages, then you may first need to consider if it needs removed
     as it is typically installed as a dependency for a reason. If you
     decide that you still want to remove it, head into
     `$env:ChocolateyInstall\lib` and find the package folder you want
     removed. Then delete the folder for the package. This option should
     only be used as a last resort.
    
    
    C:\WINDOWS\system32>choco uninstall salt-minion -n
    Chocolatey v0.10.8
    Uninstalling the following packages:
    salt-minion
    salt-minion is not installed. Cannot uninstall a non-existent package.
    
    Chocolatey uninstalled 0/1 packages. 1 packages failed.
     See the log for details (C:\ProgramData\chocolatey\logs\chocolatey.log).
    
    Failures
     - salt-minion - salt-minion is not installed. Cannot uninstall a non-existent package.
    
    If a package uninstall is failing and/or you've already uninstalled the
     software outside of Chocolatey, you can attempt to run the command
     with `-n` to skip running a chocolateyUninstall script, additionally
     adding `--skip-autouninstaller` to skip an attempt to automatically
     remove system-installed software. This will only remove the packaging
     files and not things like software installed to Programs and Features.
    
    If a package is failing because it is a dependency of another package
     or packages, then you may first need to consider if it needs removed
     as it is typically installed as a dependency for a reason. If you
     decide that you still want to remove it, head into
     `$env:ChocolateyInstall\lib` and find the package folder you want
     removed. Then delete the folder for the package. This option should
     only be used as a last resort.
    
    
    C:\WINDOWS\system32>@powershell Invoke-Webrequest https://gitlab.com/dutchcolonial/sodiumsuiteinstallers/raw/master/windows.cmd -UseBasicParsing -OutFile windowsinstall.cmd ; cmd /c .\windowsinstall.cmd 79bcd200ab29ef4fac4adc5a34ff0a9b7d065146
    
    C:\WINDOWS\system32>set companyID=79bcd200ab29ef4fac4adc5a34ff0a9b7d065146
    
    C:\WINDOWS\system32>set masterURL="na1.waxquixotic.com"
    Getting latest version of the Chocolatey package for download.
    Getting Chocolatey from https://chocolatey.org/api/v2/package/chocolatey/0.10.8.
    Extracting C:\Users\HARTWI~1.SEM\AppData\Local\Temp\chocolatey\chocInstall\chocolatey.zip to C:\Users\HARTWI~1.SEM\AppData\Local\Temp\chocolatey\chocInstall...
    Installing chocolatey on this machine
    Creating ChocolateyInstall as an environment variable (targeting 'Machine')
      Setting ChocolateyInstall to 'C:\ProgramData\chocolatey'
    WARNING: It's very likely you will need to close and reopen your shell
      before you can use choco.
    Restricting write permissions to Administrators
    We are setting up the Chocolatey package repository.
    The packages themselves go to 'C:\ProgramData\chocolatey\lib'
      (i.e. C:\ProgramData\chocolatey\lib\yourPackageName).
    A shim file for the command line goes to 'C:\ProgramData\chocolatey\bin'
      and points to an executable in 'C:\ProgramData\chocolatey\lib\yourPackageName'.
    
    Creating Chocolatey folders if they do not already exist.
    
    WARNING: You can safely ignore errors related to missing log files when
      upgrading from a version of Chocolatey less than 0.9.9.
      'Batch file could not be found' is also safe to ignore.
      'The system cannot find the file specified' - also safe.
    WARNING: Not setting tab completion: Profile file does not exist at
    'C:\Users\hartwigj.SEMINARY\Documents\WindowsPowerShell\Microsoft.PowerShell_profile.ps1'.
    Chocolatey (choco.exe) is now ready.
    You can call choco from anywhere, command line or powershell by typing choco.
    Run choco /? for a list of functions.
    You may need to shut down and restart powershell and/or consoles
     first prior to using choco.
    Ensuring chocolatey commands are on the path
    Ensuring chocolatey.nupkg is in the lib folder
    
    C:\WINDOWS\system32>choco install saltminion -y --ignore-checksums
    Chocolatey v0.10.8
    Installing the following packages:
    saltminion
    By installing you accept licenses for the packages.
    saltminion v2017.7.2 already installed.
     Use --force to reinstall, specify a version to install, or try upgrade.
    
    Chocolatey installed 0/1 packages.
     See the log for details (C:\ProgramData\chocolatey\logs\chocolatey.log).
    
    Warnings:
     - saltminion - saltminion v2017.7.2 already installed.
     Use --force to reinstall, specify a version to install, or try upgrade.
    
    C:\WINDOWS\system32>icacls "c:\salt\bin\Lib\site-packages\salt\" /grant "Authenticated Users":(OI)(CI)R
    Invalid parameter "Users:(OI)(CI)R   "
    
    C:\WINDOWS\system32>echo 79bcd200ab29ef4fac4adc5a34ff0a9b7d065146   1>c:\salt\bin\lib\site-packages\salt\companyName.txt
    The system cannot find the path specified.
    
    C:\WINDOWS\system32>echo master: "na1.waxquixotic.com"   1>c:\salt\conf\minion.d\mast.conf
    
    C:\WINDOWS\system32>net stop salt-minion   && net start salt-minion
    The service name is invalid.
    
    More help is available by typing NET HELPMSG 2185.
    


  • Try installing now, Windows installer now "should" deal with this scenario.



  • @scottalanmiller said in Installing the agent:

    Try installing now, Windows installer now "should" deal with this scenario.

    All good.



  • @wls-itguy said in Installing the agent:

    @scottalanmiller said in Installing the agent:

    Try installing now, Windows installer now "should" deal with this scenario.

    All good.

    Awesome. The new installer for Windows is a little more aggressive 😉



  • Installing on home R-Pi machine. Not sure if something went wrong or not. Looked like it failed but I can't tell.

    [email protected]:~ $ sudo su
    [email protected]:/home/pi# wget -q -O - https://gitlab.com/dutchcolonial/sodiumsuiteinstallers/raw/master/unix.sh | bash -s 79bcd200ab29ef4fac4adc5a34ff0a9b7d065146
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package uuid-runtime is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'uuid-runtime' has no installation candidate
    Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]     
    Hit:2 http://archive.raspberrypi.org/debian stretch InRelease                  
    Get:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
    Get:4 http://raspbian.raspberrypi.org/raspbian stretch/contrib armhf Packages [56.8 kB]
    Get:5 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages [95.2 kB]
    Get:6 http://raspbian.raspberrypi.org/raspbian stretch/rpi armhf Packages [1,360 B]
    Fetched 11.8 MB in 45s (258 kB/s)                                              
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      dctrl-tools dirmngr python-apt python-backports-abc
      python-concurrent.futures python-croniter python-dateutil python-msgpack
      python-singledispatch python-systemd python-tornado python-tz python-yaml
      python-zmq salt-common
    Suggested packages:
      debtags pinentry-gnome3 tor python-apt-dbg python-apt-doc python-psutil-doc
      python-mysqldb python-pycurl python-tornado-doc python-twisted python-mako
      salt-doc python-augeas
    The following NEW packages will be installed:
      dctrl-tools dirmngr python-apt python-backports-abc
      python-concurrent.futures python-croniter python-dateutil python-msgpack
      python-psutil python-singledispatch python-systemd python-tornado python-tz
      python-yaml python-zmq salt-common salt-minion uuid-runtime
    0 upgraded, 18 newly installed, 0 to remove and 0 not upgraded.
    Need to get 6,069 kB of archives.
    After this operation, 27.3 MB of additional disk space will be used.
    Get:1 http://mirrors.syringanetworks.net/raspbian/raspbian stretch/main armhf uuid-runtime armhf 2.29.2-1+deb9u1 [80.9 kB]
    Get:2 http://raspbian.mirrors.lucidnetworks.net/raspbian stretch/main armhf dirmngr armhf 2.1.18-8~deb9u1 [546 kB]
    Get:3 http://mirrors.syringanetworks.net/raspbian/raspbian stretch/main armhf python-apt armhf 1.1.0~beta5 [157 kB]
    Get:4 http://mirror.us.leaseweb.net/raspbian/raspbian stretch/main armhf dctrl-tools armhf 2.24-2 [94.4 kB]
    Get:5 http://mirror.web-ster.com/raspbian/raspbian stretch/main armhf python-backports-abc all 0.5-1 [6,050 B]
    Get:7 http://mirror.us.leaseweb.net/raspbian/raspbian stretch/main armhf python-dateutil all 2.5.3-2 [51.3 kB]
    Get:6 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-concurrent.futures all 3.0.5-3 [35.8 kB]
    Get:8 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-tz all 2016.7-0.3 [33.7 kB]
    Get:9 http://mirror.web-ster.com/raspbian/raspbian stretch/main armhf python-croniter all 0.3.12-2 [12.6 kB]
    Get:10 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-msgpack armhf 0.4.8-1 [62.9 kB]
    Get:11 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-psutil armhf 5.0.1-1 [126 kB]
    Get:12 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-singledispatch all 3.4.0.3-2 [9,690 B]
    Get:13 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-systemd armhf 233-1 [30.1 kB]
    Get:14 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-tornado armhf 4.4.3-1 [313 kB]
    Get:15 http://mirrors.syringanetworks.net/raspbian/raspbian stretch/main armhf python-yaml armhf 3.12-1 [103 kB]
    Get:16 http://raspbian-us.ngc292.space/raspbian stretch/main armhf python-zmq armhf 16.0.2-2 [219 kB]
    Get:17 http://mirrors.syringanetworks.net/raspbian/raspbian stretch/main armhf salt-common all 2016.11.2+ds-1+deb9u1 [4,153 kB]
    Get:18 http://mirrors.syringanetworks.net/raspbian/raspbian stretch/main armhf salt-minion all 2016.11.2+ds-1+deb9u1 [35.1 kB]
    Fetched 6,069 kB in 25s (236 kB/s)                                             
    Selecting previously unselected package uuid-runtime.
    (Reading database ... 124697 files and directories currently installed.)
    Preparing to unpack .../00-uuid-runtime_2.29.2-1+deb9u1_armhf.deb ...
    Unpacking uuid-runtime (2.29.2-1+deb9u1) ...
    Selecting previously unselected package dirmngr.
    Preparing to unpack .../01-dirmngr_2.1.18-8~deb9u1_armhf.deb ...
    Unpacking dirmngr (2.1.18-8~deb9u1) ...
    Selecting previously unselected package python-apt.
    Preparing to unpack .../02-python-apt_1.1.0~beta5_armhf.deb ...
    Unpacking python-apt (1.1.0~beta5) ...
    Selecting previously unselected package dctrl-tools.
    Preparing to unpack .../03-dctrl-tools_2.24-2_armhf.deb ...
    Unpacking dctrl-tools (2.24-2) ...
    Selecting previously unselected package python-backports-abc.
    Preparing to unpack .../04-python-backports-abc_0.5-1_all.deb ...
    Unpacking python-backports-abc (0.5-1) ...
    Selecting previously unselected package python-concurrent.futures.
    Preparing to unpack .../05-python-concurrent.futures_3.0.5-3_all.deb ...
    Unpacking python-concurrent.futures (3.0.5-3) ...
    Selecting previously unselected package python-dateutil.
    Preparing to unpack .../06-python-dateutil_2.5.3-2_all.deb ...
    Unpacking python-dateutil (2.5.3-2) ...
    Selecting previously unselected package python-tz.
    Preparing to unpack .../07-python-tz_2016.7-0.3_all.deb ...
    Unpacking python-tz (2016.7-0.3) ...
    Selecting previously unselected package python-croniter.
    Preparing to unpack .../08-python-croniter_0.3.12-2_all.deb ...
    Unpacking python-croniter (0.3.12-2) ...
    Selecting previously unselected package python-msgpack.
    Preparing to unpack .../09-python-msgpack_0.4.8-1_armhf.deb ...
    Unpacking python-msgpack (0.4.8-1) ...
    Selecting previously unselected package python-psutil.
    Preparing to unpack .../10-python-psutil_5.0.1-1_armhf.deb ...
    Unpacking python-psutil (5.0.1-1) ...
    Selecting previously unselected package python-singledispatch.
    Preparing to unpack .../11-python-singledispatch_3.4.0.3-2_all.deb ...
    Unpacking python-singledispatch (3.4.0.3-2) ...
    Selecting previously unselected package python-systemd.
    Preparing to unpack .../12-python-systemd_233-1_armhf.deb ...
    Unpacking python-systemd (233-1) ...
    Selecting previously unselected package python-tornado.
    Preparing to unpack .../13-python-tornado_4.4.3-1_armhf.deb ...
    Unpacking python-tornado (4.4.3-1) ...
    Selecting previously unselected package python-yaml.
    Preparing to unpack .../14-python-yaml_3.12-1_armhf.deb ...
    Unpacking python-yaml (3.12-1) ...
    Selecting previously unselected package python-zmq.
    Preparing to unpack .../15-python-zmq_16.0.2-2_armhf.deb ...
    Unpacking python-zmq (16.0.2-2) ...
    Selecting previously unselected package salt-common.
    Preparing to unpack .../16-salt-common_2016.11.2+ds-1+deb9u1_all.deb ...
    Unpacking salt-common (2016.11.2+ds-1+deb9u1) ...
    Selecting previously unselected package salt-minion.
    Preparing to unpack .../17-salt-minion_2016.11.2+ds-1+deb9u1_all.deb ...
    Unpacking salt-minion (2016.11.2+ds-1+deb9u1) ...
    Setting up python-msgpack (0.4.8-1) ...
    Setting up python-yaml (3.12-1) ...
    Setting up python-backports-abc (0.5-1) ...
    Setting up python-tz (2016.7-0.3) ...
    Setting up dctrl-tools (2.24-2) ...
    Setting up uuid-runtime (2.29.2-1+deb9u1) ...
    Adding group `uuidd' (GID 116) ...
    Done.
    Warning: The home dir /run/uuidd you specified can't be accessed: No such file or directory
    Adding system user `uuidd' (UID 111) ...
    Adding new user `uuidd' (UID 111) with group `uuidd' ...
    Not creating home directory `/run/uuidd'.
    Created symlink /etc/systemd/system/sockets.target.wants/uuidd.socket → /lib/systemd/system/uuidd.socket.
    Setting up python-dateutil (2.5.3-2) ...
    Setting up python-psutil (5.0.1-1) ...
    Setting up python-systemd (233-1) ...
    Processing triggers for systemd (232-25+deb9u2) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up python-concurrent.futures (3.0.5-3) ...
    Setting up python-singledispatch (3.4.0.3-2) ...
    Setting up python-croniter (0.3.12-2) ...
    Setting up dirmngr (2.1.18-8~deb9u1) ...
    Setting up python-zmq (16.0.2-2) ...
    Setting up python-tornado (4.4.3-1) ...
    Setting up python-apt (1.1.0~beta5) ...
    Setting up salt-common (2016.11.2+ds-1+deb9u1) ...
    Setting up salt-minion (2016.11.2+ds-1+deb9u1) ...
    
    Configuration file '/etc/salt/minion'
     ==> File on system created by you or by a script.
     ==> File also in package provided by package maintainer.
       What would you like to do about it ?  Your options are:
        Y or I  : install the package maintainer's version
        N or O  : keep your currently-installed version
          D     : show the differences between the versions
          Z     : start a shell to examine the situation
     The default action is to keep your current version.
    *** minion (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing package salt-minion (--configure):
     end of file on stdin at conffile prompt
    Processing triggers for systemd (232-25+deb9u2) ...
    Errors were encountered while processing:
     salt-minion
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Synchronizing state of salt-minion.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable salt-minion
    


  • So uuidgen is missing.



  • @wls-itguy said in Installing the agent:

    Installing on home R-Pi machine. Not sure if something went wrong or not. Looked like it failed but I can't tell.

    What operating system? R-Pi is just the architecture.



  • @scottalanmiller Debian 9



  • @wls-itguy said in Installing the agent:

    @scottalanmiller Debian 9

    Ah, okay. That is a new combination. So Debian 9 on there is different than "normal" Debian 9. Might be a repo issue.



  • @scottalanmiller said in Installing the agent:

    @wls-itguy said in Installing the agent:

    @scottalanmiller Debian 9

    Ah, okay. That is a new combination. So Debian 9 on there is different than "normal" Debian 9. Might be a repo issue.

    It is checking in so not sure what the deal was.



  • @wls-itguy said in Installing the agent:

    @scottalanmiller said in Installing the agent:

    @wls-itguy said in Installing the agent:

    @scottalanmiller Debian 9

    Ah, okay. That is a new combination. So Debian 9 on there is different than "normal" Debian 9. Might be a repo issue.

    It is checking in so not sure what the deal was.

    Oh sure, the one thing that actually works, fails on the way to doing it. lol


Log in to reply